[PATCH] guix-install.sh: add ~/.guix-profile/share/info to INFOPATH

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Trevor Arjeski
Owner
unassigned
Submitted by
Trevor Arjeski
Severity
normal
T
T
Trevor Arjeski wrote on 6 May 08:00 +0200
(address . guix-patches@gnu.org)(name . Trevor Arjeski)(address . tmarjeski@gmail.com)
20240506060059.23158-1-tmarjeski@gmail.com
Adding ~/.guix-profile/share/info to the INFOPATH env var so that when a user
does `guix install [package]` that package's info pages can be found.
---
etc/guix-install.sh | 11 ++++++-----
1 file changed, 6 insertions(+), 5 deletions(-)

Toggle diff (31 lines)
diff --git a/etc/guix-install.sh b/etc/guix-install.sh
index 82accfd5d55..4e268a52d60 100755
--- a/etc/guix-install.sh
+++ b/etc/guix-install.sh
@@ -626,11 +626,6 @@ export XDG_CACHE_HOME="${XDG_CACHE_HOME:-$HOME/.cache}"
# _GUIX_PROFILE: `guix pull` profile
_GUIX_PROFILE="$HOME/.config/guix/current"
export PATH="$_GUIX_PROFILE/bin${PATH:+:}$PATH"
-# Export INFOPATH so that the updated info pages can be found
-# and read by both /usr/bin/info and/or $GUIX_PROFILE/bin/info
-# When INFOPATH is unset, add a trailing colon so that Emacs
-# searches 'Info-default-directory-list'.
-export INFOPATH="$_GUIX_PROFILE/share/info:$INFOPATH"
# GUIX_PROFILE: User's default profile and home profile
GUIX_PROFILE="$HOME/.guix-profile"
@@ -638,6 +633,12 @@ GUIX_PROFILE="$HOME/.guix-profile"
[ -L "$GUIX_PROFILE" ] && \
GUIX_LOCPATH="$GUIX_PROFILE/lib/locale${GUIX_LOCPATH:+:}$GUIX_LOCPATH"
+# Export INFOPATH so that the updated info pages can be found
+# and read by both /usr/bin/info and/or $GUIX_PROFILE/bin/info
+# When INFOPATH is unset, add a trailing colon so that Emacs
+# searches 'Info-default-directory-list'.
+export INFOPATH="$_GUIX_PROFILE/share/info:$GUIX_PROFILE/share/info:$INFOPATH"
+
GUIX_PROFILE="$HOME/.guix-home/profile"
[ -f "$GUIX_PROFILE/etc/profile" ] && . "$GUIX_PROFILE/etc/profile"
[ -L "$GUIX_PROFILE" ] && \
--
2.43.2
L
L
Ludovic Courtès wrote on 2 Jun 11:40 +0200
(name . Trevor Arjeski)(address . tmarjeski@gmail.com)(address . 70798-done@debbugs.gnu.org)
87ikyrn0mm.fsf@gnu.org
Hi,

Trevor Arjeski <tmarjeski@gmail.com> skribis:

Toggle quote (3 lines)
> Adding ~/.guix-profile/share/info to the INFOPATH env var so that when a user
> does `guix install [package]` that package's info pages can be found.

I tweaked the commit log and applied it, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70798@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70798
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch