[PATCH] gnu: kanshi: Update to 1.6.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Wilko Meyer
Owner
unassigned
Submitted by
Wilko Meyer
Severity
normal
W
W
Wilko Meyer wrote on 5 May 13:20 +0200
(address . guix-patches@gnu.org)(name . Wilko Meyer)(address . w@wmeyer.eu)
8943908fdb88c891c72c7ea86e535d666b833999.1714908054.git.w@wmeyer.eu
* gnu/packages/wm.scm (kanshi): Update to 1.6.0.

Change-Id: I2be95e7452f708c970f235a149695df69c22b33e
---
gnu/packages/wm.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index f2cb77f5bf..16e45a5504 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2350,7 +2350,7 @@ (define-public mako
(define-public kanshi
(package
(name "kanshi")
- (version "1.5.1")
+ (version "1.6.0")
(source
(origin
(method git-fetch)
@@ -2359,7 +2359,7 @@ (define-public kanshi
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1mc2zcqsv79y7682nwi1gn8p751zwflm9zirl98v2q2kvx334k8a"))))
+ (base32 "10ym28xkxbs6nkjk3clb680815606c42vagbshd9qs9cvc8zncra"))))
(build-system meson-build-system)
(inputs (list wayland))
(native-inputs (list pkg-config scdoc))

base-commit: da9f509b0300f1b6b979c68a52d8669f9bcb89a7
--
2.41.0
W
W
Wilko Meyer wrote on 10 May 14:24 +0200
[PATCH v2 1/2] gnu: kanshi: Update to 1.6.0.
(address . 70780@debbugs.gnu.org)(name . Wilko Meyer)(address . w@wmeyer.eu)
0690031a5d139f819ef74c35c8b3d7dbacf7f332.1715343899.git.w@wmeyer.eu
* gnu/packages/wm.scm (kanshi): Update to 1.6.0.
[native-inputs]: Add libscfg.

Change-Id: I2be95e7452f708c970f235a149695df69c22b33e
---
gnu/packages/wm.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index b5e9dca524..45d4427e51 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2303,7 +2303,7 @@ (define-public mako
(define-public kanshi
(package
(name "kanshi")
- (version "1.5.1")
+ (version "1.6.0")
(source
(origin
(method git-fetch)
@@ -2312,10 +2312,10 @@ (define-public kanshi
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1mc2zcqsv79y7682nwi1gn8p751zwflm9zirl98v2q2kvx334k8a"))))
+ (base32 "10ym28xkxbs6nkjk3clb680815606c42vagbshd9qs9cvc8zncra"))))
(build-system meson-build-system)
(inputs (list wayland))
- (native-inputs (list pkg-config scdoc))
+ (native-inputs (list pkg-config scdoc libscfg))
(home-page "https://wayland.emersion.fr/kanshi")
(synopsis "Hotswappable output profiles for Wayland")
(description "Kanshi allows you to define output profiles that are

base-commit: 65e8472a4b6fc6f66871ba0dad518b7d4c63595e
prerequisite-patch-id: 14a3699912e44b1691d1c6440a5b32dd1710c12f
prerequisite-patch-id: 04942fc34d1c5c6a9ce4ce6e05174e6549e91848
prerequisite-patch-id: a835acb4f4a9924b7b747c5ea4482657dc6b1e1c
prerequisite-patch-id: 90e83f7c3e2dec237c8906c32fe80dfb5b9e9ae7
prerequisite-patch-id: 23d3dd9849a2f28c229b8a611a1f8861528c04c9
prerequisite-patch-id: 4fd1c465e6bf5e606fc7bb1b9e00bf01053cc11e
prerequisite-patch-id: 5ea7d6802c4ef2abf7f12b7d61f3df3ba39f8989
prerequisite-patch-id: 7dc520c358c10211da55318e5a0c77d36f89eb8a
--
2.41.0
W
W
Wilko Meyer wrote on 10 May 14:25 +0200
[PATCH v2 2/2] gnu: Add libscfg.
(address . 70780@debbugs.gnu.org)(name . Wilko Meyer)(address . w@wmeyer.eu)
9889610f1c2bc612ef933164f3bf57ad4202aac3.1715343899.git.w@wmeyer.eu
* gnu/packages/serialization.scm (libscfg): New variable.
* gnu/packages/serialization.scm: Add copyright.

Change-Id: I0096745f2971799bd0c9955cddeed24f0846f075
---
gnu/packages/serialization.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index 331fae80cf..be1410255a 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2024 Paul A. Patience <paul@apatience.com>
;;; Copyright © 2024 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2024 Wilko Meyer <w@wmeyer.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -420,6 +421,25 @@ (define-public lua5.2-libmpack
(inputs
`(("lua" ,lua-5.2)))))
+(define-public libscfg
+ (package
+ (name "libscfg")
+ (version "0.1.1")
+ (home-page "https://git.sr.ht/~emersion/libscfg")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~emersion/libscfg")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1b1ps7wba4anm3x1yndnd730dwl6rdz3zwjgxmsyq31fnjrjydv9"))))
+ (build-system meson-build-system)
+ (synopsis "A C library for scfg")
+ (description "This package provides a C library for scfg.")
+ (license license:expat)))
+
(define-public libyaml
(package
(name "libyaml")
--
2.41.0
L
L
Ludovic Courtès wrote on 31 May 13:47 +0200
(name . Wilko Meyer)(address . w@wmeyer.eu)(address . 70780@debbugs.gnu.org)
878qzqtd7o.fsf@gnu.org
Hi,

Wilko Meyer <w@wmeyer.eu> skribis:

Toggle quote (3 lines)
> * gnu/packages/serialization.scm (libscfg): New variable.
> * gnu/packages/serialization.scm: Add copyright.

The second line is unnecessary.

Toggle quote (3 lines)
> + (synopsis "A C library for scfg")
> + (description "This package provides a C library for scfg.")

Please run ‘guix lint’ (it’ll complain about the synopsis) and check out
:-)

Could yoiu send updated patches addressing this? Also, please make sure
the libscfg patch comes first in the series.

Thanks in advance!

Ludo’.
W
W
Wilko Meyer wrote on 6 Jun 21:04 +0200
[PATCH v2 2/2] gnu: kanshi: Update to 1.6.0.
(address . 70780@debbugs.gnu.org)(name . Wilko Meyer)(address . w@wmeyer.eu)
20240606190502.28325-4-w@wmeyer.eu
* gnu/packages/wm.scm (kanshi): Update to 1.6.0.
[native-inputs]: Add libscfg.

Change-Id: I2be95e7452f708c970f235a149695df69c22b33e
---
gnu/packages/wm.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (28 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 316caf5fa5..05fbf897bc 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2357,7 +2357,7 @@ (define-public mako
(define-public kanshi
(package
(name "kanshi")
- (version "1.5.1")
+ (version "1.6.0")
(source
(origin
(method git-fetch)
@@ -2366,10 +2366,10 @@ (define-public kanshi
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1mc2zcqsv79y7682nwi1gn8p751zwflm9zirl98v2q2kvx334k8a"))))
+ (base32 "10ym28xkxbs6nkjk3clb680815606c42vagbshd9qs9cvc8zncra"))))
(build-system meson-build-system)
(inputs (list wayland))
- (native-inputs (list pkg-config scdoc))
+ (native-inputs (list pkg-config scdoc libscfg))
(home-page "https://wayland.emersion.fr/kanshi")
(synopsis "Hotswappable output profiles for Wayland")
(description "Kanshi allows you to define output profiles that are
--
2.41.0
W
W
Wilko Meyer wrote on 6 Jun 21:04 +0200
[PATCH v2 1/2] gnu: Add libscfg.
(address . 70780@debbugs.gnu.org)(name . Wilko Meyer)(address . w@wmeyer.eu)
20240606190502.28325-3-w@wmeyer.eu
* gnu/packages/serialization.scm (libscfg): New variable.

Change-Id: I0096745f2971799bd0c9955cddeed24f0846f075
---
gnu/packages/serialization.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/serialization.scm b/gnu/packages/serialization.scm
index 23959ebc4f..a72e7e4658 100644
--- a/gnu/packages/serialization.scm
+++ b/gnu/packages/serialization.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2024 Paul A. Patience <paul@apatience.com>
;;; Copyright © 2024 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2024 Wilko Meyer <w@wmeyer.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -420,6 +421,25 @@ (define-public lua5.2-libmpack
(inputs
`(("lua" ,lua-5.2)))))
+(define-public libscfg
+ (package
+ (name "libscfg")
+ (version "0.1.1")
+ (home-page "https://git.sr.ht/~emersion/libscfg")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~emersion/libscfg")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1b1ps7wba4anm3x1yndnd730dwl6rdz3zwjgxmsyq31fnjrjydv9"))))
+ (build-system meson-build-system)
+ (synopsis "Scfg library written in C")
+ (description "This package provides a C library for scfg.")
+ (license license:expat)))
+
(define-public libyaml
(package
(name "libyaml")
--
2.41.0
W
W
Wilko Meyer wrote on 6 Jun 21:10 +0200
Re: [bug#70780] [PATCH v2 2/2] gnu: Add libscfg.
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 70780@debbugs.gnu.org)
878qzhzy2o.fsf@wmeyer.eu
Hi Ludo,

Ludovic Courtès <ludo@gnu.org> writes:
Toggle quote (3 lines)
> Could yoiu send updated patches addressing this? Also, please make sure
> the libscfg patch comes first in the series.

I've send in a v2 addressing these things a few moments ago, thanks for
reviewing this patch series (hope I got everything right this time)!

--
Kind regards,

Wilko Meyer
w@wmeyer.eu
L
L
Ludovic Courtès wrote on 13 Jun 22:42 +0200
Re: [bug#70780] [PATCH v2 1/2] gnu: Add libscfg.
(name . Wilko Meyer)(address . w@wmeyer.eu)(address . 70780-done@debbugs.gnu.org)
877cesing1.fsf@gnu.org
Hi,

Wilko Meyer <w@wmeyer.eu> skribis:

Toggle quote (4 lines)
> * gnu/packages/serialization.scm (libscfg): New variable.
>
> Change-Id: I0096745f2971799bd0c9955cddeed24f0846f075

[...]

Toggle quote (2 lines)
> + (description "This package provides a C library for scfg.")

I tweaked this to clarify what “scfg” is.

Toggle quote (5 lines)
> * gnu/packages/wm.scm (kanshi): Update to 1.6.0.
> [native-inputs]: Add libscfg.
>
> Change-Id: I2be95e7452f708c970f235a149695df69c22b33e

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70780@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70780
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch