[PATCH] gnu: Add python-clintest.

  • Done
  • quality assurance status badge
Details
2 participants
  • Liliana Marie Prikler
  • Nicolas Graves
Owner
unassigned
Submitted by
Liliana Marie Prikler
Severity
normal
L
L
Liliana Marie Prikler wrote on 4 May 08:31 +0200
(address . guix-patches@gnu.org)
9a730ca2b2a4f5b64083da4f6985745ca29264ca.1714808929.git.liliana.prikler@gmail.com
* gnu/packages/potassco.scm (python-clintest): New variable.
---
gnu/packages/potassco.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/potassco.scm b/gnu/packages/potassco.scm
index 43d9ea6647..6a124c5bba 100644
--- a/gnu/packages/potassco.scm
+++ b/gnu/packages/potassco.scm
@@ -612,3 +612,27 @@ (define-public python-clinguin
(description "Clinguin is a graphical user interface toolkit for clingo,
which allows user interfaces to be specified entirely as a logic program.")
(license license:expat)))
+
+(define-public python-clintest
+ (package
+ (name "python-clintest")
+ (version "0.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/potassco/clintest")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0xzbby9ram55h87ykm652kgm45b8rlhbjc8gjkz308h1jnjllmmy"))))
+ (build-system pyproject-build-system)
+ (inputs (list python-clingo))
+ (home-page "https://potassco.org/clintest/")
+ (synopsis "Test framework for clingo programs")
+ (description "Clintest is a framework for unit testing clingo programs.
+It provides various components to assemble the most commonly used tests quickly,
+but also works fine along custom-built test. Clintest monitors the test
+outcome while solving to abort the search for solutions once the outcome is
+certain.")
+ (license license:expat)))

base-commit: 5c13ab50b9c7d44238c64e5337027f04ae1d9223
--
2.41.0
N
N
Nicolas Graves wrote on 13 May 09:10 +0200
87y18eb30i.fsf@ngraves.fr
On 2024-05-04 08:31, Liliana Marie Prikler wrote:

Toggle quote (30 lines)
> * gnu/packages/potassco.scm (python-clintest): New variable.
> ---
> gnu/packages/potassco.scm | 24 ++++++++++++++++++++++++
> 1 file changed, 24 insertions(+)
>
> diff --git a/gnu/packages/potassco.scm b/gnu/packages/potassco.scm
> index 43d9ea6647..6a124c5bba 100644
> --- a/gnu/packages/potassco.scm
> +++ b/gnu/packages/potassco.scm
> @@ -612,3 +612,27 @@ (define-public python-clinguin
> (description "Clinguin is a graphical user interface toolkit for clingo,
> which allows user interfaces to be specified entirely as a logic program.")
> (license license:expat)))
> +
> +(define-public python-clintest
> + (package
> + (name "python-clintest")
> + (version "0.2.0")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/potassco/clintest")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "0xzbby9ram55h87ykm652kgm45b8rlhbjc8gjkz308h1jnjllmmy"))))
> + (build-system pyproject-build-system)
> + (inputs (list python-clingo))

You can add (native-inputs (list python-pytest)) to enable tests
properly. There are quite some tests that are failing for some reason
(10/31), it's unclear why at first glance.

We probably should add this native-input and ignore failing tests.

Otherwise LGTM, builds properly.

Toggle quote (11 lines)
> + (synopsis "Test framework for clingo programs")
> + (description "Clintest is a framework for unit testing clingo programs.
> +It provides various components to assemble the most commonly used tests quickly,
> +but also works fine along custom-built test. Clintest monitors the test
> +outcome while solving to abort the search for solutions once the outcome is
> +certain.")
> + (license license:expat)))
>
> base-commit: 5c13ab50b9c7d44238c64e5337027f04ae1d9223

--
Best regards,
Nicolas Graves
L
L
Liliana Marie Prikler wrote on 14 May 07:49 +0200
d222ee0c72949eae018865fdffabe69a94034c1b.camel@gmail.com
Am Montag, dem 13.05.2024 um 09:10 +0200 schrieb Nicolas Graves:
Toggle quote (7 lines)
> You can add (native-inputs (list python-pytest)) to enable tests
> properly. There are quite some tests that are failing for some reason
> (10/31), it's unclear why at first glance.
>
> We probably should add this native-input and ignore failing tests.
>
> Otherwise LGTM, builds properly.
It appears to be a known issue from python-clingo already – we'll still
have to figure out the root cause for that as well. Added a fixme and
pushed.

Thanks
N
N
Nicolas Graves wrote on 14 May 22:19 +0200
control message for bug #70769
(address . control@debbugs.gnu.org)
874jb0p2mo.fsf@ngraves.fr
close 70769
quit


--
Best regards,
Nicolas Graves
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70769@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70769
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch