[PATCH] gnu: Add python-pyrodigal.

  • Done
  • quality assurance status badge
Details
2 participants
  • nafkhamdc
  • Ricardo Wurmus
Owner
unassigned
Submitted by
nafkhamdc
Severity
normal

Debbugs page

nafkhamdc wrote 10 months ago
(address . guix-patches@gnu.org)(name . nafkhamdc)(address . navid.afkhami@mdc-berlin.de)
076e35e70f743849d45c10197865b1d74d3f9978.1714729992.git.navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (python-pyrodigal): New variable.

Change-Id: Iaa0bdb4b918d93f990d5b904f1df3a3f910726b0
---
gnu/packages/bioinformatics.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b90a1c7824..bc10123a8f 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -17710,6 +17710,37 @@ (define-public python-pypairix
bgzipped text file that contains a pair of genomic coordinates per line.")
(license license:expat)))
+(define-public python-pyrodigal
+ (package
+ (name "python-pyrodigal")
+ (version "3.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/althonos/pyrodigal")
+ (commit (string-append "v" version))
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "10vxbm9i33wari0ifsr78xnfn7d0yqwzqpc5pchirjflf1mmnr6w"))))
+ (build-system pyproject-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion "/tmp"
+ (invoke "python3" "-m" "unittest" "discover" "-vv"))))))))
+ (propagated-inputs (list python-archspec python-importlib-resources))
+ (native-inputs (list python-cython-3 python-mock python-unittest2))
+ (home-page "https://github.com/althonos/pyrodigal")
+ (synopsis "Cython bindings and Python interface for Prodigal")
+ (description
+ "This package offers Cython bindings and a Python interface for Prodigal.
+ Prodigal is an ORF finder designed for both genomes and metagenomes.")
+ (license license:gpl3)))
+
(define-public python-pyfaidx
(package
(name "python-pyfaidx")

base-commit: aa9ac252206615713ab988d7068da9e14a9bccc0
prerequisite-patch-id: 68498b47732fb0359e4db6d2f1c86f44d8c700ab
prerequisite-patch-id: 8cad86329867720ca9938e551ece489b056b37ad
--
2.34.1
Ricardo Wurmus wrote 10 months ago
(address . 70731-done@debbugs.gnu.org)
87ttjbjj7q.fsf@elephly.net
Thanks for the patch. I changed it to actually run the tests and pushed
it to the "master" branch.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70731@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70731
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help