[PATCH] gnu: Add r-memes.

  • Done
  • quality assurance status badge
Details
2 participants
  • nafkhamdc
  • Ricardo Wurmus
Owner
unassigned
Submitted by
nafkhamdc
Severity
normal

Debbugs page

nafkhamdc wrote 10 months ago
(address . guix-patches@gnu.org)(name . nafkhamdc)(address . navid.afkhami@mdc-berlin.de)
e1d0a4e94c61abfc61fa8b6485c6cca609d6e2e2.1714727972.git.navid.afkhami@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-memes): New variable.

Change-Id: Ibdf5173d35ef81d27da6831148e66be83f856deb
---
gnu/packages/bioconductor.scm | 47 +++++++++++++++++++++++++++++++++++
1 file changed, 47 insertions(+)

Toggle diff (62 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 0fca094977..5029afbefa 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2092,6 +2092,53 @@ (define-public r-macrophage
in Nature Genetics, January 2018.")
(license license:gpl2+)))
+(define-public r-memes
+ (let ((commit "55f0df1fe65c8ead5252542fdc0da0ff2339049e")
+ (revision "1"))
+ (package
+ (name "r-memes")
+ (version (git-version "1.11.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/snystrom/memes")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0mp3a610v293prmyid3w1w8fkjkppjnim60h7p9vz2884d0wdvk4"))))
+ (properties `((upstream-name . "memes")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-biostrings
+ r-cmdfun
+ r-dplyr
+ r-genomicranges
+ r-ggplot2
+ r-ggseqlogo
+ r-magrittr
+ r-matrixstats
+ r-patchwork
+ r-processx
+ r-purrr
+ r-readr
+ r-rlang
+ r-tibble
+ r-tidyr
+ r-universalmotif
+ r-usethis
+ r-xml2))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/snystrom/memes")
+ (synopsis
+ "Motif matching, comparison, and de novo discovery using the MEME Suite")
+ (description
+ "This package facilitates motif analysis using MEME Suite tools.
+Memes provides data aware utilities for using GRanges objects as
+entrypoints to motifanalysis, data structures for examining & editing
+motif lists, and novel data visualizations. Memes functions and data
+structures are amenable to both base R and tidyverse workflows.")
+ (license license:expat))))
+
(define-public r-methylclockdata
(package
(name "r-methylclockdata")

base-commit: aa9ac252206615713ab988d7068da9e14a9bccc0
--
2.34.1
Ricardo Wurmus wrote 10 months ago
gnu: Add r-memes.
(address . 70730-done@debbugs.gnu.org)
87msp3lxqe.fsf@elephly.net
Applied, thank you!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70730@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70730
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help