[PATCH] gnu: hyperrogue: correct font path

  • Open
  • quality assurance status badge
Details
One participant
  • Tadhg McDonald-Jensen
Owner
unassigned
Submitted by
Tadhg McDonald-Jensen
Severity
normal
T
T
Tadhg McDonald-Jensen wrote on 2 May 02:52 +0200
(address . guix-patches@gnu.org)
ad2f4dfd-4264-8650-836c-810eb6fcc116@gmail.com
* gnu/packages/games.scm (hyperrogue):
correct font path to use font-dejavu package instead of
font in hyperrogue source code.

Change-Id: I12a108e3fc2375d9bacd1ab1d2ad4e15144b602f
---
gnu/packages/games.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (21 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 57e6c23f41..0ebe18c4be 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -6473,9 +6473,9 @@ (define-public hyperrogue
(replace 'configure
(lambda* (#:key inputs #:allow-other-keys)
(let ((share-dir (string-append #$output
"/share/hyperrogue/"))
- (fonts-dir (dirname
- (search-input-file inputs
-
"DejaVuSans-Bold.ttf"))))
+ (fonts-dir (string-append
+ (assoc-ref inputs "font-dejavu")
+ "/share/fonts/truetype")))
;; Set fonts and music path.
(substitute* "sysconfig.h"
(("(#define HYPERPATH ).*" _ lead)

base-commit: 4514239971895fc7ad47c7752e30d98a0c44a154
--
2.41.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 70708@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70708
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch