(address . guix-patches@gnu.org)
As I'm seeing this test fail with results of 5 to 7 seconds.
* gnu/packages/nss.scm (nss/fixed)[arguments]: Tweak a test to have a higher
time threshold.
Change-Id: Icb0551cd986acf67b2ba17dc8772a67b9747d31a
---
gnu/packages/nss.scm | 8 ++++++++
1 file changed, 8 insertions(+)
Toggle diff (23 lines)
diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
index 162e748094..60bc4d52de 100644
--- a/gnu/packages/nss.scm
+++ b/gnu/packages/nss.scm
@@ -280,6 +280,14 @@ (define-public nss/fixed
(setenv "USE_IP" "TRUE")
(setenv "IP_ADDRESS" "127.0.0.1")
+ ;; This specific test is looking at performance "now
+ ;; verify that we can quickly dump a database", and
+ ;; we're not testing performance here (especially
+ ;; since we're using faketime), so raise the
+ ;; threshold
+ (substitute* "tests/dbtests/dbtests.sh"
+ ((" -lt 5") " -lt 50"))
+
;; The "PayPalEE.cert" certificate expires every six months,
;; leading to test failures:
;; <https://bugzilla.mozilla.org/show_bug.cgi?id=609734>. To
base-commit: 7d4ae2fca723114fb1df56de33b82177fbc4d0a6
--
2.41.0