[PATCH 1/1] * gnu/packages/golang.scm (go-1.22): Disable flakey tests.

  • Done
  • quality assurance status badge
Details
2 participants
  • Katherine Cox-Buday
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Katherine Cox-Buday
Severity
normal
K
K
Katherine Cox-Buday wrote on 30 Apr 19:54 +0200
(address . guix-patches@gnu.org)(name . Katherine Cox-Buday)(address . cox.katherine.e@gmail.com)
20240430175415.61463-1-cox.katherine.e@gmail.com
---
gnu/packages/golang.scm | 10 ++++++++--
1 file changed, 8 insertions(+), 2 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4ce6f5ea6b..99d83dd104 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -12,7 +12,7 @@
;;; Copyright © 2018 Tomáš ?ech <sleep_walker@gnu.org>
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
-;;; Copyright © 2018, 2019, 2020, 2023 Katherine Cox-Buday <cox.katherine.e@gmail.com>
+;;; Copyright © 2018, 2019, 2020, 2023, 2024 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;; Copyright © 2019 Giovanni Biscuolo <g@xelera.eu>
;;; Copyright © 2019, 2020 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2019, 2020, 2021 Arun Isaac <arunisaac@systemreboot.net>
@@ -971,7 +971,13 @@ (define-public go-1.22
;; to perl input in sourcecode generators and test scripts
(substitute* (find-files "src" "\\.pl$")
(("^#!.*")
- "#!/usr/bin/env perl\n"))))))))
+ "#!/usr/bin/env perl\n"))))
+ (add-after 'unpack 'remove-flakey-thread-sanitizer-tests
+ (lambda _
+ ;; These tests have been identified as flakey:
+ ;; https://github.com/golang/go/issues/66427
+ (substitute* "src/cmd/cgo/internal/testsanitizers/tsan_test.go"
+ ((".*tsan1[34].*") ""))))))))
(native-inputs
;; Go 1.22 and later requires Go 1.20 (min. 1.20.6, which we don't have)
;; as the bootstrap toolchain.

base-commit: 8dab3df9529387ec1459d5483ac9664969c52e78
--
2.41.0
S
S
Sharlatan Hellseher wrote on 14 May 12:50 +0200
[PATCH 1/1] * gnu/packages/golang.scm (go-1.22): Disable flakey tests.
(address . 70680-done@debbugs.gnu.org)
878r0cllav.fsf@gmail.com
Pushed as 6fab2d5b318fb0a8a0887f6ce0ac3e342a8c23ef to go-team.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmZDQegACgkQdtcnv/Ys
0rVRJw//c/Wu4TqYG6HGwr2NqbIc9jdcZEK66ASDSS+qkHwVh7BC7/UjOBeLOpqi
2n2cV/3u97ulP0vOEGYOnnBDtspaEAZ4u26wW6nxIiAJSKY6T494dRhLxgWwkDNl
YCfFXN3glIH08kL2JbgA1m0VV6rU8QNQDFvZGVIyONboHZOS5E5beyZgEUSR23xZ
sNcLkMXKNw90BDjqM/olcwaLa6SZhuqpLU2NXRAkJLdHheJ/pVHXvPIVm0bwGrFQ
HPQb8Bh0rhZlvTA19HZeMCXGPiUtZyKX4kseMGsTkmw6IJJIh5hP7p9U06z3ns2V
0ZYdsD+NDsqtX0MM12W1VJjF1osuFvtmMRf9V+qVfrae5h5FfdcI2D3yGfZJWeiN
/T9dEgoZBIna/Cl8ELKyvnG8b6+GmpV5UJ38UFwQre8DPWyFHIiZvkcMXeAfxxs3
KySQYC6avwXGYHNRBxrFnHJZ6kUpSvldD8bQlHDYZK+LemNvn27O5ObgOkAK1AR8
XW6n07J/D9JAsTmKPkGDXCuSqRO3WN9wuLNTXUy7pxjfE86c7yHEX47gcnu19TdG
vyw+5pOKLZNYPVxRUe4+XxHybOsCdoMtXiFKaaMEcgsIZ6qdU1FDrns9acHChaf0
VgLT/lOgi/CD2uZ46Ie1Nm2hs82c1RMi4HxrpqBF3RZNpEG1qk0=
=cFEL
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70680@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70680
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch