[PATCH] gnu: Add rust-new-string-template-1.

  • Open
  • quality assurance status badge
Details
One participant
  • Halux Luxeay
Owner
unassigned
Submitted by
Halux Luxeay
Severity
normal
H
H
Halux Luxeay wrote on 30 Apr 15:52 +0200
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
2C5KkzKtxeWuFs443PlkXyTJKm14XNSc3Wr09vOcC2aU5_jxSOXJq_dctnR3wxAEFmFkgtt17FIFzMrhI_yiGTcg2JQ9BueuZx_2jjaYnZI=@proton.me
* gnu/packages/crates-io.scm (rust-new-string-template-1): New variable.

Change-Id: I262d62b6725e644e977df9446a52815c091b25b7
---
gnu/packages/crates-io.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a67d3d74bb..80210de2c4 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -40550,6 +40550,26 @@ (define-public rust-new-debug-unreachable-1
release (fork of debug_unreachable)")
(license license:expat)))

+(define-public rust-new-string-template-1
+ (package
+ (name "rust-new-string-template")
+ (version "1.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "new_string_template" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0bng7844dshccq2mf439khpscy76ay62p13pmq06gkcr6yhz6h5f"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-lazy-static" ,rust-lazy-static-1)
+ ("rust-regex" ,rust-regex-1))))
+ (home-page "https://github.com/hasezoey/new_string_template")
+ (synopsis "Simple Customizable String-Templating Library for Rust")
+ (description "Simple Customizable String-Templating Library for Rust")
+ (license license:expat)))
+
;; Keep this package for future packaging of NewsFlash.
(define-public rust-news-flash-1
(package

base-commit: 8d29f416a9378d30f63c2a95f1bd1a420d9ccab4
--
2.39.2
Attachment: file
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 70676@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70676
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch