[PATCH] gnu: cmake: Update to 3.29.2.

  • Done
  • quality assurance status badge
Details
2 participants
  • Daniel Ziltener
  • John Kehayias
Owner
unassigned
Submitted by
Daniel Ziltener
Severity
normal
D
D
Daniel Ziltener wrote on 30 Apr 16:52 +0200
(address . guix-patches@gnu.org)
b8a8b57f-7897-9f52-8877-bf17a294b083@lyrion.ch
---
gnu/packages/cmake.scm | 26 +++++++++-----------------
1 file changed, 9 insertions(+), 17 deletions(-)

Toggle diff (61 lines)
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 0c780fe420..d9cf9851e1 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -347,24 +347,17 @@ (define preserved-files
',%preserved-third-party-files)
(define-public cmake
(package
(inherit cmake-minimal)
+ (version "3.29.2")
(name "cmake")
- (version "3.25.1")
(source (origin
- (inherit (package-source cmake-minimal))
- (method url-fetch)
- (uri (string-append "https://cmake.org/files/v"
- (version-major+minor version)
- "/cmake-" version ".tar.gz"))
- (snippet (match (origin-snippet (package-source cmake-minimal))
- (('begin ('define 'preserved-files ('quote x))
- rest ...)
- `(begin (define preserved-files
- ',(cons "Utilities/cmelf" x))
- ,@rest))))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.kitware.com/cmake/cmake")
+ (commit (string-append "v" version))
+ (recursive? #t)))
(sha256
(base32
- "1n4inb3fvk70sni5gmkljqw3cyllalyg3fnr9rlr7x3aa44isl8w"))
- (patches (search-patches "cmake-curl-certificates-3.24.patch"))))
+ "0yjk4kqrln8smz457dxansfl69zyikr5015xm23xa4g7x1rihkgg"))))
(outputs '("out" "doc"))
(arguments
(substitute-keyword-arguments (package-arguments cmake-minimal)
@@ -373,10 +366,8 @@ (define-public cmake
(if (%current-target-system)
cmake-minimal-cross
cmake-minimal))
-
;; Enable debugging information for convenience.
((#:build-type _ #f) "RelWithDebInfo")
-
((#:configure-flags flags ''())
#~(append (list "-DSPHINX_INFO=ON" "-DSPHINX_MAN=ON" "-DSPHINX_HTML=ON"
(string-append "-DCMAKE_DOC_DIR=share/doc/cmake-"
@@ -401,7 +392,8 @@ (define-public cmake
(delete-file-recursively (string-append #$output html)))))))))
(inputs
(modify-inputs (package-inputs cmake-minimal)
- (prepend ncurses))) ;required for ccmake
+ (prepend ncurses) ;required for ccmake
+ (prepend cppdap)))
;; Extra inputs required to build the documentation.
(native-inputs
(modify-inputs (package-native-inputs cmake-minimal)

--
2.41.0
J
J
John Kehayias wrote on 12 Sep 21:20 +0200
(name . Daniel Ziltener)(address . dziltener@lyrion.ch)(address . 70675-done@debbugs.gnu.org)
87v7z0smpv.fsf@protonmail.com
Hello,

On Tue, Apr 30, 2024 at 04:52 PM, Daniel Ziltener wrote:

Toggle quote (5 lines)
> ---
> gnu/packages/cmake.scm | 26 +++++++++-----------------
> 1 file changed, 9 insertions(+), 17 deletions(-)
>

Looks like the below patch had all formatting (spacing) removed. Thank
you for the submission though! I have submitted a newer cmake version
(without updating the default yet) to

Closing this one, but feel free to reopen with a properly formatted
patch to add this specific version of cmake, if that's what you intended.

John

Toggle quote (58 lines)
> diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
> index 0c780fe420..d9cf9851e1 100644
> --- a/gnu/packages/cmake.scm
> +++ b/gnu/packages/cmake.scm
> @@ -347,24 +347,17 @@ (define preserved-files
> ',%preserved-third-party-files)
> (define-public cmake
> (package
> (inherit cmake-minimal)
> + (version "3.29.2")
> (name "cmake")
> - (version "3.25.1")
> (source (origin
> - (inherit (package-source cmake-minimal))
> - (method url-fetch)
> - (uri (string-append "https://cmake.org/files/v"
> - (version-major+minor version)
> - "/cmake-" version ".tar.gz"))
> - (snippet (match (origin-snippet (package-source cmake-minimal))
> - (('begin ('define 'preserved-files ('quote x))
> - rest ...)
> - `(begin (define preserved-files
> - ',(cons "Utilities/cmelf" x))
> - ,@rest))))
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://gitlab.kitware.com/cmake/cmake")
> + (commit (string-append "v" version))
> + (recursive? #t)))
> (sha256
> (base32
> - "1n4inb3fvk70sni5gmkljqw3cyllalyg3fnr9rlr7x3aa44isl8w"))
> - (patches (search-patches "cmake-curl-certificates-3.24.patch"))))
> + "0yjk4kqrln8smz457dxansfl69zyikr5015xm23xa4g7x1rihkgg"))))
> (outputs '("out" "doc"))
> (arguments
> (substitute-keyword-arguments (package-arguments cmake-minimal)
> @@ -373,10 +366,8 @@ (define-public cmake
> (if (%current-target-system)
> cmake-minimal-cross
> cmake-minimal))
> -
> ;; Enable debugging information for convenience.
> ((#:build-type _ #f) "RelWithDebInfo")
> -
> ((#:configure-flags flags ''())
> #~(append (list "-DSPHINX_INFO=ON" "-DSPHINX_MAN=ON" "-DSPHINX_HTML=ON"
> (string-append "-DCMAKE_DOC_DIR=share/doc/cmake-"
> @@ -401,7 +392,8 @@ (define-public cmake
> (delete-file-recursively (string-append #$output html)))))))))
> (inputs
> (modify-inputs (package-inputs cmake-minimal)
> - (prepend ncurses))) ;required for ccmake
> + (prepend ncurses) ;required for ccmake
> + (prepend cppdap)))
> ;; Extra inputs required to build the documentation.
> (native-inputs
> (modify-inputs (package-native-inputs cmake-minimal)
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70675@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70675
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch