[PATCH] gnu: Add python-archspec.

  • Done
  • quality assurance status badge
Details
2 participants
  • nafkhamdc
  • Ricardo Wurmus
Owner
unassigned
Submitted by
nafkhamdc
Severity
normal

Debbugs page

nafkhamdc wrote 10 months ago
(address . guix-patches@gnu.org)(name . nafkhamdc)(address . navid.afkhami@mdc-berlin.de)
0c93cb41c25fe436646a1cb8db09d248fee5dc49.1714485972.git.navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (python-archspec): New variable.

Change-Id: Icb15a681d7f339ab25cb0a91feeaacc6a3e8cd6a
---
gnu/packages/bioinformatics.scm | 50 +++++++++++++++++++++++++++++++++
1 file changed, 50 insertions(+)

Toggle diff (65 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index aa6bce5591..437371bf89 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -19504,6 +19504,56 @@ (define-public python-arboreto
tree-based ensemble regressors.")
(license license:bsd-3)))
+(define-public python-archspec
+ (package
+ (name "python-archspec")
+ (version "0.2.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/archspec/archspec")
+ (commit (string-append "v" version))
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03yfn4b9xg41pd7vls2cils77wkkb9si1h2qqvnkds661fdankqj"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases '(modify-phases %standard-phases
+ ;; Numba needs a writable dir to cache functions.
+ (add-before 'build 'set-numba-cache-dir
+ (lambda _
+ (setenv "NUMBA_CACHE_DIR" "/tmp"))))))
+ (propagated-inputs (list python-boltons
+ python-cooler
+ python-ctxcore
+ python-interlap
+ python-intervaltree
+ python-jsonschema
+ python-networkx
+ python-numba
+ python-poetry-core
+ pyscenic
+ python-scikit-learn
+ python-tables
+ python-typing-extensions))
+ (native-inputs (list python-black
+ python-flake8
+ python-isort
+ python-poetry-core
+ python-pylint
+ python-pytest
+ python-pytest-cov))
+ (home-page "https://github.com/archspec/archspec")
+ (synopsis "Library to query system architecture")
+ (description
+ "Archspec offers human-readable labels for system architecture aspects.
+These aspects include CPU, network fabrics, etc. In addition, it offers
+APIs to detect, query, and compare them.")
+ (license license:expat)))
+
(define-public pyscenic
;; Latest commit from the update-pyarrow branch
(let ((commit "5f170fdf474548c37ab381d1849c662820d658ee")

base-commit: df3d30819e650a490ef39dd6692740bb13263c75
--
2.34.1
Ricardo Wurmus wrote 10 months ago
(address . 70673-done@debbugs.gnu.org)
87pltzjj6j.fsf@elephly.net
Applied, but moved to a different location because it is unrelated to
bioinformatics.

Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70673@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70673
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help