[core-updates] Fix python package idle output

  • Open
  • quality assurance status badge
Details
2 participants
  • Jean-Baptiste Note
  • Christopher Baines
Owner
unassigned
Submitted by
Jean-Baptiste Note
Severity
normal
J
J
Jean-Baptiste Note wrote on 30 Apr 15:41 +0200
["PATCH core-updates" 0/1] Fix python package idle output
(address . guix-patches@gnu.org)(name . Jean-Baptiste Note)(address . jean-baptiste.note@m4x.org)
cover.1714483770.git.jean-baptiste.note@m4x.org
idle has been split from python and python2 packages to their own python:idle
and python2:idle outputs. Unfortunately however, the idlelib directory is not
installed properly to be picked up by GUIX_PYTHONPATH. I don't care much for
python idle, but is used by several good kid's boot about programming, so it's
probably better to have it working.

Please note that even then, python:idle requires pythonX:tk to be installed in
order to be able to run properly.

Jean-Baptiste Note (1):
gnu: python: Fix python's idle installation.

gnu/packages/python.scm | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)


--
2.41.0
J
J
Jean-Baptiste Note wrote on 30 Apr 15:44 +0200
["PATCH core-updates" 1/1] gnu: python: Fix python's idle installation.
(address . 70672@debbugs.gnu.org)(name . Jean-Baptiste Note)(address . jean-baptiste.note@m4x.org)
5f443c4e6f3ce7a489a8ab71e5d65b1fe7dd68c8.1714483770.git.jean-baptiste.note@m4x.org
* gnu/packages/python.scm (python-2.7): Fix idle output for python-2.7.
---
gnu/packages/python.scm | 7 +++++--
1 file changed, 5 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b2757c651e..b41e75ed45 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -345,12 +345,15 @@ (define-public python-2.7
(install-file file (dirname target))
(delete-file file)))
(find-files (string-append out "/bin") "^idle"))
+ ;; The idlelib directory is in OUT/lib/pythonX.Y, but we
+ ;; want it under IDLE/lib/pythonX.Y/site-packages.
(match (find-files out "^idlelib$" #:directories? #t)
((idlelib)
(let* ((len (string-length out))
(target (string-append idle "/"
- (string-drop idlelib len)
- "/site-packages")))
+ (string-drop
+ (dirname idlelib) len)
+ "/site-packages/idlelib")))
(mkdir-p (dirname target))
(rename-file idlelib target))))))))
(add-after 'move-idle 'rebuild-bytecode
--
2.41.0
C
C
Christopher Baines wrote on 14 May 18:15 +0200
(no subject)
(address . control@debbugs.gnu.org)
878r0cxtd3.fsf@cbaines.net
retitle 70672 [core-updates] Fix python package idle output
thanks
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmZDjhhfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XcISBAAr5/8Wiq5h7rH+5hHU/2WAdKqMnUV66la
XWhjqNXcv+MSs8z7kwyIxCI+eMWUE/Fgqqg9Vp7TUx/go3xlxUjgaEt3etFqynk6
UE3FEZ5BBl61CpxE4DBnThtlXwzeTnnKuoCuOsH3r4H+EvJhyj6GhXFbgwiPB5wL
KOqtmB16/qhFgoP/MnxO7T+QMd9wdrewiG+Zsm9bpbmnbDehKKOroxVhMosj7/br
bWYPlvnCZnC7Zzr9MeTiEbnU2+pyHlAl15tpFg2+ToW2BcARHz7tQdhSDrANwcVj
hi+jL9k5oTcYquxlWYXwSR2mZknYF8vN+2RR25tbf9UJje4ERf0quWMbkDD+30Rs
MaZdusxI9PUeOrjRzw4amrnCPGKQljIS51a913g9NB+YRqc7LqBac5L6AnkA8bmY
1YvU4UKjOB0125ng92uN0ceZcfmDQBuc657B3HPFDQ0g7HyJPyTlXUPjC1aqySoA
i3jxMGqCimYtf7eqBtan3S1CURczMiSR6cGwC/Jzp39qcY698BKMZfOZK+ldhQRz
vL/fEK/GHUJPq5Ao0zCuihzYSEK4x47HkFk2NWOADmvAjcD+sLaGNTcd5zE3/82n
p0eZ0HKlLuKSfZlBJBkOTPX+Ge7umy5FSQ3SamPc9F/hms9NBAYmDo9BzUozM21d
Cb+mEWzfPxI=
=yf1U
-----END PGP SIGNATURE-----

?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 70672@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70672
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch