[PATCH 0/2] Update haxe and hashlink

  • Done
  • quality assurance status badge
Details
4 participants
  • John Kehayias
  • Maxim Cournoyer
  • vasilii.smirnov
  • Zheng Junjie
Owner
unassigned
Submitted by
vasilii.smirnov
Severity
normal
V
V
vasilii.smirnov wrote on 27 Apr 22:08 +0200
[PATCH 0/2] Update haxe and hashlink
(address . guix-patches@gnu.org)
cover.1714247880.git.vasilii.smirnov@mailbox.org
From: Vasilii Smirnov <vasilii.smirnov@mailbox.org>

The current version of Haxe in Guix isn't able to compile Heaps
2.0.0 :(. And also there is a new hlsdl version up on haxelib,
that requires a more recent hashlink. So, here are the updated
versions that can compile and run the latest Heaps.

Vasilii Smirnov (2):
gnu: haxe: Update to 4.3.4
gnu: hashlink: Update to 1.14

gnu/packages/haxe.scm | 19 ++++++++++---------
gnu/packages/ocaml.scm | 4 ++--
2 files changed, 12 insertions(+), 11 deletions(-)


base-commit: 8d29f416a9378d30f63c2a95f1bd1a420d9ccab4
--
2.41.0
V
V
vasilii.smirnov wrote on 28 Apr 09:27 +0200
[PATCH 1/2] gnu: haxe: Update to 4.3.4
(address . 70615@debbugs.gnu.org)(name . Vasilii Smirnov)(address . vasilii.smirnov@mailbox.org)
0d499fddb399aba00e996ba37b0e9519cdcec610.1714247880.git.vasilii.smirnov@mailbox.org
From: Vasilii Smirnov <vasilii.smirnov@mailbox.org>

Note that the ocaml-luv library has made a few breaking changes, while
only updating the PATCH number in their version. As of now, haxe can
only be compiled with the 0.5.12 version of ocaml-luv - no lower, no
higher.

Change-Id: I465191aa8db806275b2385d11a602dfb0d8d4bb9
---
gnu/packages/haxe.scm | 11 ++++++-----
gnu/packages/ocaml.scm | 4 ++--
2 files changed, 8 insertions(+), 7 deletions(-)

Toggle diff (73 lines)
diff --git a/gnu/packages/haxe.scm b/gnu/packages/haxe.scm
index 859941df70..6fd108abd5 100644
--- a/gnu/packages/haxe.scm
+++ b/gnu/packages/haxe.scm
@@ -115,17 +115,17 @@ (define haxelib-src
(uri (git-reference
(url "https://github.com/HaxeFoundation/haxelib")
;; This should match the haxelib submodule in haxe.
- (commit "4b27f91d8a4ff279d9903091680fee2c93a0d574")
+ (commit "f17fffa97554b1bdba37750e3418051f017a5bc2")
;; This repo includes some Haxe libs as well.
(recursive? #t)))
(sha256
(base32
- "0mwrm6gxgclwziiprfiswmjbz6z3dnvdwl8gq3gaym18pvx4p3ny"))))
+ "13ql042mxkybhw7di8c8cfq47p8snvadg9yglyif6b5k9ij85r6z"))))
(define-public haxe
(package
(name "haxe")
- (version "4.2.5")
+ (version "4.3.4")
(source
(origin
(method git-fetch)
@@ -134,7 +134,7 @@ (define-public haxe
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0pl8vpyb7gl2yqjg85yc4zxq9c3ipvw4yrrpliaxs25ynrj3l51n"))))
+ (base32 "1svbxf5g6j7vvqhyjlv1ha9yjh42c94jxvn7xhqbb0smyk64vibm"))))
(build-system dune-build-system)
(arguments
(list #:phases
@@ -173,13 +173,14 @@ (define-public haxe
(inputs (list libuv
mbedtls-lts
neko
+ ocaml-camlp-streams
ocaml-extlib
ocaml-luv
ocaml-ptmap
ocaml-sedlex
ocaml-sha
ocaml-xml-light
- pcre
+ pcre2
zlib))
(native-inputs (list ocaml-findlib camlp5))
(home-page "https://haxe.org/")
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 7fad276b4e..3bd923f97d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3464,14 +3464,14 @@ (define-public ocaml-bheap
(define-public ocaml-luv
(package
(name "ocaml-luv")
- (version "0.5.11")
+ (version "0.5.12")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/aantron/luv/releases/download/"
version "/luv-" version ".tar.gz"))
(sha256
(base32
- "0hrsi8n2l31bcwgj847df4chjgqb9lmwkaky8fvvi15k25rz9v6c"))
+ "1h2n9iij4mh60sy3g437p1xwqyqpyw72fgh4417d8j9ahq46m7vn"))
(modules '((guix build utils)))
(snippet
'(begin
--
2.41.0
V
V
vasilii.smirnov wrote on 28 Apr 09:27 +0200
[PATCH 2/2] gnu: hashlink: Update to 1.14
(address . 70615@debbugs.gnu.org)(name . Vasilii Smirnov)(address . vasilii.smirnov@mailbox.org)
1e627cc57385e1cfd73de39ff5a00b357d505963.1714247880.git.vasilii.smirnov@mailbox.org
From: Vasilii Smirnov <vasilii.smirnov@mailbox.org>

Change-Id: I1fe593cc03675cce81f70efb2576ff7bcd374187
---
gnu/packages/haxe.scm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/haxe.scm b/gnu/packages/haxe.scm
index 6fd108abd5..c7af07325f 100644
--- a/gnu/packages/haxe.scm
+++ b/gnu/packages/haxe.scm
@@ -196,7 +196,7 @@ (define-public haxe
(define-public hashlink
(package
(name "hashlink")
- (version "1.12")
+ (version "1.14")
(source
(origin
(method git-fetch)
@@ -205,7 +205,7 @@ (define-public hashlink
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0i5f1mxpgjcdirx60kxrw0r0y15qh3j16a6fj8mzkq3k7j2hc982"))
+ (base32 "163kj2fww8a1hp93aklla181sp84hrsl8dy5rwrv79057bmkjz5d"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -233,7 +233,7 @@ (define-public hashlink
(lambda _
(substitute* "Makefile"
(("\\$\\{PCRE\\}") "")
- (("-lpthread") "-lpthread -lpcre16")
+ (("-lpthread") "-lpthread -lpcre2-16")
(("include/minimp3")
(string-append #$(this-package-input "minimp3") "/include"))
(("include/mikktspace ")
@@ -260,7 +260,7 @@ (define-public hashlink
mikktspace
minimp3
openal
- pcre
+ pcre2
sdl2
sqlite
zlib))
--
2.41.0
Z
Z
Zheng Junjie wrote on 28 Apr 09:35 +0200
Re: [bug#70615] [PATCH 0/2] Update haxe and hashlink
(name . vasilii.smirnov--- via Guix-patches via)(address . guix-patches@gnu.org)
87jzkindn6.fsf@iscas.ac.cn
"vasilii.smirnov--- via Guix-patches" via <guix-patches@gnu.org> writes:

Toggle quote (18 lines)
> From: Vasilii Smirnov <vasilii.smirnov@mailbox.org>
>
> The current version of Haxe in Guix isn't able to compile Heaps
> 2.0.0 :(. And also there is a new hlsdl version up on haxelib,
> that requires a more recent hashlink. So, here are the updated
> versions that can compile and run the latest Heaps.
>
> Vasilii Smirnov (2):
> gnu: haxe: Update to 4.3.4
> gnu: hashlink: Update to 1.14
>
> gnu/packages/haxe.scm | 19 ++++++++++---------
> gnu/packages/ocaml.scm | 4 ++--
> 2 files changed, 12 insertions(+), 11 deletions(-)
>
>
> base-commit: 8d29f416a9378d30f63c2a95f1bd1a420d9ccab4

I didn't see the patch. Did you forget to send them?
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmYt/C0ACgkQO1qpk+Gi
3/BJvg//Wsrz8YtgHHWjR/djv7kAo/ST2YIbRuQJ749WniUIqO9xXLJApAtZA2Lz
KqtuaABOVpOkOy4LKTblUYuslTyGAe8IWfrrJ32r5Sq0H1e30s9KdnyjXSNg4DDe
RcVjQgXhyw/CRHSJI02uGe5sb7KfBclGEKJ18NS5vmixfCWdfp5AyC0+U1kWmsG5
ASfOZaHFrLXiNZk+gYgxMLBsdDZ0ycK9Q4gEBhu3NVnpYU8I94a5MaUbdDgzT1aJ
xD8f70OO4EHZBjxZYJW8hTJ0IwcduCkX+upJaOYC4GJww5V1oZBx6QouI19OBBKm
O5+rIYUjknBT6Ywb6jizgDkgzRnKUTRpS5EB2IVfubdZ+9qjqHC+lDMt632NcMRm
AY2QJ1OxF5oEOclb3ZJJGJ8xNYaqtnVr8f1BErYTukQbkN9oF7vFdcShOYz7Onjn
Sh6ClxfmnLYaSv2btrXbAVgcMM08TGOWIQbaEa/yfb6j+mIbvT0dCkLFIyZxzzze
AhRzKQ2xmb9T8z+Ocrg+13nPdfsSygGl94cls8yyq9XE9m9Wpn73De/7YxFy9gFe
sYK4SSgaP+oh2afJ1EnZwa7qA5ccNeFyBsmAQQGj+HWDAv00xZaXQTPfi25mHsY6
Lq6IZ+Ok16rMWVnVaH+qiHKeNVZQxUuHvAItLUtfILmIEDldUXA=
=hg1c
-----END PGP SIGNATURE-----

V
V
Vasilii Smirnov wrote on 28 Apr 09:44 +0200
(address . 70615@debbugs.gnu.org)
c779f9c5a11844c8a77d93b7d0c1bda7637368f8.camel@mailbox.org
On Sun, 2024-04-28 at 15:35 +0800, Zheng Junjie wrote:
Toggle quote (2 lines)
> I didn't see the patch. Did you forget to send them?

I've sent the rest just a few minutes ago. Took debbugs a while to
create a ticket, I assumed it didn't work at first.
M
M
Maxim Cournoyer wrote on 28 Apr 16:45 +0200
(address . vasilii.smirnov@mailbox.org)(address . 70615-done@debbugs.gnu.org)
87zftdczr5.fsf@gmail.com
Hello,

vasilii.smirnov@mailbox.org writes:

Toggle quote (11 lines)
> From: Vasilii Smirnov <vasilii.smirnov@mailbox.org>
>
> The current version of Haxe in Guix isn't able to compile Heaps
> 2.0.0 :(. And also there is a new hlsdl version up on haxelib,
> that requires a more recent hashlink. So, here are the updated
> versions that can compile and run the latest Heaps.
>
> Vasilii Smirnov (2):
> gnu: haxe: Update to 4.3.4
> gnu: hashlink: Update to 1.14

Applied!

--
Thanks,
Maxim
Closed
J
J
John Kehayias wrote on 3 May 17:08 +0200
Re: bug#70615: closed (Re: [bug#70615] [PATCH 0/2] Update haxe and hashlink)
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
878r0rrkzp.fsf@protonmail.com
Hi Maxim and Vsilii,

On Sun, Apr 28, 2024 at 02:46 PM, GNU bug Tracking System wrote:

Toggle quote (42 lines)
> Your bug report
>
> #70615: [PATCH 0/2] Update haxe and hashlink
>
> which was filed against the guix-patches package, has been closed.
>
> The explanation is attached below, along with your original report.
> If you require more details, please reply to 70615@debbugs.gnu.org.
>
> --
> 70615: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=70615
> GNU Bug Tracking System
> Contact help-debbugs@gnu.org with problems
>
> From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
> Subject: Re: [bug#70615] [PATCH 0/2] Update haxe and hashlink
> To: vasilii.smirnov@mailbox.org
> Cc: 70615-done@debbugs.gnu.org
> Date: Sun, 28 Apr 2024 10:45:18 -0400 (5 days, 19 minutes, 40 seconds ago)
>
> Hello,
>
> vasilii.smirnov@mailbox.org writes:
>
>> From: Vasilii Smirnov <vasilii.smirnov@mailbox.org>
>>
>> The current version of Haxe in Guix isn't able to compile Heaps
>> 2.0.0 :(. And also there is a new hlsdl version up on haxelib,
>> that requires a more recent hashlink. So, here are the updated
>> versions that can compile and run the latest Heaps.
>>
>> Vasilii Smirnov (2):
>> gnu: haxe: Update to 4.3.4
>> gnu: hashlink: Update to 1.14
>
> Applied!
>
> --
> Thanks,
> Maxim
>

Just a heads up that these patches applied without full commit logs
(which weren't included in the patches sent either). Patch 1 also
affected 3 packages, maybe the haxe ones needed to be upgraded together
(along with the ocaml-luv?) but that should have been noted (and
probably still done separately).

Thanks,
John

Toggle quote (25 lines)
> ----------
>
> From: vasilii.smirnov@mailbox.org
> Subject: [PATCH 0/2] Update haxe and hashlink
> To: guix-patches@gnu.org
> Date: Sat, 27 Apr 2024 22:08:18 +0200
> Date: Sat, 27 Apr 2024 22:08:18 +0200 (5 days, 18 hours, 56 minutes ago)
>
> From: Vasilii Smirnov <vasilii.smirnov@mailbox.org>
>
> The current version of Haxe in Guix isn't able to compile Heaps
> 2.0.0 :(. And also there is a new hlsdl version up on haxelib,
> that requires a more recent hashlink. So, here are the updated
> versions that can compile and run the latest Heaps.
>
> Vasilii Smirnov (2):
> gnu: haxe: Update to 4.3.4
> gnu: hashlink: Update to 1.14
>
> gnu/packages/haxe.scm | 19 ++++++++++---------
> gnu/packages/ocaml.scm | 4 ++--
> 2 files changed, 12 insertions(+), 11 deletions(-)
>
>
> base-commit: 8d29f416a9378d30f63c2a95f1bd1a420d9ccab4
V
V
Vasilii Smirnov wrote on 3 May 20:29 +0200
(name . John Kehayias)(address . john.kehayias@protonmail.com)
d747a478-e5a7-0b87-b189-cac83e2d0911@mailbox.org
On 5/3/24 17:08, John Kehayias wrote:
Toggle quote (9 lines)
> Just a heads up that these patches applied without full commit logs
> (which weren't included in the patches sent either). Patch 1 also
> affected 3 packages, maybe the haxe ones needed to be upgraded together
> (along with the ocaml-luv?) but that should have been noted (and
> probably still done separately).
>
> Thanks,
> John

Hi, John. I did add an explanation for ocaml-luv in the commit message
(git show 2205660ce2), but yeah, it's not in the ChangeLog format. Sorry
about that.
?