(address . bug-mumi@gnu.org)
When the mumi GraphQL endpoint is requested for a non-existent bug, it
should provide a clear error message in the response. At the moment, it
merely fails with an "Internal Server Error", and the user is left
groping in the darkness.
Here's a minimal failing example:
Toggle snippet (15 lines)
(use-modules (kolam http)
(ice-9 pretty-print))
(define %graphql-endpoint
"https://issues.guix.gnu.org/graphql")
(pretty-print
(graphql-http-get %graphql-endpoint
'(document
(query (#(issue #:number 2)
number
title
date
open)))))