Report GraphQL error when queried for non-existent bug

  • Open
  • quality assurance status badge
Details
One participant
  • Arun Isaac
Owner
unassigned
Submitted by
Arun Isaac
Severity
normal
A
A
Arun Isaac wrote on 27 Apr 21:18 +0200
(address . bug-mumi@gnu.org)
87zfted37k.fsf@systemreboot.net
When the mumi GraphQL endpoint is requested for a non-existent bug, it
should provide a clear error message in the response. At the moment, it
merely fails with an "Internal Server Error", and the user is left
groping in the darkness.

Here's a minimal failing example:

Toggle snippet (15 lines)
(use-modules (kolam http)
(ice-9 pretty-print))

(define %graphql-endpoint
"https://issues.guix.gnu.org/graphql")

(pretty-print
(graphql-http-get %graphql-endpoint
'(document
(query (#(issue #:number 2)
number
title
date
open)))))
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 70613@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70613
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch