(address . bug-guix@gnu.org)
Hello everyone,
I'm seeing some issues with greetd-wlgreet-session.
According to the docs
https://guix.gnu.org/manual/en/html_node/Base-Services.htmlI would assume that
greetd-wlgreet-session and greetd-agreety-session are easily exchangeable, but
greetd-wlgreet-session leads to an error, whereas greetd-agreety-session does not.
Here's the error:
```
guix system: error: #<<greetd-wlgreet-session> wlgreet: #<package
wlgreet@0.4.1-1.7e79d60 gnu/packages/admin.scm:5602 7f90a2f8e9a0> command:
#<file-append #<package sway@1.9 gnu/packages/wm.scm:1883 7f90aa657dc0>
"/bin/sway"> command-args: () output-mode: "all" scale: 1 background: (0 0 0
0.9) headline: (1 1 1 1) prompt: (1 1 1 1) prompt-error: (1 1 1 1) border: (1 1
1 1) extra-env: ()>: invalid G-expression input
```
Here's what my service looks like:
```
(service greetd-service-type
(greetd-configuration
(greeter-supplementary-groups (list "video" "input"))
(terminals
(list
;; working
(greetd-terminal-configuration
(terminal-vt "1")
(default-session-command
(greetd-agreety-session)))
;; working
(greetd-terminal-configuration
(terminal-vt "1")
(default-session-command
(greetd-wlgreet-sway-session)))
;; not working
(greetd-terminal-configuration
(terminal-vt "1")
(default-session-command
(greetd-wlgreet-session)))
(greetd-terminal-configuration
(terminal-vt "2"))
(greetd-terminal-configuration
(terminal-vt "3"))
(greetd-terminal-configuration
(terminal-vt "4"))
(greetd-terminal-configuration
(terminal-vt "5"))
(greetd-terminal-configuration
(terminal-vt "6"))))))
```
Either I'm doing something wrong, or greetd-wlgreet-session does not work by
itself. When I have time, I'll dig a little deeper.
Cheers,
Franz