greetd-wlgreet-session: invalid G-expression input

  • Done
  • quality assurance status badge
Details
2 participants
  • Franz Geffke
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Franz Geffke
Severity
normal

Debbugs page

Franz Geffke wrote 10 months ago
(address . bug-guix@gnu.org)
b205a9b8-7a29-25bb-1de3-2528f90f2776@f-a.nz
Hello everyone,

I'm seeing some issues with greetd-wlgreet-session.

According to the docs
greetd-wlgreet-session and greetd-agreety-session are easily exchangeable, but
greetd-wlgreet-session leads to an error, whereas greetd-agreety-session does not.

Here's the error:

```
guix system: error: #<<greetd-wlgreet-session> wlgreet: #<package
wlgreet@0.4.1-1.7e79d60 gnu/packages/admin.scm:5602 7f90a2f8e9a0> command:
#<file-append #<package sway@1.9 gnu/packages/wm.scm:1883 7f90aa657dc0>
"/bin/sway"> command-args: () output-mode: "all" scale: 1 background: (0 0 0
0.9) headline: (1 1 1 1) prompt: (1 1 1 1) prompt-error: (1 1 1 1) border: (1 1
1 1) extra-env: ()>: invalid G-expression input
```

Here's what my service looks like:

```
(service greetd-service-type
(greetd-configuration
(greeter-supplementary-groups (list "video" "input"))
(terminals
(list

;; working
(greetd-terminal-configuration
(terminal-vt "1")
(default-session-command
(greetd-agreety-session)))

;; working
(greetd-terminal-configuration
(terminal-vt "1")
(default-session-command
(greetd-wlgreet-sway-session)))

;; not working
(greetd-terminal-configuration
(terminal-vt "1")
(default-session-command
(greetd-wlgreet-session)))

(greetd-terminal-configuration
(terminal-vt "2"))
(greetd-terminal-configuration
(terminal-vt "3"))
(greetd-terminal-configuration
(terminal-vt "4"))
(greetd-terminal-configuration
(terminal-vt "5"))
(greetd-terminal-configuration
(terminal-vt "6"))))))
```

Either I'm doing something wrong, or greetd-wlgreet-session does not work by
itself. When I have time, I'll dig a little deeper.

Cheers,
Franz
Maxim Cournoyer wrote 1 months ago
Re: [bug#75270] [PATCH v6 0/3] services: greetd: Improve greeter configurations.
(name . muradm)(address . mail@muradm.net)
8734gr8aff.fsf@gmail.com
close 64112
close 65769
close 70605
close 70318
quit

Hi,

muradm <mail@muradm.net> writes:

Toggle quote (10 lines)
> Minor improvements and fixes compared to v5.
> Adds extra-shepherd-requirement.
>
> Improves greeter configuration and adds new gtkgreet greeter.
>
> Fixes: https://issues.guix.gnu.org/64112
> Fixes: https://issues.guix.gnu.org/65769
> Fixes: https://issues.guix.gnu.org/70605
> Obsoletes: https://issues.guix.gnu.org/70318

Pushed as commit 220ef58440. Thanks a lot for tackling these various
issues and for your patience during the review.

--
Thanks,
Maxim
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70605@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70605
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help