[PATCH 00/14] Updated series to update gnucash to 5.6 / aqbanking 6.5.4 / gwenhywfar 5.10.2

  • Done
  • quality assurance status badge
Details
One participant
  • Julian Flake
Owner
unassigned
Submitted by
Julian Flake
Severity
normal
J
J
Julian Flake wrote on 26 Apr 13:41 +0200
(address . 70222@debbugs.gnu.org)
cover.1714130774.git.flake@uni-koblenz.de
I merged the v1 patch with the patch of #70479. Additionally I had to remove from gnu/local.mk the reference to perl-finance-quote-unuse-mozilla-ca.patch to compile the tree with this patch applied. That's all what v2 differs from v1.

Steve George (14):
Series to update gnucash to 5.6
gnu: gwenhywfar: Update to 5.10.2.
gnu: aqbanking: Update to 6.5.4.
gnu: Add perl-html-selector-xpath.
gnu: Add perl-html-treebuilder-xpath.
gnu: Add perl-web-scraper.
gnu: Add perl-string-util.
gnu: Add perl-sub-override.
gnu: Add perl-html-tokeparser-simple.
gnu: Add perl-digest-perl-md5.
gnu: Add perl-spreadsheet-parseexcel.
gnu: Add perl-spreadsheet-xlsx.
gnu: perl-finance-quote: Update perl-finance-quote.
gnu: gnucash: Update to 5.6.

gnu/local.mk | 1 -
gnu/packages/gnucash.scm | 136 ++++++++---------
.../perl-finance-quote-unuse-mozilla-ca.patch | 15 --
gnu/packages/perl.scm | 105 +++++++++++++
gnu/packages/web.scm | 138 ++++++++++++++++--
5 files changed, 302 insertions(+), 93 deletions(-)
delete mode 100644 gnu/packages/patches/perl-finance-quote-unuse-mozilla-ca.patch


base-commit: 4caf26a4f5708f490c62f46ab68527f6fcc54295
--
2.41.0
J
J
Julian Flake wrote on 26 Apr 13:42 +0200
[PATCH v2 08/14] gnu: Add perl-sub-override.
(address . 70222@debbugs.gnu.org)
05bf5a094bf4bd0049ffa7ae950932523c19020e.1714130775.git.flake@uni-koblenz.de
From: Steve George <steve@futurile.net>

* gnu/packages/crates-io.scm (perl-sub-override): New variable.

Change-Id: I5a366862bb5bfd777094e2d58239d50aad95577c

-- >8 --

Change-Id: Ib4542ceedcff114e1184fc8bafac0f76985b78be
---
gnu/packages/perl.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 362957d5f5..a72c3af765 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -38,6 +38,7 @@
;;; Copyright © 2023 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2023 Jake Leporte <jakeleporte@outlook.com>
;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2020, 2023 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -10118,6 +10119,26 @@ (define-public perl-sub-name
return value is the sub.")
(license (package-license perl))))
+(define-public perl-sub-override
+ (package
+ (name "perl-sub-override")
+ (version "0.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://cpan.metacpan.org/authors/id/O/OV/OVID/Sub-Override-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0ixbaxhnicx90483rqhcz5dzqzxfwjxf2crghw3lgmasairwr3bd"))))
+ (native-inputs `(("perl-test-fatal" ,perl-test-fatal)))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/Sub-Override")
+ (synopsis "Perl extension to override a subroutine")
+ (description "A @code{Sub::Override}} module that makes it easy to override
++subroutines. Particularly useful for mocking in tests.")
+ (license (package-license perl))))
+
(define-public perl-sub-quote
(package
(name "perl-sub-quote")
--
2.41.0
J
J
Julian Flake wrote on 26 Apr 13:42 +0200
[PATCH v2 09/14] gnu: Add perl-html-tokeparser-simple.
(address . 70222@debbugs.gnu.org)
ed6001fe6c1393112d7dbd4cfaa6e3e591c17b41.1714130775.git.flake@uni-koblenz.de
From: Steve George <steve@futurile.net>

* gnu/packages/web.scm (perl-html-tokeparser-simple): New variable.

Change-Id: If779dbe29de05697d87143b38d986d5ff7fa2c8f
---
gnu/packages/web.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index de8847fac0..52d7048fde 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -3578,6 +3578,29 @@ (define-public perl-html-tableextract
in tables within an HTML document, either as text or encoded element trees.")
(license license:perl-license)))
+(define-public perl-html-tokeparser-simple
+ (package
+ (name "perl-html-tokeparser-simple")
+ (version "3.16")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/O/OV/OVID/HTML-TokeParser-Simple-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "17aa1v62sp8ycxcicwhankmj4brs6nnfclk9z7mf1rird1f164gd"))))
+ (build-system perl-build-system)
+ (native-inputs (list perl-module-build))
+ (propagated-inputs (list perl-html-parser
+ perl-html-tagset
+ perl-sub-override))
+ (home-page "https://metacpan.org/release/HTML-TokeParser-Simple")
+ (synopsis "Easy to use parsing interface")
+ (description "Provides @code{HTML::TokeParser::Simple}, a simpler interface
+to @code{HTML::TokeParser} for parsing HTML.")
+ (license license:perl-license)))
+
(define-public perl-html-tree
(package
(name "perl-html-tree")
--
2.41.0
J
J
Julian Flake wrote on 26 Apr 13:41 +0200
[PATCH v2 02/14] gnu: gwenhywfar: Update to 5.10.2.
(address . 70222@debbugs.gnu.org)
7aa3bdadb5a2fe754f1b929f75040d61d0ad3942.1714130774.git.flake@uni-koblenz.de
From: Steve George <steve@futurile.net>

* gnu/packages/gnucash.scm (gwenhywfar): Update to 5.10.2.
[inputs]: add libxml2.
[arguments]: <configure-flags>: Remove flag that's not recognised
--with-openssl-includes; add --with-libxml2-code, --enable-system-certs
and --disable-binreloc

Change-Id: I4085779e3ed7ecb621dd3d0b5427e92962466033
---
gnu/packages/gnucash.scm | 62 ++++++++++++++++++++--------------------
1 file changed, 31 insertions(+), 31 deletions(-)

Toggle diff (76 lines)
diff --git a/gnu/packages/gnucash.scm b/gnu/packages/gnucash.scm
index 0f3217ffe3..d8d13f9780 100644
--- a/gnu/packages/gnucash.scm
+++ b/gnu/packages/gnucash.scm
@@ -242,38 +242,38 @@ (define gnucash-docs
(license (list license:fdl1.1+ license:gpl3+)))))
(define-public gwenhywfar
- (package
- (name "gwenhywfar")
- (version "5.6.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://www.aquamaniac.de/rdm/attachments/"
- "download/364/gwenhywfar-" version ".tar.gz"))
- (sha256
- (base32 "1isbj4a7vdgagp3kkvx2pjcjy8lba6kzjr11fmr06aci1694dbsp"))))
- (build-system gnu-build-system)
- (arguments
- `(#:configure-flags
- (list "--disable-network-checks"
- ;; GTK+3, GTK+2 and QT4 are supported.
- "--with-guis=gtk3"
- (string-append "--with-openssl-includes="
- (assoc-ref %build-inputs "openssl") "/include")
- (string-append "--with-openssl-libs="
- (assoc-ref %build-inputs "openssl") "/lib"))))
- (inputs
- (list libgcrypt gnutls openssl gtk+))
- (native-inputs
- (list pkg-config))
- (home-page "https://www.aquamaniac.de")
- (synopsis "Utility library for networking and security applications")
- (description
- "This package provides a helper library for networking and security
+ (let ((attachid "501")) ;; file attachid changes for each version
+ (package
+ (name "gwenhywfar")
+ (version "5.10.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.aquamaniac.de/rdm/attachments/"
+ "download/" attachid "/gwenhywfar-" version ".tar.gz"))
+ (sha256
+ (base32 "1qd950kilf9bcb51b1daykipanml6bg1h3pj10950r98ah1xm9v0"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "--disable-network-checks"
+ ;; GTK+3, GTK+2 and QT4 are supported.
+ "--with-guis=gtk3"
+ "--enable-system-certs"
+ "--with-libxml2-code=yes"
+ "--disable-binreloc")))
+ (inputs
+ (list libgcrypt gnutls openssl gtk+ libxml2))
+ (native-inputs
+ (list pkg-config))
+ (home-page "https://www.aquamaniac.de")
+ (synopsis "Utility library for networking and security applications")
+ (description
+ "This package provides a helper library for networking and security
applications and libraries. It is used by AqBanking.")
- ;; The license includes an explicit additional permission to compile and
- ;; distribute this library with the OpenSSL Toolkit.
- (license license:lgpl2.1+)))
+ ;; The license includes an explicit additional permission to compile and
+ ;; distribute this library with the OpenSSL Toolkit.
+ (license license:lgpl2.1+))))
(define-public aqbanking
(package
--
2.41.0
J
J
Julian Flake wrote on 26 Apr 13:41 +0200
[PATCH v2 03/14] gnu: aqbanking: Update to 6.5.4.
(address . 70222@debbugs.gnu.org)
ef51d28cd3feb394cac7f1a05cbc4e422123dbbb.1714130774.git.flake@uni-koblenz.de
From: Steve George <steve@futurile.net>

* gnu/packages/gnucash (aqbanking): Update to 6.5.4.

Change-Id: I8d10562e1fc8517bee946792ad1ac901a26137d5
---
gnu/packages/gnucash.scm | 71 ++++++++++++++++++++--------------------
1 file changed, 36 insertions(+), 35 deletions(-)

Toggle diff (85 lines)
diff --git a/gnu/packages/gnucash.scm b/gnu/packages/gnucash.scm
index d8d13f9780..d5681ed86d 100644
--- a/gnu/packages/gnucash.scm
+++ b/gnu/packages/gnucash.scm
@@ -276,42 +276,43 @@ (define-public gwenhywfar
(license license:lgpl2.1+))))
(define-public aqbanking
- (package
- (name "aqbanking")
- (version "6.3.2")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://www.aquamaniac.de/rdm/attachments/"
- "download/386/aqbanking-" version ".tar.gz"))
- (sha256
- (base32 "061l7qja7x557650kphbg1gzxc52a7557nibgdhv5jwqf8pv8ym9"))))
- (build-system gnu-build-system)
- (arguments
- `(;; Parallel building fails because aqhbci is required before it's
- ;; built.
- #:parallel-build? #f
- #:phases
- (modify-phases %standard-phases
- ;; Embed the package version instead of the build date
- (add-after 'unpack 'use-version-instead-of-date
- (lambda _
- (substitute*
- "src/libs/plugins/backends/aqhbci/header.xml.in"
- (("@DATETIME@") ,version)))))))
- (propagated-inputs
- (list gwenhywfar))
- (inputs
- (list gmp xmlsec gnutls))
- (native-inputs
- (list pkg-config gettext-minimal libltdl))
- (home-page "https://www.aquamaniac.de")
- (synopsis "Interface for online banking tasks")
- (description
- "AqBanking is a modular and generic interface to online banking tasks,
+ (let ((attachid "499")) ;; file attachid changes for each version
+ (package
+ (name "aqbanking")
+ (version "6.5.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.aquamaniac.de/rdm/attachments/"
+ "download/" attachid "/aqbanking-" version ".tar.gz"))
+ (sha256
+ (base32 "16dc63gav0b4rmwj0clqilfpz4hlidx59x1qcr38wwghfspcw5hd"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(;; Parallel building fails because aqhbci is required before it's
+ ;; built.
+ #:parallel-build? #f
+ #:phases
+ (modify-phases %standard-phases
+ ;; Embed the package version instead of the build date
+ (add-after 'unpack 'use-version-instead-of-date
+ (lambda _
+ (substitute*
+ "src/libs/plugins/backends/aqhbci/header.xml.in"
+ (("@DATETIME@") ,version)))))))
+ (propagated-inputs
+ (list gwenhywfar))
+ (inputs
+ (list gmp xmlsec gnutls))
+ (native-inputs
+ (list pkg-config gettext-minimal libltdl))
+ (home-page "https://www.aquamaniac.de")
+ (synopsis "Interface for online banking tasks")
+ (description
+ "AqBanking is a modular and generic interface to online banking tasks,
financial file formats (import/export) and bank/country/currency information.
AqBanking uses backend plugins to actually perform the online tasks. HBCI,
OFX DirectConnect, YellowNet, GeldKarte, and DTAUS discs are currently
supported. AqBanking is used by GnuCash, KMyMoney, and QBankManager.")
- ;; AqBanking is licensed under the GPLv2 or GPLv3
- (license (list license:gpl2 license:gpl3))))
+ ;; AqBanking is licensed under the GPLv2 or GPLv3
+ (license (list license:gpl2 license:gpl3)))))
--
2.41.0
J
J
Julian Flake wrote on 26 Apr 13:42 +0200
[PATCH v2 10/14] gnu: Add perl-digest-perl-md5.
(address . 70222@debbugs.gnu.org)
28201957e8f6a7687ec3f8615f5dd4621980d0ba.1714130775.git.flake@uni-koblenz.de
From: Steve George <steve@futurile.net>

* gnu/packages/perl.scm (perl-digest-perl-md5): New variable.

Change-Id: Ic656fef7bbc77790d114812f0c9dcafa1586e357
---
gnu/packages/perl.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index a72c3af765..9f1a9fdfcc 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -4094,6 +4094,26 @@ (define-public perl-digest-md5
128-bit \"fingerprint\" or \"message digest\" of the input.")
(license (package-license perl))))
+(define-public perl-digest-perl-md5
+ (package
+ (name "perl-digest-perl-md5")
+ (version "1.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/D/DE/DELTA/Digest-Perl-MD5-" version
+ ".tar.gz"))
+ (sha256
+ (base32 "1cfrxkzazxdg4prdfcfd9b33bvyav1xim2vxj07gni8gf6hwn03i"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/Digest-Perl-MD5")
+ (synopsis "Perl Implementation of Rivest's MD5 algorithm")
+ (description "This @code{Digest::Perl::MD5} has the same interface as the
+much faster @code{Digest::MD5}, but it's a pure Perl implementation of MD5.
+Because of this it is slow but it works without C code.")
+ (license license:perl-license)))
+
(define-public perl-digest-sha
(package
(name "perl-digest-sha")
--
2.41.0
J
J
Julian Flake wrote on 26 Apr 13:42 +0200
[PATCH v2 11/14] gnu: Add perl-spreadsheet-parseexcel.
(address . 70222@debbugs.gnu.org)
18798aedb721e68e8c0631d5e46ecb33c7549e44.1714130775.git.flake@uni-koblenz.de
From: Steve George <steve@futurile.net>

* gnu/packages/perl.scm (perl-spreadsheet-parseexcel): New variable.

Change-Id: I0dfbf49f4b8b1865a738edc805d3dc83b038a124
---
gnu/packages/perl.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 9f1a9fdfcc..9a810ca44b 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -9639,6 +9639,30 @@ (define-public perl-spiffy
other OO languages like Python, Ruby, Java and Perl 6.")
(license (package-license perl))))
+(define-public perl-spreadsheet-parseexcel
+ (package
+ (name "perl-spreadsheet-parseexcel")
+ (version "0.66")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/J/JM/JMCNAMARA/Spreadsheet-ParseExcel-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0nzn8n928720lyv61nbd02d87xi5pfs77nhv0pf031lqpb7nmmxz"))))
+ (build-system perl-build-system)
+ (propagated-inputs (list perl-crypt-rc4
+ perl-digest-perl-md5
+ perl-io-stringy
+ perl-ole-storage-lite
+ perl-scalar-list-utils))
+ (home-page "https://metacpan.org/release/Spreadsheet-ParseExcel")
+ (synopsis "Read information from an Excel file")
+ (description "This @code{Spreadsheet::ParseExcel} module parses Microsoft
+Excel95, 97 and 2000 format files.")
+ (license license:perl-license)))
+
(define-public perl-want
(package
(name "perl-want")
--
2.41.0
J
J
Julian Flake wrote on 26 Apr 13:42 +0200
[PATCH v2 12/14] gnu: Add perl-spreadsheet-xlsx.
(address . 70222@debbugs.gnu.org)
00032221e04e07828f414e8a2021e3b7b5f5650e.1714130775.git.flake@uni-koblenz.de
From: Steve George <steve@futurile.net>

* gnu/packages/perl.scm (perl-spreadsheet-xlsx): New variable.

Change-Id: Iec4fc26945bd2f154587d4b13b593fd947bb0e5a
---
gnu/packages/perl.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 9a810ca44b..0abf3f7fd1 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -9663,6 +9663,26 @@ (define-public perl-spreadsheet-parseexcel
Excel95, 97 and 2000 format files.")
(license license:perl-license)))
+(define-public perl-spreadsheet-xlsx
+ (package
+ (name "perl-spreadsheet-xlsx")
+ (version "0.17")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/A/AS/ASB/Spreadsheet-XLSX-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0xp9rqm0j1a6pr2zxk9c1mk720vbd72bhkmpcn8305pzgj97idrk"))))
+ (build-system perl-build-system)
+ (native-inputs (list perl-test-nowarnings perl-test-warnings))
+ (propagated-inputs (list perl-archive-zip perl-spreadsheet-parseexcel))
+ (home-page "https://metacpan.org/release/Spreadsheet-XLSX")
+ (synopsis "Perl extension for reading MS Excel 2007 files")
+ (description "This module implements @code{Spreadsheet::XLSX} parsing
+Microsoft Excel 2007 xlsx files.")
+ (license license:perl-license)))
+
(define-public perl-want
(package
(name "perl-want")
--
2.41.0
J
J
Julian Flake wrote on 26 Apr 13:42 +0200
[PATCH v2 07/14] gnu: Add perl-string-util.
(address . 70222@debbugs.gnu.org)
7f18028cf4880858eaecb00d63970fe84c5188be.1714130775.git.flake@uni-koblenz.de
From: Steve George <steve@futurile.net>

* gnu/packages/perl.scm (perl-string-util): New variable.

Change-Id: Iaef13963efb3d795bcc0c16bcdd72c112894f886
---
gnu/packages/perl.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 57a06f836b..362957d5f5 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -9967,6 +9967,26 @@ (define-public perl-string-print
a functional interface.")
(license (package-license perl))))
+(define-public perl-string-util
+ (package
+ (name "perl-string-util")
+ (version "1.34")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/B/BA/BAKERSCOT/String-Util-" version
+ ".tar.gz"))
+ (sha256
+ (base32 "0sf44mky5kawj9jnf0zpv688wchr5ab5s5gs45jyahakcv6yi71i"))))
+ (build-system perl-build-system)
+ (native-inputs (list perl-module-build-tiny))
+ (home-page "https://metacpan.org/release/String-Util")
+ (synopsis "String processing utility functions")
+ (description "A @code{String::Util} module of small, handy functions for
+processing strings in various ways.")
+ (license license:perl-license)))
+
(define-public perl-sub-exporter
(package
(name "perl-sub-exporter")
--
2.41.0
J
J
Julian Flake wrote on 26 Apr 13:41 +0200
[PATCH v2 04/14] gnu: Add perl-html-selector-xpath.
(address . 70222@debbugs.gnu.org)
b02e3483df7c1f66f6716ac828ffb1383bd9c631.1714130774.git.flake@uni-koblenz.de
From: Steve George <steve@futurile.net>

* gnu/packages/web.scm (perl-html-selector-xpath): New variable.

Change-Id: Ib4ccaf4e7f5fdbb90118d6ba16a478be26bbed84
---
gnu/packages/web.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index a71a0e07a3..b311fa505b 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -3535,6 +3535,27 @@ (define-public perl-html-lint
syntactic legitmacy.")
(license license:artistic2.0)))
+(define-public perl-html-selector-xpath
+ (package
+ (name "perl-html-selector-xpath")
+ (version "0.28")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/C/CO/CORION/HTML-Selector-XPath-" version
+ ".tar.gz"))
+ (sha256
+ (base32 "03wdwnrf0bvr2dw01njnz3a9mw2kl7ad7krh25j3vkyj7vq1f9s3"))))
+ (build-system perl-build-system)
+ (native-inputs (list perl-test-base
+ perl-test-pod))
+ (home-page "https://metacpan.org/release/HTML-Selector-XPath")
+ (synopsis "CSS Selector to XPath compiler")
+ (description "@code{HTML::Selector::XPath} is a Perl module for parsing
+and scraping XML/HTML documents using XPath expressions.")
+ (license license:perl-license)))
+
(define-public perl-html-tableextract
(package
(name "perl-html-tableextract")
--
2.41.0
J
J
Julian Flake wrote on 26 Apr 13:42 +0200
[PATCH v2 14/14] gnu: gnucash: Update to 5.6.
(address . 70222@debbugs.gnu.org)
a1c80599aeef3c114f492884c59f1f49807a4d09.1714130775.git.flake@uni-koblenz.de
From: Steve George <steve@futurile.net>

* gnu/packages/gnucash.scm (gnucash): Update to 5.6.

Change-Id: I3646082d628470327fbd9deec6111de8c1eec921
---
gnu/packages/gnucash.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/gnucash.scm b/gnu/packages/gnucash.scm
index d5681ed86d..ce99c04e39 100644
--- a/gnu/packages/gnucash.scm
+++ b/gnu/packages/gnucash.scm
@@ -93,7 +93,7 @@ (define-public gnucash
(lambda _
(call-with-output-file "libgnucash/app-utils/test/CMakeLists.txt"
(lambda (port)
- (display "set(CTEST_CUSTOM_TESTS_IGNORE online_wiggle)" port)))))
+ (display "set(CTEST_CUSTOM_TESTS_IGNORE online_wiggle test-lots)" port)))))
(add-after 'unpack 'set-env-vars
(lambda* (#:key inputs #:allow-other-keys)
;; At least one test is time-related and requires this
@@ -184,6 +184,7 @@ (define-public gnucash
libxslt
perl-date-manip
perl-finance-quote
+ perl-json
perl-json-parse
python
tzdata-for-tests
--
2.41.0
J
J
Julian Flake wrote on 26 Apr 13:42 +0200
[PATCH v2 13/14] gnu: perl-finance-quote: Update perl-finance-quote.
(address . 70222@debbugs.gnu.org)
f055cdc05d19661ac864d6508e4150fd4137cbe5.1714130775.git.flake@uni-koblenz.de
From: Steve George <steve@futurile.net>

* gnu/packages/web.scm (perl-finance-quote): Update to 1.59.
[source] remove patch
* gnu/packages/patches/perl-finance-quote-unuse-mozilla-ca.patch: Remove file.

Change-Id: I3646082d628470327fbd9deec6111de8c1eec921

Change-Id: Ibe50f9736bcbe4e628c05f86c0e0be8bd335d4c8
---
gnu/local.mk | 1 -
.../perl-finance-quote-unuse-mozilla-ca.patch | 15 -------
gnu/packages/web.scm | 42 ++++++++++++++-----
3 files changed, 32 insertions(+), 26 deletions(-)
delete mode 100644 gnu/packages/patches/perl-finance-quote-unuse-mozilla-ca.patch

Toggle diff (113 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 42961e60b2..85858c0df6 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1860,7 +1860,6 @@ dist_patch_DATA = \
%D%/packages/patches/perl-5.14-no-sys-dirs.patch \
%D%/packages/patches/perl-autosplit-default-time.patch \
%D%/packages/patches/perl-class-methodmaker-reproducible.patch \
- %D%/packages/patches/perl-finance-quote-unuse-mozilla-ca.patch \
%D%/packages/patches/perl-image-exiftool-CVE-2021-22204.patch \
%D%/packages/patches/perl-net-amazon-s3-moose-warning.patch \
%D%/packages/patches/perl-net-dns-resolver-programmable-fix.patch \
diff --git a/gnu/packages/patches/perl-finance-quote-unuse-mozilla-ca.patch b/gnu/packages/patches/perl-finance-quote-unuse-mozilla-ca.patch
deleted file mode 100644
index 5f37bb0ba7..0000000000
--- a/gnu/packages/patches/perl-finance-quote-unuse-mozilla-ca.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Rather than unconditionally using Mozilla's CA certificates, let the user tell
-LWP's UserAgent where to find certificates with the PERL_LWP_SSL_CA_FILE,
-HTTPS_CA_FILE, PERL_LWP_SSL_CA_PATH, or HTTPS_CA_DIR environment variables
-instead.
-
---- Finance-Quote-1.37/lib/Finance/Quote/Tiaacref.pm.orig 2015-02-01 13:24:41.000000000 -0600
-+++ Finance-Quote-1.37/lib/Finance/Quote/Tiaacref.pm 2015-07-07 20:09:47.278885944 -0500
-@@ -30,7 +30,6 @@
- package Finance::Quote::Tiaacref;
- require 5.005;
- require LWP::Protocol::https;
--require Mozilla::CA;
-
- use strict;
-
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 52d7048fde..b45333ce51 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -184,6 +184,7 @@ (define-module (gnu packages web)
#:use-module (gnu packages pcre)
#:use-module (gnu packages perl)
#:use-module (gnu packages perl-check)
+ #:use-module (gnu packages perl-compression)
#:use-module (gnu packages python)
#:use-module (gnu packages python-build)
#:use-module (gnu packages python-check)
@@ -3387,34 +3388,55 @@ (define-public perl-file-listing
(define-public perl-finance-quote
(package
(name "perl-finance-quote")
- (version "1.47")
+ (version "1.59")
(source
(origin
(method url-fetch)
- (uri (string-append "https://cpan.metacpan.org/authors/id/E/EC/ECOCODE/"
+ (uri (string-append "https://cpan.metacpan.org/authors/id/B/BP/BPSCHUCK/"
"Finance-Quote-" version ".tar.gz"))
(sha256
- (base32 "0gzbq85738f299jaw4nj3ljnka380j2y6yspmyl71rgfypqjvbr7"))
- (patches (search-patches
- "perl-finance-quote-unuse-mozilla-ca.patch"))))
+ (base32 "0a19y5bj2pvdlfi747ihgz5khjlfkhjakv712r0gz0n6miwjiscs"))))
(build-system perl-build-system)
+ (native-inputs
+ (list perl-test-harness
+ perl-date-manip
+ perl-date-range
+ perl-date-simple
+ perl-datetime
+ perl-datetime-format-iso8601
+ perl-string-util
+ perl-pathtools
+ perl-test-pod
+ perl-test-pod-coverage))
(propagated-inputs
- (list perl-cgi
- perl-datetime
+ (list perl-datetime
+ perl-datetime-format-strptime
perl-html-parser
perl-html-tableextract
+ perl-html-tokeparser-simple
perl-html-tree
+ perl-html-treebuilder-xpath
+ perl-http-cookiejar
perl-http-cookies
perl-http-message
+ perl-io-string
perl-json
perl-libwww
perl-lwp-protocol-https
- perl-uri))
+ perl-mozilla-ca
+ perl-spreadsheet-xlsx
+ perl-readonly
+ perl-string-util
+ perl-text-template
+ perl-try-tiny
+ perl-web-scraper
+ perl-xml-libxml))
(home-page "https://metacpan.org/release/Finance-Quote")
(synopsis "Stock and mutual fund quotes")
(description
- "Finance::Quote gets stock quotes from various internet sources, including
-Yahoo! Finance, Fidelity Investments, and the Australian Stock Exchange.")
+ "The @code{Finance::Quote} module retries stock quotes from various
+internet sources, including Yahoo! Finance, Fidelity Investments, and the
+Australian Stock Exchange.")
(license license:gpl2)))
(define-public perl-gssapi
--
2.41.0
J
J
Julian Flake wrote on 26 Apr 13:41 +0200
[PATCH v2 05/14] gnu: Add perl-html-treebuilder-xpath.
(address . 70222@debbugs.gnu.org)
fcbaadc942010bf3994a5067d5762942f97db59b.1714130774.git.flake@uni-koblenz.de
From: Steve George <steve@futurile.net>

* gnu/packages/web.scm (perl-html-treebuilder-xpath): New variable.

Change-Id: I4069eae36a8c49a507e89c18fed90e0e53fdde4d
---
gnu/packages/web.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index b311fa505b..28ca51416a 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -3671,6 +3671,26 @@ (define-public perl-html-template
you to separate design from the data.")
(license license:perl-license)))
+(define-public perl-html-treebuilder-xpath
+ (package
+ (name "perl-html-treebuilder-xpath")
+ (version "0.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/M/MI/MIROD/HTML-TreeBuilder-XPath-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1wx4i1scng20n405fp3a4vrwvvq9bvbmg977wnd5j2ja8jrbvsr5"))))
+ (build-system perl-build-system)
+ (propagated-inputs (list perl-html-tree perl-xml-xpathengine))
+ (home-page "https://metacpan.org/release/HTML-TreeBuilder-XPath")
+ (synopsis "XPath support for @code{HTML::TreeBuilder}")
+ (description "This module implements @code{HTML::TreeBuilder::XPath} for
+@code{HTML::TreeBuilder}, making it easy to parse documents using XPath.")
+ (license license:perl-license)))
+
(define-public perl-http-body
(package
(name "perl-http-body")
--
2.41.0
J
J
Julian Flake wrote on 26 Apr 13:42 +0200
[PATCH v2 06/14] gnu: Add perl-web-scraper.
(address . 70222@debbugs.gnu.org)
4de823a7220e9efde67cc1db70d1bbf8e7549758.1714130775.git.flake@uni-koblenz.de
From: Steve George <steve@futurile.net>

* gnu/packages/web.scm (perl-web-scraper): New variable.

Change-Id: I3d0a476ca6c09bc20391303f99b260410f16de65
---
gnu/packages/web.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 28ca51416a..de8847fac0 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4778,6 +4778,38 @@ (define-public perl-uri-ws
methods for WebSocket URIs as it does for HTTP URIs.")
(license license:perl-license)))
+(define-public perl-web-scraper
+ (package
+ (name "perl-web-scraper")
+ (version "0.38")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/M/MI/MIYAGAWA/Web-Scraper-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1gs3fmbc83j34c0sig1hkpnm26ngnyi5kgq5dl8vxvkzimgnwnzr"))))
+ (build-system perl-build-system)
+ (native-inputs (list perl-module-build-tiny
+ perl-test-base
+ perl-test-requires))
+ (propagated-inputs (list perl-html-parser
+ perl-html-selector-xpath
+ perl-html-tagset
+ perl-html-tree
+ perl-html-treebuilder-xpath
+ perl-libwww
+ perl-universal-require
+ perl-uri
+ perl-xml-xpathengine
+ perl-yaml))
+ (home-page "https://metacpan.org/release/Web-Scraper")
+ (synopsis
+ "Web Scraping toolkit using HTML and CSS Selectors or XPath expressions")
+ (description "Perl module @code{Web::Scraper} is a toolkit for
+traversing and scraping sites, inspired by Ruby's Scapi.")
+ (license license:perl-license)))
+
(define-public perl-uri-template
(package
(name "perl-uri-template")
--
2.41.0
J
?