[PATCH] gnu: Add emacs-ellama.

  • Done
  • quality assurance status badge
Details
3 participants
  • Liliana Marie Prikler
  • Nicolas Graves
  • Roman Scherer
Owner
unassigned
Submitted by
Roman Scherer
Severity
normal
R
R
Roman Scherer wrote on 26 Apr 09:10 +0200
(address . guix-patches@gnu.org)(name . Roman Scherer)(address . roman@burningswell.com)
ff0a121fc932046bb4acaa19fc28ea9da1821cd6.1714115406.git.roman@burningswell.com
* gnu/packages/emacs-xyz.scm (emacs-ellama): New variable.

Change-Id: I47bf40971adca845aa132d08f59cd083154bec0e
---
gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

This package depends on the emacs-llm package, which I submitted previously at bug#70584.

Toggle diff (38 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8c712612b6..4945cee411 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4957,6 +4957,31 @@ (define-public emacs-elf-mode
that the binary uses instead of the actual binary contents.")
(license license:gpl3+)))

+(define-public emacs-ellama
+ (package
+ (name "emacs-ellama")
+ (version "0.9.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/s-kostyaev/ellama")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256 (base32
+ "1nwwqvl91c65r45yxa2dcl4a41r3ahw6294h79riya48nrp8kn54"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-dash emacs-llm emacs-spinner))
+ (home-page "https://github.com/s-kostyaev/ellama")
+ (synopsis "Tool for interacting with LLMs")
+ (description
+ "Ellama is a tool for interacting with large language models from Emacs.
+It allows you to ask questions and receive responses from the LLMs. Ellama
+can perform various tasks such as translation, code review, summarization,
+enhancing grammar/spelling or wording and more through the Emacs interface.
+Ellama natively supports streaming output, making it effortless to use with
+your preferred text editor.")
+ (license license:gpl3+)))
+
(define-public emacs-org-fc
(package
(name "emacs-org-fc")

base-commit: bf984c5c80f460f36298f46b0389d4341086b47c
--
2.41.0
L
L
Liliana Marie Prikler wrote on 9 May 11:59 +0200
(address . 70585@debbugs.gnu.org)
e09d03af4c36cb4cc1e27df402bd73a8026624f8.camel@gmail.com
Pushed as 73818c254b8a833dc474105b9c3fb66b86227fc4.

Cheers
N
N
Nicolas Graves wrote on 13 May 15:02 +0200
control message for bug #70585
(address . control@debbugs.gnu.org)
87pltp27ce.fsf@ngraves.fr
close 70585
# Pushed as 73818c254b8a833dc474105b9c3fb66b86227fc4.
quit


--
Best regards,
Nicolas Graves
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70585@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70585
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch