[PATCH] gnu: Add pkcs11-helper.

  • Done
  • quality assurance status badge
Details
4 participants
  • Andy Tai
  • Ludovic Courtès
  • Nicolas Graves
  • Z572
Owner
unassigned
Submitted by
Andy Tai
Severity
normal

Debbugs page

Andy Tai wrote 11 months ago
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
356e77d1fbad51a042ebb8eaae2804bb74a30c9b.1714036907.git.atai@atai.org
* gnu/packages/security-token.scm (pkcs11-helper): New variable.

Change-Id: Ib17e0cf209a6fe797d0c797829ba91091b719028
---
gnu/packages/security-token.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 00a7f97582..5e20424001 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -394,6 +394,30 @@ (define-public opensc
#15 standard and the PKCS #11 API.")
(license license:lgpl2.1+)))
+
+(define-public pkcs11-helper
+ (package
+ (name "pkcs11-helper")
+ (version "1.30.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/OpenSC/pkcs11-helper/releases/download/pkcs11-helper-"
+ version "/pkcs11-helper-" version ".tar.bz2"))
+ (sha256
+ (base32 "1ac86jfj4qfwzbvsg6l9r4w4bbwxj2i9qi4dy1nz5aqcj6x1an2c"))))
+ (build-system gnu-build-system)
+ (inputs (list openssl-1.1 pcsc-lite))
+ (native-inputs (list pkg-config))
+ (home-page "https://github.com/OpenSC/pkcs11-helper")
+ (synopsis "Library that simplifies the interaction with PKCS#11 providers")
+ (description
+ "Pkcs11-helper is a library that simplifies the interaction with
+PKCS#11 providers for end-user applications")
+ (license (list license:gpl2 license:bsd-3))))
+
+
(define-public yubico-piv-tool
(package
(name "yubico-piv-tool")

base-commit: 4514239971895fc7ad47c7752e30d98a0c44a154
--
2.41.0
Andy Tai wrote 10 months ago
Re: bug#70563: Acknowledgement ([PATCH] gnu: Add pkcs11-helper.)
(address . 70563@debbugs.gnu.org)
CAJsg1E-MyYFE4-M1mpWwXHdrHgBFt3dyx3_bX8TdSZqJNciEhA@mail.gmail.com
Nicolas Graves wrote 10 months ago
877cfyci07.fsf@ngraves.fr
user guix
usertag 70563 + reviewed-looks-good
thanks

Guix QA review form submission:
The description probably needs a little bit more precision. In particular, it would be good to include the statement "PKCS#11 is the de-facto standard to access cryptographic devices." or something like that.

Otherwise LGTM.

Items marked as checked: Lint warnings, Package builds, Commit messages, New package licenses, New package tests

--
Best regards,
Nicolas Graves
Ludovic Courtès wrote 10 months ago
875xvhc2le.fsf@gnu.org
Hi Andy,

Did you receive Nicolas’ message below?

Nicolas Graves <ngraves@ngraves.fr> skribis:

Toggle quote (9 lines)
> user guix
> usertag 70563 + reviewed-looks-good
> thanks
>
> Guix QA review form submission:
> The description probably needs a little bit more precision. In particular, it would be good to include the statement &quot;PKCS#11 is the de-facto standard to access cryptographic devices.&quot; or something like that.
>
> Otherwise LGTM.

Note that despite being marked as “reviewed-looks-good”, Nicolas makes
a suggestion that I think is worth addressing in a second version.

Thanks,
Ludo’.
Andy Tai wrote 10 months ago
(name . Ludovic Courtès)(address . ludo@gnu.org)
CAJsg1E9HceszayvyC568zkgTzFsvdZxMq2BxNQKS2w2VdzVAqg@mail.gmail.com
OK I did not see that reply in email but I will send v2 patch
addressing the comment

On Mon, May 13, 2024 at 5:34 AM Ludovic Courtès <ludo@gnu.org> wrote:
Toggle quote (24 lines)
>
> Hi Andy,
>
> Did you receive Nicolas’ message below?
>
> Nicolas Graves <ngraves@ngraves.fr> skribis:
>
> > user guix
> > usertag 70563 + reviewed-looks-good
> > thanks
> >
> > Guix QA review form submission:
> > The description probably needs a little bit more precision. In particular, it would be good to include the statement &quot;PKCS#11 is the de-facto standard to access cryptographic devices.&quot; or something like that.
> >
> > Otherwise LGTM.
>
> Note that despite being marked as “reviewed-looks-good”, Nicolas makes
> a suggestion that I think is worth addressing in a second version.
>
> Thanks,
> Ludo’.



--
Andy Tai, atai@atai.org, Skype: licheng.tai, Line: andy_tai, WeChat: andytai1010
Year 2024 民國113年
自動的精神力是信仰與覺悟
自動的行為力是勞動與技能
Andy Tai wrote 10 months ago
[PATCH v2] gnu: Add pkcs11-helper.
(name . Andy Tai)(address . atai@atai.org)
3592b94458c7dddc7f560e8238c8f9f4119eff8f.1715838075.git.atai@atai.org
* gnu/packages/security-token.scm (pkcs11-helper): New variable.

Change-Id: Ib17e0cf209a6fe797d0c797829ba91091b719028
---
gnu/packages/security-token.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 35a8d4e216..78ddf5456b 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -394,6 +394,31 @@ (define-public opensc
#15 standard and the PKCS #11 API.")
(license license:lgpl2.1+)))
+
+(define-public pkcs11-helper
+ (package
+ (name "pkcs11-helper")
+ (version "1.30.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/OpenSC/pkcs11-helper/releases/download/pkcs11-helper-"
+ version "/pkcs11-helper-" version ".tar.bz2"))
+ (sha256
+ (base32 "1ac86jfj4qfwzbvsg6l9r4w4bbwxj2i9qi4dy1nz5aqcj6x1an2c"))))
+ (build-system gnu-build-system)
+ (inputs (list openssl-1.1 pcsc-lite))
+ (native-inputs (list pkg-config))
+ (home-page "https://github.com/OpenSC/pkcs11-helper")
+ (synopsis "Library that simplifies the interaction with PKCS#11 providers")
+ (description
+ "Pkcs11-helper is a library that simplifies the interaction with
+PKCS#11 providers for end-user applications. PKCS#11 is published standard.
+PKCS#11 is the de-facto standard to access cryptographic devices")
+ (license (list license:gpl2 license:bsd-3))))
+
+
(define-public yubico-piv-tool
(package
(name "yubico-piv-tool")

base-commit: 5a624adfd7b14c3717237d137bd0766c77f0f570
--
2.41.0
Z572 wrote 10 months ago
(name . Andy Tai)(address . atai@atai.org)
87y182o1dz.fsf@iscas.ac.cn
Andy Tai <atai@atai.org> writes:

Toggle quote (31 lines)
> * gnu/packages/security-token.scm (pkcs11-helper): New variable.
>
> Change-Id: Ib17e0cf209a6fe797d0c797829ba91091b719028
> ---
> gnu/packages/security-token.scm | 25 +++++++++++++++++++++++++
> 1 file changed, 25 insertions(+)
>
> diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
> index 35a8d4e216..78ddf5456b 100644
> --- a/gnu/packages/security-token.scm
> +++ b/gnu/packages/security-token.scm
> @@ -394,6 +394,31 @@ (define-public opensc
> #15 standard and the PKCS #11 API.")
> (license license:lgpl2.1+)))
>
> +
> +(define-public pkcs11-helper
> + (package
> + (name "pkcs11-helper")
> + (version "1.30.0")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append
> + "https://github.com/OpenSC/pkcs11-helper/releases/download/pkcs11-helper-"
> + version "/pkcs11-helper-" version ".tar.bz2"))
> + (sha256
> + (base32 "1ac86jfj4qfwzbvsg6l9r4w4bbwxj2i9qi4dy1nz5aqcj6x1an2c"))))
> + (build-system gnu-build-system)
> + (inputs (list openssl-1.1 pcsc-lite))

Can this package use openssl-3.0? As i known, openssl 1.1 is EOL,
It is best not to add more openssl-1.1 dependencies. other LGTM.

Toggle quote (15 lines)
> + (native-inputs (list pkg-config))
> + (home-page "https://github.com/OpenSC/pkcs11-helper")
> + (synopsis "Library that simplifies the interaction with PKCS#11 providers")
> + (description
> + "Pkcs11-helper is a library that simplifies the interaction with
> +PKCS#11 providers for end-user applications. PKCS#11 is published standard.
> +PKCS#11 is the de-facto standard to access cryptographic devices")
> + (license (list license:gpl2 license:bsd-3))))
> +
> +
> (define-public yubico-piv-tool
> (package
> (name "yubico-piv-tool")
>
> base-commit: 5a624adfd7b14c3717237d137bd0766c77f0f570
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmZNg/gACgkQO1qpk+Gi
3/D0cQ/9EFD5woLW8gRqG/waIX9nK0cZm2kKQ34fO/sO89vRVn5P15FU/QVpwOfz
/uh9lLH21CL34JQZaHRTWoQLSd/sg0tvUAwW89LtJsm0ZoafjTlE0CegIP1h9DYx
JjmoehmAHz/WpWvzpq+CvTOydd1Gne61/l8eETE27nK+PAL7n0LQBgRN8WhT3Lsw
7XvqLF8bDwVwuCUSe8XTAGXZyZv/UiO6AUUK8PePGH3vGEdHayeheNGXR/AXbuZ9
PQ88BTZphPeuW8GVn1Db0c/KIVA2WHWIPkyL/YoHkH5ckXjJRYJ5LkySvT1k+C1T
QK9+Bs3FdFO9xhn7+JZ0hGGncLrj2j50zLNKgafF8pyKoQ/cVqtJcOp9386+pjeQ
6vjoPxLwwjWGVXUW7l9kdNNPoo5oQqg+vq8md/EcvvJ+7pEhbH04tHKXsdSE9iW2
ej0RVOVLvRfbtnFg5JSfQsM0yqgQvn6lBmGj/i1Tf/KWL+8XPRiuBbX0mKJ5/BF4
9peLLRYlwEWx0OcjYEM3Utmv4xy/QbVEjM/nhRwfx2Nflh0FAmWVf8lc9Ng2N3wd
h1L1ssWNhdJK9XLN1Uii2+hQyGfy7JZDva/Kv5CaSp47wQyozm2wxurSKbze1yYH
f7ymGmqtrLb24QX992v663QSBIea5xFEha4MhTG7yPkdLFI9ZRM=
=eTxV
-----END PGP SIGNATURE-----

Andy Tai wrote 10 months ago
(name . Z572)(address . zhengjunjie@iscas.ac.cn)
CAJsg1E_6sH1TGA=GmVr7v+vu+12SG9XLvoMJjaqS55nZuQJ5mA@mail.gmail.com
will check and possible update patch
Andy Tai wrote 10 months ago
[PATCH v3] gnu: Add pkcs11-helper.
(address . 70563@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
4577a4a2d365d4ed62f5801c35fc148180a317b9.1716399055.git.atai@atai.org
* gnu/packages/security-token.scm (pkcs11-helper): New variable.

Change-Id: Ib17e0cf209a6fe797d0c797829ba91091b719028
---
gnu/packages/security-token.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 35a8d4e216..939febd4e3 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -394,6 +394,31 @@ (define-public opensc
#15 standard and the PKCS #11 API.")
(license license:lgpl2.1+)))
+
+(define-public pkcs11-helper
+ (package
+ (name "pkcs11-helper")
+ (version "1.30.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/OpenSC/pkcs11-helper/releases/download/pkcs11-helper-"
+ version "/pkcs11-helper-" version ".tar.bz2"))
+ (sha256
+ (base32 "1ac86jfj4qfwzbvsg6l9r4w4bbwxj2i9qi4dy1nz5aqcj6x1an2c"))))
+ (build-system gnu-build-system)
+ (inputs (list openssl pcsc-lite))
+ (native-inputs (list pkg-config))
+ (home-page "https://github.com/OpenSC/pkcs11-helper")
+ (synopsis "Library that simplifies the interaction with PKCS#11 providers")
+ (description
+ "Pkcs11-helper is a library that simplifies the interaction with
+PKCS#11 providers for end-user applications. PKCS#11 is published standard.
+PKCS#11 is the de-facto standard to access cryptographic devices")
+ (license (list license:gpl2 license:bsd-3))))
+
+
(define-public yubico-piv-tool
(package
(name "yubico-piv-tool")

base-commit: f1a573067c7157a30e8d5e5b3443fee7fcb8af42
--
2.34.1
Zheng Junjie wrote 10 months ago
(name . Andy Tai)(address . atai@atai.org)(address . 70563-done@debbugs.gnu.org)
8734q9rszo.fsf@iscas.ac.cn
Andy Tai <atai@atai.org> writes:

Toggle quote (46 lines)
> * gnu/packages/security-token.scm (pkcs11-helper): New variable.
>
> Change-Id: Ib17e0cf209a6fe797d0c797829ba91091b719028
> ---
> gnu/packages/security-token.scm | 25 +++++++++++++++++++++++++
> 1 file changed, 25 insertions(+)
>
> diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
> index 35a8d4e216..939febd4e3 100644
> --- a/gnu/packages/security-token.scm
> +++ b/gnu/packages/security-token.scm
> @@ -394,6 +394,31 @@ (define-public opensc
> #15 standard and the PKCS #11 API.")
> (license license:lgpl2.1+)))
>
> +
> +(define-public pkcs11-helper
> + (package
> + (name "pkcs11-helper")
> + (version "1.30.0")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append
> + "https://github.com/OpenSC/pkcs11-helper/releases/download/pkcs11-helper-"
> + version "/pkcs11-helper-" version ".tar.bz2"))
> + (sha256
> + (base32 "1ac86jfj4qfwzbvsg6l9r4w4bbwxj2i9qi4dy1nz5aqcj6x1an2c"))))
> + (build-system gnu-build-system)
> + (inputs (list openssl pcsc-lite))
> + (native-inputs (list pkg-config))
> + (home-page "https://github.com/OpenSC/pkcs11-helper")
> + (synopsis "Library that simplifies the interaction with PKCS#11 providers")
> + (description
> + "Pkcs11-helper is a library that simplifies the interaction with
> +PKCS#11 providers for end-user applications. PKCS#11 is published standard.
> +PKCS#11 is the de-facto standard to access cryptographic devices")
> + (license (list license:gpl2 license:bsd-3))))
> +
> +
> (define-public yubico-piv-tool
> (package
> (name "yubico-piv-tool")
>
> base-commit: f1a573067c7157a30e8d5e5b3443fee7fcb8af42

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmZO1XsACgkQO1qpk+Gi
3/BVSw/+PGSF0bdHBw/iCO56LR/m7p27MwYiHycMYjnj4KSLcikvbmDo4qaa0Woa
cW7N0iEDzqieMnAI5UsjMvrvgddgGSRp3PjrFCxrl1H7DN2sTy6qo3KNZVvysrIB
BBcM5nEu0bcTdwtzOjcVSVlQspARzoczsIvUpOj4ebIoeBnDKf+mH/NiYqEc1UL2
X71ZyvvQgZEfHpCefGMI2W41+AedJ37NnfVpYW+qOkjETlZDyLPcqB+GJO03i7cz
PcEPAnyiEEDEPV9lCAdmDukTCisEUv6lXRt82SclWZNk5ZHnUuqBsypXs9OWD8Ss
DqSPKrD06gUOVrv/+mxFRVIP1q2wrGmvS2WdciYK69gkTWyY9TFhOUg26yGFFHA8
9ksgkDuVD7Cfw3Y2aoGmrIe6Jvs1td5KO0x718cTvXEYtYz8HZKdpHNFO6lRVsJ7
8IdqNRRtGnLll4hQ8vS4Xa4SAKPZ1B1LUTw/QnNpkGYNInkJ5hBJfXM5/uJB0dhG
8z2WBOejXQNIhJKy0TLKSBWsZU2WGYClfFnPfRqQ0Kowaws53pRrlu2fzi7SSLv1
KGIVeRmAp5ioIEBXdTCTEw8UfUhugSk3txN6faMpK4f4isR/U0IZ+QJikoc52bZG
16YgRwM7fTgtpr7Ef6/nfQthxg822HQO8UkeJH7fTE4J06J8uzE=
=TfMR
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70563@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70563
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help