[PATCH] gnu: Resolve poweron script failure vmware-open-vm-tools

  • Open
  • quality assurance status badge
Details
One participant
  • Deslauriers, Douglas
Owner
unassigned
Submitted by
Deslauriers, Douglas
Severity
normal
D
D
Deslauriers, Douglas wrote on 24 Apr 21:06 +0200
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
5f2b8c79eaf48572570daad90387ecbaf3d5bed9.camel@vector.com
Hello Guix,
I have attached my first patch. This resolves a failing script in the
`vmware-open-vm-tools` package due to the package's daemon trying to
execute a script in the `/etc/` directory. A substitution has been
added so that the built binary will now execute that script from the
proper location in the store.
I ran `guix style` on this package and it seems that the entire package
definition isn't formatted, but I didn't add that to my patch since
that would beyond the scope of this change. Please let me know if there
is anything else I should update or change.
Regards,
Douglas Deslauriers
From 299233a887e97b6fcb1e40a2fd2eb0a1d1556d67 Mon Sep 17 00:00:00 2001
Message-ID: <299233a887e97b6fcb1e40a2fd2eb0a1d1556d67.1713980728.git.Douglas.Deslauriers@vector.com>
From: Douglas Deslauriers <Douglas.Deslauriers@vector.com>
Date: Wed, 24 Apr 2024 08:41:20 -0400
Subject: [PATCH] gnu: Resolve poweron script failure open-vm-tools.

* gnu/packages/virtualization.scm (vmware-open-vm-tools,
vmware-open-vm-tools-gtk)[arguments]: Added a substitution to
provide a proper path to the store for running the power-on script.

Change-Id: I9671d3c134e3aafdc610d2c168be46dbc95bdea8
---
gnu/packages/virtualization.scm | 4 ++++
1 file changed, 4 insertions(+)

Toggle diff (26 lines)
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 34cccd6550..00cc50aa37 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -32,6 +32,7 @@
;;; Copyright © 2023 Ahmad Draidi <a.r.draidi@redscript.org>
;;; Copyright © 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2023, 2024 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2024 Douglas Deslauriers <Douglas.Deslauriers@vector.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1787,6 +1788,9 @@ (define-public vmware-open-vm-tools
(("/bin/fusermount3")
(string-append
#$(this-package-input "fuse") "/bin/fusermount3")))
+ (substitute* "lib/guestApp/guestApp.c"
+ (("/etc/vmware-tools")
+ (string-append #$output "/etc/vmware-tools")))
;; XXX: This part might need more testing with shutdown and halt
;; commands provided by Shepherd.
(substitute* "lib/system/systemLinux.c"

base-commit: e2ba93373a29ddf5d5754368957e89f3b426bb0a
--
2.41.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 70560@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70560
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch