[PATCH] gnu: cairo: Fix cross-compilation.

  • Done
  • quality assurance status badge
Details
3 participants
  • Liliana Marie Prikler
  • Ludovic Courtès
  • Zheng Junjie
Owner
unassigned
Submitted by
Zheng Junjie
Severity
normal
Z
Z
Zheng Junjie wrote on 24 Apr 05:17 +0200
(address . guix-patches@gnu.org)
c496085ed765e3e8cc037c0f9fa86d79b9871bf4.1713928638.git.zhengjunjie@iscas.ac.cn
* gnu/packages/gtk.scm (cairo)[arguments]: When
cross-compilation, Add fix-cross-compile phase.

Change-Id: I3579bb1249c749ee5f164bb4dd47f585b181c2bc
---
gnu/packages/gtk.scm | 16 ++++++++++++++--
1 file changed, 14 insertions(+), 2 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index b0098e780e..8fcd3ed1f3 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -34,7 +34,7 @@
;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2023 Sergiu Ivanov <sivanov@colimite.fr>
-;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2023, 2024 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2024 John Kehayias <john.kehayias@protonmail.com>
;;;
@@ -182,7 +182,19 @@ (define cairo
`(#:tests? #f ; see http://lists.gnu.org/archive/html/bug-guix/2013-06/msg00085.html
#:glib-or-gtk? #t
#:configure-flags
- (list "-Dtests=disabled")))
+ (list "-Dtests=disabled")
+ ,@(if (%current-target-system)
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-cross-compile
+ (lambda _
+ ;; XXX: Let meson-build-system can customize the property
+ (substitute* "meson.build"
+ (("'ipc_rmid_deferred_release', 'auto'")
+ ;; see https://github.com/NixOS/nixpkgs/blob/df51f2293e935e85f6a2e69bcf89a40cb31bbc3d/pkgs/development/libraries/cairo/default.nix#L65
+ ;; XXX: check it on hurd.
+ "'ipc_rmid_deferred_release', 'true'"))))))
+ '())))
(native-inputs
`(,@(if (target-hurd?)
'()

base-commit: d115af1bcc48f07a40dafd94d1d00926d446d068
--
2.41.0
L
L
Liliana Marie Prikler wrote on 24 Apr 06:18 +0200
ecc1fb038795ddab619748497f3120a59bc882f5.camel@gmail.com
Am Mittwoch, dem 24.04.2024 um 11:17 +0800 schrieb Zheng Junjie:
Toggle quote (5 lines)
> * gnu/packages/gtk.scm (cairo)[arguments]: When
> cross-compilation, Add fix-cross-compile phase.
>
> Change-Id: I3579bb1249c749ee5f164bb4dd47f585b181c2bc
> ---
Haven't checked that it works yet, but at least lexically it LGTM.
For the commit message – particularly the ChangeLog portion – I'd say
"Add ‘fix-cross-compilation’ phase when cross-compiling." and adjust
the phase name accordingly.

Cheers
Z
Z
Zheng Junjie wrote on 24 Apr 06:34 +0200
[PATCH v2] gnu: cairo: Fix cross-compilation.
(address . 70546@debbugs.gnu.org)
e7e54c3b1fa933c57ceddcb2c2524cdcd5154fad.1713933265.git.zhengjunjie@iscas.ac.cn
* gnu/packages/gtk.scm (cairo)[arguments]: Add ‘fix-cross-compilation’ phase
when cross-compiling.

Change-Id: I3579bb1249c749ee5f164bb4dd47f585b181c2bc
---
gnu/packages/gtk.scm | 16 ++++++++++++++--
1 file changed, 14 insertions(+), 2 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index b0098e780e..678bc89378 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -34,7 +34,7 @@
;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2023 Sergiu Ivanov <sivanov@colimite.fr>
-;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2023, 2024 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2024 John Kehayias <john.kehayias@protonmail.com>
;;;
@@ -182,7 +182,19 @@ (define cairo
`(#:tests? #f ; see http://lists.gnu.org/archive/html/bug-guix/2013-06/msg00085.html
#:glib-or-gtk? #t
#:configure-flags
- (list "-Dtests=disabled")))
+ (list "-Dtests=disabled")
+ ,@(if (%current-target-system)
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-cross-compilation
+ (lambda _
+ ;; XXX: Let meson-build-system can customize the property
+ (substitute* "meson.build"
+ (("'ipc_rmid_deferred_release', 'auto'")
+ ;; see https://github.com/NixOS/nixpkgs/blob/df51f2293e935e85f6a2e69bcf89a40cb31bbc3d/pkgs/development/libraries/cairo/default.nix#L65
+ ;; XXX: check it on hurd.
+ "'ipc_rmid_deferred_release', 'true'"))))))
+ '())))
(native-inputs
`(,@(if (target-hurd?)
'()

base-commit: d115af1bcc48f07a40dafd94d1d00926d446d068
--
2.41.0
L
L
Ludovic Courtès wrote on 13 May 14:47 +0200
(name . Zheng Junjie)(address . zhengjunjie@iscas.ac.cn)
87jzjxanfa.fsf@gnu.org
Hi,

Zheng Junjie <zhengjunjie@iscas.ac.cn> skribis:

Toggle quote (5 lines)
> * gnu/packages/gtk.scm (cairo)[arguments]: Add ‘fix-cross-compilation’ phase
> when cross-compiling.
>
> Change-Id: I3579bb1249c749ee5f164bb4dd47f585b181c2bc

[...]

Toggle quote (7 lines)
> + ,@(if (%current-target-system)
> + `(#:phases
> + (modify-phases %standard-phases
> + (add-after 'unpack 'fix-cross-compilation
> + (lambda _
> + ;; XXX: Let meson-build-system can customize the property

s/can customize/customize/

Toggle quote (7 lines)
> + (substitute* "meson.build"
> + (("'ipc_rmid_deferred_release', 'auto'")
> + ;; see https://github.com/NixOS/nixpkgs/blob/df51f2293e935e85f6a2e69bcf89a40cb31bbc3d/pkgs/development/libraries/cairo/default.nix#L65
> + ;; XXX: check it on hurd.
> + "'ipc_rmid_deferred_release', 'true'"))))))
> + '())))

Otherwise LGTM, thanks!

Ludo’.
Z
Z
Zheng Junjie wrote on 13 May 18:37 +0200
(name . Ludovic Courtès)(address . ludo@gnu.org)
877cfxzn0j.fsf@iscas.ac.cn
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (31 lines)
> Hi,
>
> Zheng Junjie <zhengjunjie@iscas.ac.cn> skribis:
>
>> * gnu/packages/gtk.scm (cairo)[arguments]: Add ‘fix-cross-compilation’ phase
>> when cross-compiling.
>>
>> Change-Id: I3579bb1249c749ee5f164bb4dd47f585b181c2bc
>
> [...]
>
>> + ,@(if (%current-target-system)
>> + `(#:phases
>> + (modify-phases %standard-phases
>> + (add-after 'unpack 'fix-cross-compilation
>> + (lambda _
>> + ;; XXX: Let meson-build-system can customize the property
>
> s/can customize/customize/
>
>> + (substitute* "meson.build"
>> + (("'ipc_rmid_deferred_release', 'auto'")
>> + ;; see https://github.com/NixOS/nixpkgs/blob/df51f2293e935e85f6a2e69bcf89a40cb31bbc3d/pkgs/development/libraries/cairo/default.nix#L65
>> + ;; XXX: check it on hurd.
>> + "'ipc_rmid_deferred_release', 'true'"))))))
>> + '())))
>
> Otherwise LGTM, thanks!
>
> Ludo’.

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmZCQbwACgkQO1qpk+Gi
3/Ai/w/8CaStXqy4TM9pYK8O3oGJ1+AKNot/iljXLVBRFwitXPlk2zrMGvgVPeoo
8pFnY28H9Tw6MM2djn1D2/H2z6mfj3m0oqKUgm7gSobo7N2u/FowmfG6Zdo6Rm0X
ToK2t80Vnrmyw7MXbzg7BX1LHJSKdVm0xKIxMP8A+6QzQP9+6KE5ZqBJbWpZ3L18
JwWnVt8EvQy7Ty+dDiFOROIJelHmC2dJt4ACZSJc8E3XP53yjKqrkcVTH17oweee
Ag9LZMUYIWIEouVACabVGCGv1Ed7hGQ1HoQ+5bKHNK0NTUG2M+b+31u9Ogx6lMu1
Ecd7XElNXY5a70VVZnqyJX8b7z8J11WrahgdGaxRp6TPCYzjAd1u13VxoChTMSG9
lbfYHlftkcNshuuOEBvag3kTs86LRbvO5qZzmz+oPAEm++/Ga9BmI1skV/OvvXnc
iwT5Fj6g5/BZa8Kp5Ftwr53FDqNOLlpefdCxmzbnjxrazSO9OfKpRu/r7E4r8Pmd
CJiwzLRllH5bnO1MEirZpDMAD10RjPiW6CJYXBCl1AZ9HSPTYzrEFrqqlNZrI8Lq
PtmaYLwh2ImXpvv8lbBOE/8he0W7bjqsxiq+M+6n5F215IaqJLN3yqr8ypd2g1+N
GslprlMRhH8FdWxTbfSP/ZQDhK9lkPuUlp7Hx617vRYGrwn3Pfc=
=67t6
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70546@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70546
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch