[PATCH] gnu: retroarch: Fix OpenGL core and Vulkan drivers.

  • Done
  • quality assurance status badge
Details
2 participants
  • iyzsong
  • Nicolas Goaziou
Owner
unassigned
Submitted by
iyzsong
Severity
normal
I
I
iyzsong wrote on 22 Apr 15:45 +0200
(address . guix-patches@gnu.org)(name . ???)(address . iyzsong@member.fsf.org)
aff3cb8e23c19f6c03d0cc7652ee455573ecd8e7.1713793535.git.iyzsong@member.fsf.org
From: ??? <iyzsong@member.fsf.org>

* gnu/packages/emulators.scm (retroarch)[arguments]: Ignore check result for
HAVE_GLSLANG_HLSL in the configure phase.

Change-Id: I3ba110b834acca25ada0e680a6bcb879b4db96f4
---
gnu/packages/emulators.scm | 4 ++++
1 file changed, 4 insertions(+)

Toggle diff (19 lines)
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index a935808da5..08894bd685 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -1462,6 +1462,10 @@ (define-public retroarch
(("/usr/local/share/wayland-protocols")
(string-append wayland-protocols "/share/wayland-protocols")))
+ ;; Without HLSL, we can still enable GLSLANG and Vulkan support.
+ (substitute* "qb/config.libs.sh"
+ (("[$]HAVE_GLSLANG_HLSL") "notcare"))
+
;; The configure script does not yet accept the extra arguments
;; (like ‘CONFIG_SHELL=’) passed by the default configure phase.
(invoke

base-commit: 30de2751094fa7cceeb692c656296209970d61cb
--
2.41.0
N
N
Nicolas Goaziou wrote on 6 May 13:52 +0200
(name . iyzsong--- via Guix-patches via)(address . guix-patches@gnu.org)
87zft3yx76.fsf@nicolasgoaziou.fr
Hello,

iyzsong--- via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (3 lines)
> * gnu/packages/emulators.scm (retroarch)[arguments]: Ignore check result for
> HAVE_GLSLANG_HLSL in the configure phase.

Applied. Thank you.

Regards,
--
Nicolas Goaziou
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70514@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70514
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch