[PATCH] gnu: isc-dhcp: Make dhclien-script hooks work.

  • Done
  • quality assurance status badge
Details
3 participants
  • Alexey Abramov
  • Christopher Baines
  • Nicolas Graves
Owner
unassigned
Submitted by
Alexey Abramov
Severity
normal
A
A
Alexey Abramov wrote on 19 Apr 08:30 +0200
(address . guix-patches@gnu.org)
20240419063038.21727-1-levenson@mmer.org
dhclient provides a hook mechanism for users. In order to run these
hooks, dhclient-script uses run-parts to run all the executable files
found in requested directory. run-parts is part of debianutils
packages.

* gnu/packages/admin.scm (isc-dhcp)[inputs]: Add "debianutils" to
provide access to run-parts.
---
gnu/packages/admin.scm | 10 ++++++++--
1 file changed, 8 insertions(+), 2 deletions(-)

Toggle diff (44 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index b60857b264..0bf96af835 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -122,6 +122,7 @@ (define-module (gnu packages admin)
#:use-module (gnu packages curl)
#:use-module (gnu packages cyrus-sasl)
#:use-module (gnu packages datastructures)
+ #:use-module (gnu packages debian)
#:use-module (gnu packages dns)
#:use-module (gnu packages elf)
#:use-module (gnu packages file)
@@ -1563,7 +1564,8 @@ (define-public isc-dhcp
(coreutils (assoc-ref inputs "coreutils*"))
(inetutils (assoc-ref inputs "inetutils"))
(grep (assoc-ref inputs "grep*"))
- (sed (assoc-ref inputs "sed*")))
+ (sed (assoc-ref inputs "sed*"))
+ (debianutils (assoc-ref inputs "debianutils")))
(substitute* "client/scripts/linux"
(("/sbin/ip")
(search-input-file inputs "/sbin/ip")))
@@ -1578,7 +1580,7 @@ (define-public isc-dhcp
,(map (lambda (dir)
(string-append dir "/bin:"
dir "/sbin"))
- (list inetutils coreutils grep sed))))))))))
+ (list inetutils coreutils grep sed debianutils))))))))))
(native-inputs
(list config perl file))
@@ -1589,6 +1591,10 @@ (define-public isc-dhcp
'()
`(("iproute" ,iproute)))
+ ;; dhclient-script provides hooks to users and uses run-parts in
+ ;; order to list users defined hooks.
+ ("debianutils" ,debianutils)
+
;; isc-dhcp bundles a copy of BIND, which has proved vulnerable
;; in the past. Use a BIND-VERSION of our choosing instead.
("bind-source-tarball"
--
2.41.0
N
N
Nicolas Graves wrote on 13 May 14:18 +0200
QA review for 70469
87v83h29cr.fsf@ngraves.fr
user guix
usertag 70469 + reviewed-looks-good
thanks

Guix QA review form submission:
LGTM.

Items marked as checked: Lint warnings, Package builds, Commit messages

--
Best regards,
Nicolas Graves
C
C
Christopher Baines wrote on 13 May 22:45 +0200
Re: [bug#70469] [PATCH] gnu: isc-dhcp: Make dhclien-script hooks work.
(name . Alexey Abramov via Guix-patches via)(address . guix-patches@gnu.org)
87ttj11lwr.fsf@cbaines.net
Alexey Abramov via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (11 lines)
> dhclient provides a hook mechanism for users. In order to run these
> hooks, dhclient-script uses run-parts to run all the executable files
> found in requested directory. run-parts is part of debianutils
> packages.
>
> * gnu/packages/admin.scm (isc-dhcp)[inputs]: Add "debianutils" to
> provide access to run-parts.
> ---
> gnu/packages/admin.scm | 10 ++++++++--
> 1 file changed, 8 insertions(+), 2 deletions(-)

Thanks both, I've pushed this to master as
7d6d54202ab609877b14490e487a1df106072b7d.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmZCe9RfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xd5sA/9H+zCIw0o3TdvrO6rDbD+go/Md4AuD7Nu
MehqOsDAWoPa78g8L/WvpzfXOsitSmzyf2JT16SFZYlRbzEdEgasT1fC+WH6iKXX
Q7Mtyn1w6nb6kVKZvVbjVaHIYzfGb/CwFxK8oHKB/f3PAChdgX9cMbwdgLp3lTN0
BQI/4+3nEJx2HZIcfP0BAC1IhHv0//mSGcUJLcUtyg2ou2BB0smHOMUpcoBFgq/L
fVwonYrgK3kgn/CcAo5zFUsdSrRofNQ2sTYgWnPwnCrzFbqQcbMKT69KUvvry8BT
zq8mD1X69RDizXAhF+74cDz6MWRqaQFFaLnv75RKK/zV4Ry0LVwi+Sh2Y6WCF4qR
l0OwVhSRZQD/5RcNCRjrCYAmr8VTUnFmehHTgqkDH5Sg+YnqtIlP9b32uDTjMayG
v6X8sPz3HfD+Hu6slYFwGfy2/nk+/++gsKUzX17WBKGTnw9jdAIHS7w68cC4RkKL
l6gjZxtDXp/JQiv2fLcyr/XxVcSnNN18K1dAiICYK+FoxduG9FUTxVtv6ID2eFm9
kpw8RXOoXlM8sMo/L2NE4IH24lULRKCZDZVeGtHYDwNDdniBn82sNRw9CO10K5Dw
5usZF7SnDqNO6A03/I4/knzWsAD2PvqgoWoDyHwbBeNOLbWMppIDj9QV2gf2prF/
c9oSEiDzwtg=
=v6yL
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 70469@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70469
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch