customize-kernel does not accept inferior package

  • Open
  • quality assurance status badge
Details
One participant
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Ricardo Wurmus
Severity
normal
R
R
Ricardo Wurmus wrote on 17 Apr 10:20 +0200
(address . bug-guix@gnu.org)
87o7a8763f.fsf@elephly.net
Especially on underpowered aarch64 systems with custom kernels it may be
desirable to avoid rebuilding the kernel on "guix deploy" or "guix
system reconfigure". It's possible to use an inferior to pin the kernel
to a known good version.

Unfortunately, this doesn't work when attempting to customize the kernel
with "customize-kernel" as that procedure doesn't accept an inferior as
an input package.

--
Ricardo
R
R
Ricardo Wurmus wrote on 17 Apr 10:37 +0200
(address . 70433@debbugs.gnu.org)
87il0g75bd.fsf@elephly.net
Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (9 lines)
> Especially on underpowered aarch64 systems with custom kernels it may be
> desirable to avoid rebuilding the kernel on "guix deploy" or "guix
> system reconfigure". It's possible to use an inferior to pin the kernel
> to a known good version.
>
> Unfortunately, this doesn't work when attempting to customize the kernel
> with "customize-kernel" as that procedure doesn't accept an inferior as
> an input package.

"customize-kernel" works by inheriting from a base package. It then
augments the arguments.

Inheriting from an inferior package does not work, though. Nor is there
a procedure to obtain the arguments of an inferior package. The naïve
approach of simply defining inferior-package-arguments fails:

Toggle snippet (12 lines)
(define (inferior-package-arguments package)
"Return the arguments field of PACKAGE."
(inferior-package-field package 'package-arguments))

...

(inferior-package-arguments linux-libre-arm64-generic/fixed)
ice-9/boot-9.scm:1685:16: In procedure raise-exception:
socket:20:156: Unknown # object: "#<"


--
Ricardo
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 70433@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70433
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch