[PATCH] gnu: ruby-ruby-memcheck.

  • Done
  • quality assurance status badge
Details
One participant
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal
C
C
Christopher Baines wrote on 15 Apr 10:26 +0200
(address . guix-patches@gnu.org)
0161cd7e715da4b3758471c77a63f67b5736665e.1713169618.git.mail@cbaines.net
Use valgrind rather than valgrind/interactive, as this doesn't have gdb as an
input, which makes it easier to update gdb.

* gnu/packages/ruby.scm (ruby-ruby-memcheck)[inputs]: Use valgrind.

Change-Id: Icfcee2c27fc41e68e1a34b38c043ece188cc56af
---
gnu/packages/ruby.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 0541bb9562..5e34109a59 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -10114,7 +10114,7 @@ (define-public ruby-ruby-memcheck
(("%x\\(git ls-files -z)")
"`git ls-files -z`")))))))
(native-inputs (list ruby-rake-compiler ruby-rspec))
- (inputs (list valgrind/interactive))
+ (inputs (list valgrind))
(propagated-inputs (list ruby-nokogiri))
(synopsis "Valgrind memcheck tool for Ruby")
(description "The @code{ruby_memcheck} gem provides a sane way to use

base-commit: 58a0c85ad35db14c9fed7d5791b43d30882e13bf
--
2.41.0
C
C
Christopher Baines wrote on 19 May 14:16 +0200
(address . 70394-done@debbugs.gnu.org)
8734qeatdw.fsf@cbaines.net
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (7 lines)
> Use valgrind rather than valgrind/interactive, as this doesn't have gdb as an
> input, which makes it easier to update gdb.
>
> * gnu/packages/ruby.scm (ruby-ruby-memcheck)[inputs]: Use valgrind.
>
> Change-Id: Icfcee2c27fc41e68e1a34b38c043ece188cc56af

I've pushed this to master now as
a47cab5d286f81278af6e26a359f6429fd085e10.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmZJ7btfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XeGZQ//bymfDUA9c4gYz5PVVUDNcN8gYEzIrDr4
cK2hHS9wS1w3s8Gam51+hWaNfwjE3z9z2JMovmHtzOVY8dtBebu/zwHs+84ZKIjc
IAtSxPz1q8zQ9cE9kfiM3jKIcW50fPJdP1yvNEr6ro08X1mitKWB7yLu3Lavo1Dh
O+NThiy99otZma61h9cOirMMfhQYNrNaFV9A7/1TmQkvrfML+HaMY9mD0YRTb2mw
ETPO8v7RF+8Ba67rBFWHWlrNdEhtnDbUJy2oum/+LHYVV/E+O4mTqcsAfrerzd2l
Yzo9inHrFD24EB4mXE/XutnOILn3S6Q5Ix6Ev8hxyf+ra4L9pyWLu6w+ffXfRo11
/yeEEX3FoSTdEFMv9gkeFgY7GXPTDFtiZXXyxwERLxbI7mk8ueU0BEABZ/zjko+5
EQgpHtcKoGYcbvzg6ric3XLcM6EaisuvqahTgISbkiJOOP/4o7GF/nD5zxsE2xow
9qN20CwTciwxQhS83QV2wWxKuZ6uAE2Swr+iErujrkeK2YWYKN0pys3bjOdpnVSO
hxRJw8VPpqOt4MLIKYcGF/aBcF5t17s7o4ctvhZ3acb2s+HHapqm2dTHZpHFy5lA
JANO/4C+EgcIHUjl6a4/bA1or1FEkTuRw090LTsqDgKoIXxwygJHyVZrpyZa2oX/
9R8/YDCHVbE=
=KxO0
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70394@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70394
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch