[PATCH] gnu: python-pydevd: Use gdb/pinned.

  • Open
  • quality assurance status badge
Details
4 participants
  • Lars-Dominik Braun
  • Ludovic Courtès
  • Christopher Baines
  • Nicolas Graves
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal
C
C
Christopher Baines wrote on 15 Apr 10:25 +0200
(address . guix-patches@gnu.org)
58a0c85ad35db14c9fed7d5791b43d30882e13bf.1713169547.git.mail@cbaines.net
To allow gdb to be updated more easily.

* gnu/packages/python-xyz.scm (python-pydevd)[inputs]: Use gdb/pinned.

Change-Id: Icf417f89933bc190bf4c0d869c199cfe50d463ef
---
gnu/packages/python-xyz.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 92566abfed..a19422aa4a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16471,7 +16471,7 @@ (define-public python-pydevd
python-pytest-xdist
python-trio
python-untangle))
- (inputs (list coreutils gdb procps))
+ (inputs (list coreutils gdb/pinned procps))
(home-page "https://github.com/fabioz/PyDev.Debugger/")
(synopsis "Python debugger")
(description "PyDev.Debugger is a capable Python debugger used in PyDev

base-commit: 4e7337536ba41e888a601c92fada8a4adca9d2c6
--
2.41.0
L
L
Ludovic Courtès wrote on 15 Apr 18:27 +0200
(name . Christopher Baines)(address . mail@cbaines.net)
87o7aazj45.fsf@gnu.org
Hi!

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (6 lines)
> To allow gdb to be updated more easily.
>
> * gnu/packages/python-xyz.scm (python-pydevd)[inputs]: Use gdb/pinned.
>
> Change-Id: Icf417f89933bc190bf4c0d869c199cfe50d463ef

[...]

Toggle quote (5 lines)
> - (inputs (list coreutils gdb procps))
> + (inputs (list coreutils gdb/pinned procps))
> (home-page "https://github.com/fabioz/PyDev.Debugger/")
> (synopsis "Python debugger")

If PyDev uses GDB, then it’ll be stuck with an older version of GDB?
Maybe that’s OK? (I know nothing about PyDev and how it uses GDB so I
can’t really judge whether it’s OK.)

Ludo’.
C
C
Christopher Baines wrote on 17 Apr 15:43 +0200
(name . Ludovic Courtès)(address . ludo@gnu.org)
87ttk0rtox.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (21 lines)
> Hi!
>
> Christopher Baines <mail@cbaines.net> skribis:
>
>> To allow gdb to be updated more easily.
>>
>> * gnu/packages/python-xyz.scm (python-pydevd)[inputs]: Use gdb/pinned.
>>
>> Change-Id: Icf417f89933bc190bf4c0d869c199cfe50d463ef
>
> [...]
>
>> - (inputs (list coreutils gdb procps))
>> + (inputs (list coreutils gdb/pinned procps))
>> (home-page "https://github.com/fabioz/PyDev.Debugger/")
>> (synopsis "Python debugger")
>
> If PyDev uses GDB, then it’ll be stuck with an older version of GDB?
> Maybe that’s OK? (I know nothing about PyDev and how it uses GDB so I
> can’t really judge whether it’s OK.)

I don't really know either, but at least this will allow updating gdb
without rebuilding a bunch of Python things.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmYf0e5fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XdzkA//b2svTnoyu9W7REBibVNKpZsLylW6yNz1
JLZtI3xm3oBi37y16k90zvJ0xZXphgJODag+ZjOujWW74Pawl7W9xfNfcbL/nX9W
elQYMudAOjFY6g2Wp+inv4cb1RXj5dvFFRqzWbZtQta5zLRIm/B8dvrPL2MJ5xwU
n2Nplez51XPuge3P2P7B8xNxMGfv721UODd3uhZbYIVWsGlFwXv2tnXk4XiFJths
4n3BK/0Fe9UHlp5I/xAkxZhMrJnqFLlBa+Ft76k9Ps1qaypNdGDfMhiAWnP7uSMx
1Ne1zTzZwUiODCkw9hbXi9eTPXyiwmY+PEpqY87L9JLoBCGMDMBicSu6wdw5iWui
xWsUlOD1SRd0a+TP/A8q9/wHEO+sVT6dfCNI98rsWUYWgQET8z+qbFQGdkm4+wW6
KxFzz1j1+JE4EDmFkGL612jxjQMSrFYu2NggGqqG7Ip1+i21teg9m2zaizuvD1EQ
bUDwryT2uv6xmIgYp4J+m9OBXSLjo2yLrKWNio72z/zkV3EhoGJE1MYhsm7OscU2
WXCKZl0WSF/mbnlL3mIP262HfUJFhk2SXTV109I+imEeGA/Fy7tINULxqASPxMUL
nVCaC9rSHT1iHKqUF0mgfGqzR+ByUnP9cUjMNDn+rFQvtEi9oal9yldnTRFzL504
LG0RXmhOzA4=
=OS8Q
-----END PGP SIGNATURE-----

L
L
Lars-Dominik Braun wrote on 25 Apr 17:09 +0200
(name . Christopher Baines)(address . mail@cbaines.net)
ZipyIWiBNAJdpuI9@noor.fritz.box
Hi Chris,

Toggle quote (7 lines)
> > If PyDev uses GDB, then it’ll be stuck with an older version of GDB?
> > Maybe that’s OK? (I know nothing about PyDev and how it uses GDB so I
> > can’t really judge whether it’s OK.)
>
> I don't really know either, but at least this will allow updating gdb
> without rebuilding a bunch of Python things.

I don’t see anything that would prevent pydevd running on a pinned/older
GDB version. We might want to verify when we update python-pydevd, but
right now it just attaches to the process and injects a shared object
– that’s all. So, LGTM.

Lars
L
L
Ludovic Courtès wrote on 1 May 11:53 +0200
(name . Lars-Dominik Braun)(address . lars@6xq.net)
87sez17ta1.fsf@gnu.org
Hi,

Lars-Dominik Braun <lars@6xq.net> skribis:

Toggle quote (12 lines)
>> > If PyDev uses GDB, then it’ll be stuck with an older version of GDB?
>> > Maybe that’s OK? (I know nothing about PyDev and how it uses GDB so I
>> > can’t really judge whether it’s OK.)
>>
>> I don't really know either, but at least this will allow updating gdb
>> without rebuilding a bunch of Python things.
>
> I don’t see anything that would prevent pydevd running on a pinned/older
> GDB version. We might want to verify when we update python-pydevd, but
> right now it just attaches to the process and injects a shared object
> – that’s all. So, LGTM.

OK, thanks for checking. Go for it, Chris!

Ludo’.
N
N
Nicolas Graves wrote on 18 May 14:49 +0200
control message for bug #71037
(address . control@debbugs.gnu.org)
87zfsncmkf.fsf@ngraves.fr
block 71037 by 70393
quit


--
Best regards,
Nicolas Graves
L
L
Ludovic Courtès wrote on 24 Oct 14:56 +0200
[PATCH v2] gnu: python-pydevd: Use gdb/pinned.
(address . 70393@debbugs.gnu.org)
88f587f560ce0f31dc1cc9eb5dcb8850c97fb81a.1729774524.git.ludo@gnu.org
From: Christopher Baines <mail@cbaines.net>

To allow gdb to be updated more easily.

* gnu/packages/python-xyz.scm (python-pydevd)[inputs]: Use gdb/pinned.

Change-Id: Icf417f89933bc190bf4c0d869c199cfe50d463ef
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
---
gnu/packages/python-xyz.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Dear qa.guix, could you please build this for us?

Ludo'.

Toggle diff (17 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b58eb1ff88..95c33342b6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17093,7 +17093,7 @@ (define-public python-pydevd
python-pytest-xdist
python-trio
python-untangle))
- (inputs (list coreutils gdb procps))
+ (inputs (list coreutils gdb/pinned procps))
(home-page "https://github.com/fabioz/PyDev.Debugger/")
(synopsis "Python debugger")
(description "PyDev.Debugger is a capable Python debugger used in PyDev

base-commit: f125143d64c3fac8c9576a55b48331cbf6096460
--
2.46.0
L
L
Ludovic Courtès wrote on 24 Oct 14:57 +0200
control message for bug #73615
(address . control@debbugs.gnu.org)
87r0854q1t.fsf@gnu.org
block 73615 by 70393
quit
N
N
Nicolas Graves wrote on 3 Nov 16:32 +0100
[PATCH] gnu: python-pydevd: Use gdb/pinned.
8734k8qqo7.fsf@ngraves.fr
Hi Ludo,

I have two/three patches updating python-debugpy to its latest version,
also refreshing pydevd in the process. Can I append them in this patch
series ? I've checked that it updates properly until python-ipykernel,
so it is probably correct for other packages that most likely rely on
ipykernel rather than pydevd api.

Also, this have more than 400 rebuilds, will that not abort the build on
QA once the derivation is evaluated?

By the way, is there a way to make QA prioritize some builds? Like
[security fixes] or [important] tags? I guess that would be welcome if
users don't take advantage of that too much.

--
Best regards,
Nicolas Graves
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 70393@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70393
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch