[PATCH] gnu: fossil: update to 2.24

  • Open
  • quality assurance status badge
Details
One participant
  • ashish.is
Owner
unassigned
Submitted by
ashish.is
Severity
normal
A
A
ashish.is wrote on 15 Apr 01:54 +0200
[PATCH] gnu: fossil: update to 2.23
(address . guix-patches@gnu.org)(name . Ashish SHUKLA)(address . ashish.is@lostca.se)
12bbabebdc8c229f8a000858cfb96495a7259d61.1713138890.git.ashish.is@lostca.se
From: Ashish SHUKLA <ashish.is@lostca.se>

* gnu/packages/version-control.scm (fossil): Update to 2.23.

Signed-off-by: Ashish SHUKLA <ashish.is@lostca.se>
Change-Id: I1794e75cedc4a9bd878850e25686674cecd360e0
---
gnu/packages/version-control.scm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 19f128d45f..923f67a6a4 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -3015,17 +3015,17 @@ (define-public git-annex-remote-rclone
(define-public fossil
(package
(name "fossil")
- (version "2.20")
+ (version "2.23")
(source
(origin
(method url-fetch)
(uri (string-append
"https://www.fossil-scm.org/home/tarball/"
- "210e89a0597f225f49722b096cf5563bf193e920e02a9bd38503a906deacd416"
+ "47362306a7dd7c6fc3cab77cebe5d25469b0a9448479d9718eb5c49c8337b29"
"/fossil-src-" version ".tar.gz"))
;; XXX: Currently the above hash must be manually updated.
(sha256
- (base32 "08g7img88n2nwcdkpzmg4aqbp2iy40nllgas53502dspm97ym4h8"))
+ (base32 "1r1kabvmlhc0qgyq8g9zhq8i0123x9dba9b71j4xc71k14kfqjm9"))
(modules '((guix build utils)))
(snippet
'(delete-file-recursively "compat"))))
@@ -3035,7 +3035,7 @@ (define-public fossil
which ;for tests only
ed)) ;ditto
(inputs
- (list openssl zlib sqlite))
+ (list openssl zlib sqlite-next))
(arguments
`(#:configure-flags (list "--with-openssl=auto"
"--disable-internal-sqlite")

base-commit: 4e7337536ba41e888a601c92fada8a4adca9d2c6
--
2.41.0
A
A
ashish.is wrote on 22 May 01:59 +0200
[PATCH v2] gnu: fossil: Update to 2.24.
(address . 70389@debbugs.gnu.org)(name . Ashish SHUKLA)(address . ashish.is@lostca.se)
b96ed1d29cfc8601ccd8ead081ff931b11f52eb3.1716335986.git.ashish.is@lostca.se
From: Ashish SHUKLA <ashish.is@lostca.se>

* gnu/packages/version-control.scm (fossil): Update to 2.24.
[sources]: Switch to a simpler tarball URL. Add patches from
upstream to fix unit-tests.
[inputs]: Switch to sqlite-next as fossil needs bleeding edge
sqlite.

Change-Id: Id0cac2634282a0a141e2b17cb423c25e8aacee38
---
gnu/packages/version-control.scm | 30 +++++++++++++++++++++++-------
1 file changed, 23 insertions(+), 7 deletions(-)

Toggle diff (59 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index c01eb9decd..d985c531d0 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -3068,19 +3068,35 @@ (define-public git-annex-remote-rclone
(license license:gpl3+)))
(define-public fossil
+ (define (fossil-patch name from to hash)
+ (origin (method url-fetch)
+ (uri (string-append "https://fossil-scm.org/home/vpatch?from=" from
+ "&to=" to))
+ (sha256 (base32 hash))
+ (file-name name)))
(package
(name "fossil")
- (version "2.20")
+ (version "2.24")
(source
(origin
(method url-fetch)
(uri (string-append
- "https://www.fossil-scm.org/home/tarball/"
- "210e89a0597f225f49722b096cf5563bf193e920e02a9bd38503a906deacd416"
- "/fossil-src-" version ".tar.gz"))
- ;; XXX: Currently the above hash must be manually updated.
+ "https://fossil-scm.org/home/tarball/version-" version "/fossil-" version ".tar.gz"))
(sha256
- (base32 "08g7img88n2nwcdkpzmg4aqbp2iy40nllgas53502dspm97ym4h8"))
+ (base32 "0k1gjvxbvvs98yspnf7nj6rb0c7yf60savq7jywbkgimd0bkrkcm"))
+ (patch-flags '("-p0"))
+ (patches `(,(fossil-patch "fossil-disable-tests.patch"
+ "8be0372c10510437"
+ "5ad708085a90365f"
+ "1b4svsrz7cr1zi6qfpavj3ddm6dr0966jbgkbvgjz79ljqmpiasf")
+ ,(fossil-patch "fossil-fix-json-test.patch"
+ "fb4e90b662803e47"
+ "17c01c549e73c6b8"
+ "12gjzyxs22g9grv7qbgp9jg133bgcsj74621s05fk82j3fc7z59g")
+ ,(fossil-patch "fossil-comment-utf-tests.patch"
+ "5ad708085a90365f"
+ "fb4e90b662803e47"
+ "05h2mb6g0840yq74x1cdj95jmqb95i75h6g5v0rzqdc994b96cd4")))
(modules '((guix build utils)))
(snippet
'(delete-file-recursively "compat"))))
@@ -3090,7 +3106,7 @@ (define-public fossil
which ;for tests only
ed)) ;ditto
(inputs
- (list openssl zlib sqlite))
+ (list openssl zlib sqlite-next))
(arguments
`(#:configure-flags (list "--with-openssl=auto"
"--disable-internal-sqlite")

base-commit: 413ef75f89ac337f7ac3331a862c7c8cdc88aa64
--
2.45.1
A
A
Ashish SHUKLA wrote on 22 May 02:19 +0200
retitle bug 70389
(address . control@debbugs.gnu.org)
080c62214ee3a2566e4390ace04eec44@lostca.se
retitle 70389 [PATCH] gnu: fossil: update to 2.24
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 70389@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70389
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch