Increase verbosity of diffoscope test suite

  • Done
  • quality assurance status badge
Details
One participant
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Vagrant Cascadian
Severity
normal
V
V
Vagrant Cascadian wrote on 11 Apr 21:50 +0200
(address . guix-patches@gnu.org)
87r0fb3cgx.fsf@wireframe
The attached patch increases the verbosity of the test suite, showing
each test on it's own line and provides a useful summary, often
including a reason why skipped tests were skipped.

This can be useful to help find additional packages to add for broader
test coverage, inspired by discussion in

This also reveals that the conditional to add "enjarify" to
native-inputs on x86_64 is not working correctly... and plausibly could
reveal other similar issues with other missing native-inputs.

live well,
vagrant
From b1475226dc655986e97445dca889d4b0c362215c Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@reproducible-builds.org>
Date: Thu, 11 Apr 2024 12:40:19 -0700
Subject: [PATCH] gnu: diffoscope: Increase test verbosity.

* gnu/packages/diffoscope.scm (diffoscope)[phases]: Replace 'check.
---
gnu/packages/diffoscope.scm | 5 +++++
1 file changed, 5 insertions(+)

Toggle diff (18 lines)
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index 3db52e5008..8106a6d258 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -139,6 +139,11 @@ (define (bin command)
(lambda _
;; This requires /sbin to be in $PATH.
(delete-file "tests/test_tools.py")))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; Increase verbosity of tests and provide a summary
+ (invoke "pytest" "-vv" "-r" "sxX"))))
(add-after 'install 'install-man-page
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
--
2.39.2
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZhg/HgAKCRDcUY/If5cW
qgW5AQDzQ7f7cJAMcFuWYQn+QzKZ232WSPuBPZYNO174a61EwAEA1OKOc9dj92dJ
gosZBACXOiuHDyy99tk3SlkjZve9Bg4=
=hxq0
-----END PGP SIGNATURE-----

V
V
Vagrant Cascadian wrote on 18 May 05:08 +0200
(name . Christopher Baines)(address . mail@cbaines.net)
87ed9zrf48.fsf@wireframe
On 2024-04-15, Christopher Baines wrote:
Toggle quote (31 lines)
> Vagrant Cascadian <vagrant@reproducible-builds.org> writes:
>
>> The attached patch increases the verbosity of the test suite, showing
>> each test on it's own line and provides a useful summary, often
>> including a reason why skipped tests were skipped.
>>
>> This can be useful to help find additional packages to add for broader
>> test coverage, inspired by discussion in
>> https://issues.guix.gnu.org/70293
>>
>> This also reveals that the conditional to add "enjarify" to
>> native-inputs on x86_64 is not working correctly... and plausibly could
>> reveal other similar issues with other missing native-inputs.
>>
>> live well,
>> vagrant
>>
>> [2. text/x-diff; 0001-gnu-diffoscope-Increase-test-verbosity.patch]
>> From b1475226dc655986e97445dca889d4b0c362215c Mon Sep 17 00:00:00 2001
>> From: Vagrant Cascadian <vagrant@reproducible-builds.org>
>> Date: Thu, 11 Apr 2024 12:40:19 -0700
>> Subject: [PATCH] gnu: diffoscope: Increase test verbosity.
>>
>> * gnu/packages/diffoscope.scm (diffoscope)[phases]: Replace 'check.
>> ---
>> gnu/packages/diffoscope.scm | 5 +++++
>> 1 file changed, 5 insertions(+)
>
> This looks great, I've pushed it to master as
> 4dec6e9fb74a688e0297b127773b88a699531785.

Sending to the correct -done address. :)

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZkgbtwAKCRDcUY/If5cW
qu4MAQC7yMX87FLQ/SP1kbXLbTou8AIBi22ekBDHYf+rNZp4hAEAx2wi07I/X5wj
EspB1TRhSL+n+9JdGMeDPJ6DYz7nlQA=
=XZLe
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70344@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70344
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch