[PATCH 0/2] gnu: Add kdepim-addons.

  • Open
  • quality assurance status badge
Details
One participant
  • Sughosha
Owner
unassigned
Submitted by
Sughosha
Severity
normal
S
S
Sughosha wrote on 11 Apr 09:32 +0200
(address . guix-patches@gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
cover.1712820360.git.sughosha@disroot.org
This patch series add akonadi-import-wizard and kdepim-addons.

Sughosha (2):
gnu: Add akonadi-import-wizard.
gnu: Add kdepim-addons.

gnu/packages/kde-pim.scm | 147 +++++++++++++++++++++++++++++++++++++++
1 file changed, 147 insertions(+)


base-commit: 5a95cf76e1d0f9fdff5b232b42337c657b76d1d4
--
2.41.0
S
S
Sughosha wrote on 11 Apr 09:43 +0200
[PATCH 2/2] gnu: Add kdepim-addons.
(address . 70334@debbugs.gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
830fd2701e30464853ebfef5149c21d787596ae1.1712821437.git.sughosha@disroot.org
Change-Id: Ie955bf42328925d21b80cfe4a052618f9dc3a661
---
gnu/packages/kde-pim.scm | 95 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 95 insertions(+)

Toggle diff (115 lines)
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index 5c7c430e23..0b95bbd4d7 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -42,6 +42,7 @@ (define-module (gnu packages kde-pim)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages kde)
#:use-module (gnu packages kde-frameworks)
+ #:use-module (gnu packages markup)
#:use-module (gnu packages openldap)
#:use-module (gnu packages pdf)
#:use-module (gnu packages pkg-config)
@@ -844,6 +845,100 @@ (define-public kcalutils
functions for accessing calendar data using the kcalcore API.")
(license license:lgpl2.0+)))
+(define-public kdepim-addons
+ (package
+ (name "kdepim-addons")
+ (version "23.04.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/release-service/" version
+ "/src/kdepim-addons-" version ".tar.xz"))
+ (sha256
+ (base32 "1nai47wccf1shrgvywslqdkxk066zdkpb1grf3qzh8q77za2kmqz"))))
+ (build-system qt-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ ;; TODO: Out of 156 tests, 10 fail and 2 get stuck.
+ ;; kdepim-addons-todoedittest and kdepim-addons-eventedittest
+ ;; get stuck. Do they require user input?
+ ;; eventdatavisitortest and pimeventsplugintest fail only in the
+ ;; check phase of guix build, but testing the same normally
+ ;; outside the guix build passes these two tests.
+ ;; messageviewer-dkimauthenticationverifiedserverdialogtest
+ ;; fails due to SEGFAULT.
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (setenv "HOME" "/tmp")
+ (when tests?
+ (invoke "dbus-launch" "ctest" "-E" "\
+(kdepim-addons-todoedittest|kdepim-addons-eventedittest\
+|enterpriseheaderstyleplugintest|fancyheaderstyleplugintest\
+|grantleeheaderstyleplugintest|messageviewerplugins-rendertest\
+|akonadi-sqlite-rendertest-akonadi|akonadi-sqlite-mailsenderjobtest\
+|akonadi-sqlite-gravatarupdatewidgettest|eventdatavisitortest\
+|pimeventsplugintest\
+|messageviewer-dkimauthenticationverifiedserverdialogtest)")))))))
+ (native-inputs
+ (list dbus extra-cmake-modules libxml2)) ;libxml2 for xmllint
+ (inputs
+ (list akonadi
+ akonadi-calendar
+ akonadi-contacts
+ akonadi-import-wizard
+ akonadi-mime
+ akonadi-notes
+ discount
+ grantlee
+ grantleetheme
+ kaddressbook
+ kcalendarcore
+ kcalendarsupport
+ kcalutils
+ karchive
+ kconfig
+ kcontacts
+ kdbusaddons
+ kdeclarative
+ keventviews
+ kguiaddons
+ kholidays
+ ki18n
+ kiconthemes
+ kidentitymanagement
+ kimap
+ kincidenceeditor
+ kio
+ kitemmodels
+ kmailcommon
+ kmailimporter
+ kmailtransport
+ kitinerary
+ kmessagelib
+ kmime
+ kparts
+ kpimcommon
+ kpimtextedit
+ kpkpass
+ ksyntaxhighlighting
+ ktextaddons
+ ktnef
+ kwallet
+ kxmlgui
+ libgravatar
+ libkdepim
+ libkleo
+ libksieve
+ prison
+ qtwebengine-5))
+ (home-page "https://invent.kde.org/pim/kdepim-addons")
+ (synopsis "Add-ons for KDE PIM applications")
+ (description "This package contains add-ons for KDE PIM applications such
+as KMail, KAddressBook etc.")
+ (license
+ (list license:gpl2+ license:lgpl2.0+))))
+
(define-public kdepim-runtime
(package
(name "kdepim-runtime")
--
2.41.0
S
S
Sughosha wrote on 11 Apr 09:43 +0200
[PATCH 1/2] gnu: Add akonadi-import-wizard.
(address . 70334@debbugs.gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
4f1e9eb5bc0afe8bd79c2735a55d3a4b34a389b9.1712821437.git.sughosha@disroot.org
Change-Id: I3dda8acaee01138a327e457cc4488ff35b79b17d
---
gnu/packages/kde-pim.scm | 52 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 52 insertions(+)

Toggle diff (67 lines)
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index 5780b9dbca..5c7c430e23 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -365,6 +365,58 @@ (define-public akonadi-search
(license ;; GPL for programs, LGPL for libraries
(list license:gpl2+ license:lgpl2.0+))))
+(define-public akonadi-import-wizard
+ (package
+ (name "akonadi-import-wizard")
+ (version "23.04.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/release-service/" version
+ "/src/akonadi-import-wizard-" version
+ ".tar.xz"))
+ (sha256
+ (base32 "0dj7cvxnvld2h9nbg6v0bn3p81fx73dgj6kbpginavci52kgk240"))))
+ (build-system qt-build-system)
+ (native-inputs
+ (list extra-cmake-modules kdoctools))
+ (inputs
+ (list akonadi
+ akonadi-contacts
+ akonadi-mime
+ grantlee
+ grantleetheme
+ karchive
+ kauth
+ kconfig
+ kcontacts
+ kcrash
+ kdbusaddons
+ kidentitymanagement
+ kimap
+ kio
+ kitemmodels
+ kmailcommon
+ kmailimporter
+ kmailtransport
+ kmessagelib
+ kmime
+ kpimcommon
+ kpimtextedit
+ ktextaddons
+ ktextwidgets
+ kwallet
+ libkdepim
+ libkleo
+ qtkeychain
+ qtwebengine-5))
+ (home-page "https://invent.kde.org/pim/akonadi-import-wizard")
+ (synopsis "Assistant to import external PIM data into Akonadi")
+ (description "Akonadi Data import Wizard is an assistant to import external
+PIM data into Akonadi for use in KDE PIM applications.")
+ (license
+ (list license:gpl2+ license:lgpl2.0+))))
+
(define-public itinerary
(package
(name "itinerary")

base-commit: 5a95cf76e1d0f9fdff5b232b42337c657b76d1d4
--
2.41.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 70334@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70334
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch