[PATCH] gnu: audit: Build with aarch64 and arm support.

  • Open
  • quality assurance status badge
Details
One participant
  • Leo Nikkilä
Owner
unassigned
Submitted by
Leo Nikkilä
Severity
normal
L
L
Leo Nikkilä wrote on 11 Apr 01:55 +0200
(address . guix-patches@gnu.org)(name . Leo Nikkilä)(address . hello@lnikki.la)
20240410235555.21183-1-hello@lnikki.la
* gnu/packages/admin.scm (audit)[arguments]<#:configure-flags>: Add
`--with-aarch64' when building for aarch64. Likewise for arm.
---
gnu/packages/admin.scm | 13 +++++++++++--
1 file changed, 11 insertions(+), 2 deletions(-)

Toggle diff (27 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 2b94b1e17a..d8b2c25af4 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -3355,9 +3355,18 @@ (define-public audit
"0y5w8pl91xapi49ih1pw7h48lac201cj7fm89hkklmzi9m2715gx"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags (list "--with-python=no"
- "--disable-static")))
+ (list #:configure-flags
+ #~(list #$@(let ((system (or (%current-target-system)
+ (%current-system))))
+ (cond ((string-prefix? "aarch64-" system)
+ '("--with-aarch64"))
+ ((string-prefix? "arm-" system)
+ '("--with-arm"))
+ (else
+ '())))
+ "--with-python=no"
+ "--disable-static")))
(inputs
(list openldap gnutls cyrus-sasl))
(synopsis "User-space component to the Linux auditing system")

--
2.41.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 70328@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70328
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch