[PATCH] gnu: vtk: Update to 9.3.0

  • Done
  • quality assurance status badge
Details
3 participants
  • Andreas Enge
  • Lars Bilke
  • Ludovic Courtès
Owner
unassigned
Submitted by
Lars Bilke
Severity
normal
L
L
Lars Bilke wrote on 10 Apr 14:26 +0200
(address . guix-patches@gnu.org)(name . Lars Bilke)(address . lars.bilke@ufz.de)
e30f02e0cd7f6ff3b760356aa8e2026225d1b68c.1712751978.git.lars.bilke@ufz.de
Change-Id: Iec44a8e8dcfcf188a872af99e5b6e8c9fda7b416
---
gnu/packages/image-processing.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 98a3d0396d..de026d1bc8 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -328,7 +328,7 @@ (define-public opencolorio
(define-public vtk
(package
(name "vtk")
- (version "9.2.2")
+ (version "9.3.0")
(source (origin
(method url-fetch)
(uri (string-append "https://vtk.org/files/release/"
@@ -336,7 +336,7 @@ (define-public vtk
"/VTK-" version ".tar.gz"))
(sha256
(base32
- "0x8h2bwxq2870067j7wqd0qym87pa3inkbri93zrdb0zwwmhlnqw"))
+ "1s8vd34nhrgnw1bf9zhfn062d53fwq3csjfwvm7lxcr5a8lvkizx"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -407,6 +407,7 @@ (define-public vtk
;; Do not retain a reference to GCC.
(substitute* (choose
+ "Common/Core/vtkBuild.h.in" ;dummy >=v9.3
"Common/Core/vtkConfigureDeprecated.h.in" ;v9.x
"Common/Core/vtkConfigure.h.in") ;v7.x
(("@CMAKE_CXX_COMPILER@") "c++")))))

base-commit: 75bad75367fcf2c289fae3b40dbcc850f92177be
prerequisite-patch-id: a5dde500e72a24257ecf0f50b15a7298fde4ff57
--
2.44.0
L
L
Ludovic Courtès wrote on 31 May 12:31 +0200
(name . Lars Bilke)(address . lars.bilke@ufz.de)(address . 70323@debbugs.gnu.org)
8734pyuvb1.fsf@gnu.org
Hi Lars,

Apparently this change breaks Freecad:

Toggle snippet (18 lines)
/tmp/guix-build-freecad-0.21.2.drv-0/source/src/3rdParty/salomesmesh/src/SMDS/SMDS_UnstructuredGrid.cpp: In member func
tion ‘void SMDS_UnstructuredGrid::BuildLinks()’:
/tmp/guix-build-freecad-0.21.2.drv-0/source/src/3rdParty/salomesmesh/src/SMDS/SMDS_UnstructuredGrid.cpp:1029:25: error:
no matching function for call to ‘vtkCellLinks::BuildLinks(SMDS_UnstructuredGrid*)’
1029 | GetLinks()->BuildLinks(this);
| ~~~~~~~~~~~~~~~~~~~~~~^~~~~~
In file included from /tmp/guix-build-freecad-0.21.2.drv-0/source/src/3rdParty/salomesmesh/inc/SMDS_UnstructuredGrid.hx
x:30,
from /tmp/guix-build-freecad-0.21.2.drv-0/source/src/3rdParty/salomesmesh/src/SMDS/SMDS_UnstructuredGr
id.cpp:20:
/gnu/store/r3zpn5wmn98rllifyqq4h4wkp46zq0j2-vtk-9.3.0/include/vtk-9.3/vtkCellLinks.h:56:8: note: candidate: ‘virtual vo
id vtkCellLinks::BuildLinks()’
56 | void BuildLinks() override;
| ^~~~~~~~~~
/gnu/store/r3zpn5wmn98rllifyqq4h4wkp46zq0j2-vtk-9.3.0/include/vtk-9.3/vtkCellLinks.h:56:8: note: candidate expects 0
arguments, 1 provided

I haven’t checked the other dependents returned by ‘guix refresh -l
vtk@9’, but we should (for some reason

Could you take a look?

Thanks,
Ludo’.
L
L
Lars Bilke wrote on 3 Jun 16:01 +0200
[PATCH v2] gnu: vtk: Update to 9.3.0
(address . 70323@debbugs.gnu.org)(name . Lars Bilke)(address . lars.bilke@ufz.de)
dcda5e3afb55fd0b956c8aa9fa024f787144911f.1717423301.git.lars.bilke@ufz.de
Change-Id: Iec44a8e8dcfcf188a872af99e5b6e8c9fda7b416
---
gnu/packages/engineering.scm | 4 +-
gnu/packages/image-processing.scm | 5 ++-
gnu/packages/patches/freecad-vtk-9.3.patch | 43 ++++++++++++++++++++++
3 files changed, 49 insertions(+), 3 deletions(-)
create mode 100644 gnu/packages/patches/freecad-vtk-9.3.patch

Toggle diff (99 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 624024b8d4..cfcd3f8da7 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2806,7 +2806,9 @@ (define-public freecad
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0s720q6vxlh78jzahqp69nl8wagb42l05dym5aqhfnr31dx666hc"))))
+ (base32 "0s720q6vxlh78jzahqp69nl8wagb42l05dym5aqhfnr31dx666hc"))
+ ;; https://github.com/FreeCAD/FreeCAD/pull/11496
+ (patches (search-patches "freecad-vtk-9.3.patch"))))
(build-system qt-build-system)
(native-inputs
(list doxygen
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 7c9d12557e..65fe793f2d 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -309,7 +309,7 @@ (define-public opencolorio
(define-public vtk
(package
(name "vtk")
- (version "9.2.2")
+ (version "9.3.0")
(source (origin
(method url-fetch)
(uri (string-append "https://vtk.org/files/release/"
@@ -317,7 +317,7 @@ (define-public vtk
"/VTK-" version ".tar.gz"))
(sha256
(base32
- "0x8h2bwxq2870067j7wqd0qym87pa3inkbri93zrdb0zwwmhlnqw"))
+ "1s8vd34nhrgnw1bf9zhfn062d53fwq3csjfwvm7lxcr5a8lvkizx"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -388,6 +388,7 @@ (define-public vtk
;; Do not retain a reference to GCC.
(substitute* (choose
+ "Common/Core/vtkBuild.h.in" ;dummy >=v9.3
"Common/Core/vtkConfigureDeprecated.h.in" ;v9.x
"Common/Core/vtkConfigure.h.in") ;v7.x
(("@CMAKE_CXX_COMPILER@") "c++")))))
diff --git a/gnu/packages/patches/freecad-vtk-9.3.patch b/gnu/packages/patches/freecad-vtk-9.3.patch
new file mode 100644
index 0000000000..af9d654046
--- /dev/null
+++ b/gnu/packages/patches/freecad-vtk-9.3.patch
@@ -0,0 +1,43 @@
+From d0fb2b8b29fe0428d9dd8aa790b0d6e45c8a9516 Mon Sep 17 00:00:00 2001
+From: Adrian Insaurralde Avalos <adrianinsaval@gmail.com>
+Date: Wed, 22 Nov 2023 16:42:06 -0300
+Subject: [PATCH] 3rdPart/salomesmesh - fix for vtk 9.3 compatibility
+
+minimum required version is 7.1
+---
+ src/3rdParty/salomesmesh/inc/SMESH_SMDS.hxx | 4 ----
+ src/3rdParty/salomesmesh/src/SMDS/SMDS_UnstructuredGrid.cpp | 5 +++++
+ 2 files changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/src/3rdParty/salomesmesh/inc/SMESH_SMDS.hxx b/src/3rdParty/salomesmesh/inc/SMESH_SMDS.hxx
+index 7f89573efd0d..47a52fe585fe 100644
+--- a/src/3rdParty/salomesmesh/inc/SMESH_SMDS.hxx
++++ b/src/3rdParty/salomesmesh/inc/SMESH_SMDS.hxx
+@@ -39,10 +39,6 @@
+ #define SMDS_EXPORT
+ #endif
+
+-#ifdef VTK_HAS_MTIME_TYPE
+ #define VTK_MTIME_TYPE vtkMTimeType
+-#else
+-#define VTK_MTIME_TYPE unsigned long
+-#endif
+
+ #endif
+diff --git a/src/3rdParty/salomesmesh/src/SMDS/SMDS_UnstructuredGrid.cpp b/src/3rdParty/salomesmesh/src/SMDS/SMDS_UnstructuredGrid.cpp
+index 7e3de0070a02..e9895d615717 100644
+--- a/src/3rdParty/salomesmesh/src/SMDS/SMDS_UnstructuredGrid.cpp
++++ b/src/3rdParty/salomesmesh/src/SMDS/SMDS_UnstructuredGrid.cpp
+@@ -1026,7 +1026,12 @@ void SMDS_UnstructuredGrid::BuildLinks()
+ GetLinks()->Allocate(this->GetNumberOfPoints());
+ GetLinks()->Register(this);
+ //FIXME: vtk9
++ #if VTK_VERSION_NUMBER < VTK_VERSION_CHECK(9,3,0)
+ GetLinks()->BuildLinks(this);
++ #else
++ GetLinks()->SetDataSet(this);
++ GetLinks()->BuildLinks();
++ #endif
+ GetLinks()->Delete();
+ #else
+ this->Links = SMDS_CellLinks::New();
\ No newline at end of file

base-commit: 2dfe45e12ed55e5f9bf3d4061200bc607e2e5db8
--
2.44.0
L
L
Lars Bilke wrote on 4 Jun 08:29 +0200
[PATCH] gnu: vtk: Update to 9.3.0
(address . 70323@debbugs.gnu.org)
15D059AA-DF6C-472F-A176-14AFAD9BD454@ufz.de
I have added a patch for FreeCAD and also tested some dependant packages such as pyvista, openfoam, f3d and siril.
A
A
Andreas Enge wrote on 10 Jun 13:09 +0200
Further work
(address . 70323@debbugs.gnu.org)
Zmbe3Y_7MncLh47m@jurong
Hello Lars,

everything works well according to QA.

However, could you split the commit into two, one updating vtk;
and the second one applying the patch to freecad, and also mentioning
the file in the commit message and registering it in gnu/local.mk?

Thanks,

Andreas
L
L
Lars Bilke wrote on 17 Jun 10:34 +0200
[PATCH v3 1/2] gnu: vtk: Update to 9.3.0
(address . 70323@debbugs.gnu.org)
ac1219fa8708cd4a72e7d5ce13db50ce079dba45.1718613292.git.lars.bilke@ufz.de
Change-Id: Id31d41e7dc457d1f17c0e8e824c170942d81698c
---
gnu/packages/image-processing.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 7c9d12557e..65fe793f2d 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -309,7 +309,7 @@ (define-public opencolorio
(define-public vtk
(package
(name "vtk")
- (version "9.2.2")
+ (version "9.3.0")
(source (origin
(method url-fetch)
(uri (string-append "https://vtk.org/files/release/"
@@ -317,7 +317,7 @@ (define-public vtk
"/VTK-" version ".tar.gz"))
(sha256
(base32
- "0x8h2bwxq2870067j7wqd0qym87pa3inkbri93zrdb0zwwmhlnqw"))
+ "1s8vd34nhrgnw1bf9zhfn062d53fwq3csjfwvm7lxcr5a8lvkizx"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -388,6 +388,7 @@ (define-public vtk
;; Do not retain a reference to GCC.
(substitute* (choose
+ "Common/Core/vtkBuild.h.in" ;dummy >=v9.3
"Common/Core/vtkConfigureDeprecated.h.in" ;v9.x
"Common/Core/vtkConfigure.h.in") ;v7.x
(("@CMAKE_CXX_COMPILER@") "c++")))))

base-commit: bd5c61781c13611ed16686513980907c6ee34ae6
--
2.44.0
L
L
Lars Bilke wrote on 17 Jun 10:34 +0200
[PATCH v3 2/2] gnu: freecad: patch for vtk 9.3.0
(address . 70323@debbugs.gnu.org)
b79c99854faf23f201fe0f34911ec672f21476dd.1718613292.git.lars.bilke@ufz.de
Change-Id: Ie520a92ffe6f8bdd2678470ee06f618d74349460
---
gnu/local.mk | 1 +
gnu/packages/engineering.scm | 4 +-
gnu/packages/patches/freecad-vtk-9.3.patch | 43 ++++++++++++++++++++++
3 files changed, 47 insertions(+), 1 deletion(-)
create mode 100644 gnu/packages/patches/freecad-vtk-9.3.patch

Toggle diff (79 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 83b7402b09..2a5a54a265 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1242,6 +1242,7 @@ dist_patch_DATA = \
%D%/packages/patches/fpc-reproducibility.patch \
%D%/packages/patches/fpc-glibc-2.34-compat.patch \
%D%/packages/patches/fpm-newer-clamp-fix.patch \
+ %D%/packages/patches/freecad-vtk-9.3.patch \
%D%/packages/patches/freedink-engine-fix-sdl-hints.patch \
%D%/packages/patches/freeimage-libtiff-compat.patch \
%D%/packages/patches/freeimage-unbundle.patch \
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index e518d24fa2..fcb73eab12 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2783,7 +2783,9 @@ (define-public freecad
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0s720q6vxlh78jzahqp69nl8wagb42l05dym5aqhfnr31dx666hc"))))
+ (base32 "0s720q6vxlh78jzahqp69nl8wagb42l05dym5aqhfnr31dx666hc"))
+ ;; https://github.com/FreeCAD/FreeCAD/pull/11496
+ (patches (search-patches "freecad-vtk-9.3.patch"))))
(build-system qt-build-system)
(native-inputs
(list doxygen
diff --git a/gnu/packages/patches/freecad-vtk-9.3.patch b/gnu/packages/patches/freecad-vtk-9.3.patch
new file mode 100644
index 0000000000..af9d654046
--- /dev/null
+++ b/gnu/packages/patches/freecad-vtk-9.3.patch
@@ -0,0 +1,43 @@
+From d0fb2b8b29fe0428d9dd8aa790b0d6e45c8a9516 Mon Sep 17 00:00:00 2001
+From: Adrian Insaurralde Avalos <adrianinsaval@gmail.com>
+Date: Wed, 22 Nov 2023 16:42:06 -0300
+Subject: [PATCH] 3rdPart/salomesmesh - fix for vtk 9.3 compatibility
+
+minimum required version is 7.1
+---
+ src/3rdParty/salomesmesh/inc/SMESH_SMDS.hxx | 4 ----
+ src/3rdParty/salomesmesh/src/SMDS/SMDS_UnstructuredGrid.cpp | 5 +++++
+ 2 files changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/src/3rdParty/salomesmesh/inc/SMESH_SMDS.hxx b/src/3rdParty/salomesmesh/inc/SMESH_SMDS.hxx
+index 7f89573efd0d..47a52fe585fe 100644
+--- a/src/3rdParty/salomesmesh/inc/SMESH_SMDS.hxx
++++ b/src/3rdParty/salomesmesh/inc/SMESH_SMDS.hxx
+@@ -39,10 +39,6 @@
+ #define SMDS_EXPORT
+ #endif
+
+-#ifdef VTK_HAS_MTIME_TYPE
+ #define VTK_MTIME_TYPE vtkMTimeType
+-#else
+-#define VTK_MTIME_TYPE unsigned long
+-#endif
+
+ #endif
+diff --git a/src/3rdParty/salomesmesh/src/SMDS/SMDS_UnstructuredGrid.cpp b/src/3rdParty/salomesmesh/src/SMDS/SMDS_UnstructuredGrid.cpp
+index 7e3de0070a02..e9895d615717 100644
+--- a/src/3rdParty/salomesmesh/src/SMDS/SMDS_UnstructuredGrid.cpp
++++ b/src/3rdParty/salomesmesh/src/SMDS/SMDS_UnstructuredGrid.cpp
+@@ -1026,7 +1026,12 @@ void SMDS_UnstructuredGrid::BuildLinks()
+ GetLinks()->Allocate(this->GetNumberOfPoints());
+ GetLinks()->Register(this);
+ //FIXME: vtk9
++ #if VTK_VERSION_NUMBER < VTK_VERSION_CHECK(9,3,0)
+ GetLinks()->BuildLinks(this);
++ #else
++ GetLinks()->SetDataSet(this);
++ GetLinks()->BuildLinks();
++ #endif
+ GetLinks()->Delete();
+ #else
+ this->Links = SMDS_CellLinks::New();
\ No newline at end of file
--
2.44.0
A
A
Andreas Enge wrote on 27 Jun 19:17 +0200
Re: [PATCH v3 1/2] gnu: vtk: Update to 9.3.0
(name . Lars Bilke)(address . lars.bilke@ufz.de)(address . 70323-done@debbugs.gnu.org)
Zn2emOk3OE0n_mcA@jurong
Hello,

I just realised that the patches already built on QA when they were put
together as one; so there is no real point to wait for QA again.
I have checked that freecad still builds on x86_64 and pushed the two
patches.

Thanks!

Andreas
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70323@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70323
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch