(address . guix-patches@gnu.org)(name . Jean-Pierre De Jesus DIAZ)(address . jean@foundation.xyz)
* gnu/packages/qt.scm (soqt): Update to 1.6.2.
Change-Id: Ie4c9f0c4cff7584801952cc561f4d6fa3515d0ec
---
gnu/packages/qt.scm | 48 ++++++++++++++++++++++-----------------------
1 file changed, 23 insertions(+), 25 deletions(-)
Toggle diff (65 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index dcc9bfeb62..100d6cac97 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -5095,33 +5095,31 @@ (define-public qthttpserver
(license license:gpl3+)))
(define-public soqt
- (let ((commit-ref "fb8f655632bb9c9c60e0ff9fa69a5ba22d3ff99d")
- (revision "1"))
- (package
- (name "soqt")
- (version (git-version "1.6.0" revision commit-ref))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/coin3d/soqt")
- (commit commit-ref)
- (recursive? #t)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "16vikb3fy8rmk10sg5g0gy2c343hi3x7zccsga90ssnkzpq6m032"))))
- (build-system cmake-build-system)
- (arguments '(#:tests? #f)) ; There are no tests
- (native-inputs
- (list pkg-config cmake))
- (inputs
- (list qtbase-5 coin3D))
- (home-page "https://github.com/coin3d/soqt")
- (synopsis "Qt GUI component toolkit library for Coin")
- (description "SoQt is a Qt GUI component toolkit library for Coin. It is
+ (package
+ (name "soqt")
+ (version "1.6.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/coin3d/soqt")
+ (commit (string-append "v" version))
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0rsfc4wmghl9fr4bwh9rpzjwzsmx00k4ki5gyvy85nb4kbmr9dwv"))))
+ (build-system cmake-build-system)
+ (arguments '(#:tests? #f)) ; There are no tests
+ (native-inputs
+ (list pkg-config cmake))
+ (inputs
+ (list qtbase-5 coin3d))
+ (home-page "https://github.com/coin3d/soqt")
+ (synopsis "Qt GUI component toolkit library for Coin")
+ (description "SoQt is a Qt GUI component toolkit library for Coin. It is
also compatible with SGI and TGS Open Inventor, and the API is based on the API
of the InventorXt GUI component toolkit.")
- (license license:bsd-3))))
+ (license license:bsd-3)))
(define-public libdbusmenu-qt
(package
base-commit: cd45294d576975a3bff2f755764a3f46f09ea6f9
--
2.41.0