[PATCH] gnu: Add python-pybadges.

  • Open
  • quality assurance status badge
Details
One participant
  • Giacomo Leidi
Owner
unassigned
Submitted by
Giacomo Leidi
Severity
normal
G
G
Giacomo Leidi wrote on 8 Apr 00:13 +0200
(address . guix-patches@gnu.org)(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
e5ffe23e93f708cb0c5a3f449b16ca36c5033550.1712527982.git.goodoldpaul@autistici.org
* gnu/packages/python-web.scm (python-pybadges): New variable.

Change-Id: Idd53ddf94b24112015c0a0b82396cf366920417e
---
gnu/packages/python-web.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 9ad081beb1..da4f019476 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -9123,6 +9123,40 @@ (define-public python-whatthepatch
"This package provides a library to parse and apply patches.")
(license license:expat)))
+(define-public python-pybadges
+ (package
+ (name "python-pybadges")
+ (version "3.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/pybadges")
+ (commit (string-append version))))
+ (file-name (git-file-name name version))
+ (sha256
+ "1zgb9idz7m3mzf8wvik0gwmyrxp753axqjv2pab326cr5myj1s4b")))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ #~'("-k"
+ ;; Disable network dependent tests.
+ "not test_changes and not test_not_image_url and not test_http_url")))
+ (propagated-inputs (list python-jinja2 python-requests))
+ (native-inputs (list python-flask
+ python-fonttools
+ python-nox
+ python-pillow
+ python-pytest
+ python-xmldiff))
+ (home-page "https://github.com/google/pybadges")
+ (synopsis
+ "Libbrary and command-line tool for generating Github-style badges")
+ (description
+ "This package provides @code{python-pybadges}: a library and command-line
+tool for generating Github-style badges.")
+ (license license:asl2.0)))
+
(define-public python-grid5000
(package
(name "python-grid5000")

base-commit: 69951a61a1d8f1f2135ea2dc836738be282b97bc
--
2.41.0
?