[PATCH] gnu: Add python-pybadges.

  • Done
  • quality assurance status badge
Details
4 participants
  • Andreas Enge
  • Giacomo Leidi
  • Ludovic Courtès
  • Nicolas Graves
Owner
unassigned
Submitted by
Giacomo Leidi
Severity
normal
G
G
Giacomo Leidi wrote on 8 Apr 00:13 +0200
(address . guix-patches@gnu.org)(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
e5ffe23e93f708cb0c5a3f449b16ca36c5033550.1712527982.git.goodoldpaul@autistici.org
* gnu/packages/python-web.scm (python-pybadges): New variable.

Change-Id: Idd53ddf94b24112015c0a0b82396cf366920417e
---
gnu/packages/python-web.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 9ad081beb1..da4f019476 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -9123,6 +9123,40 @@ (define-public python-whatthepatch
"This package provides a library to parse and apply patches.")
(license license:expat)))
+(define-public python-pybadges
+ (package
+ (name "python-pybadges")
+ (version "3.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/pybadges")
+ (commit (string-append version))))
+ (file-name (git-file-name name version))
+ (sha256
+ "1zgb9idz7m3mzf8wvik0gwmyrxp753axqjv2pab326cr5myj1s4b")))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ #~'("-k"
+ ;; Disable network dependent tests.
+ "not test_changes and not test_not_image_url and not test_http_url")))
+ (propagated-inputs (list python-jinja2 python-requests))
+ (native-inputs (list python-flask
+ python-fonttools
+ python-nox
+ python-pillow
+ python-pytest
+ python-xmldiff))
+ (home-page "https://github.com/google/pybadges")
+ (synopsis
+ "Libbrary and command-line tool for generating Github-style badges")
+ (description
+ "This package provides @code{python-pybadges}: a library and command-line
+tool for generating Github-style badges.")
+ (license license:asl2.0)))
+
(define-public python-grid5000
(package
(name "python-grid5000")

base-commit: 69951a61a1d8f1f2135ea2dc836738be282b97bc
--
2.41.0
N
N
Nicolas Graves wrote on 13 May 07:40 +0200
87bk5acls5.fsf@ngraves.fr
On 2024-04-08 00:13, Giacomo Leidi via Guix-patches via wrote:

Toggle quote (25 lines)
> * gnu/packages/python-web.scm (python-pybadges): New variable.
>
> Change-Id: Idd53ddf94b24112015c0a0b82396cf366920417e
> ---
> gnu/packages/python-web.scm | 34 ++++++++++++++++++++++++++++++++++
> 1 file changed, 34 insertions(+)
>
> diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
> index 9ad081beb1..da4f019476 100644
> --- a/gnu/packages/python-web.scm
> +++ b/gnu/packages/python-web.scm
> @@ -9123,6 +9123,40 @@ (define-public python-whatthepatch
> "This package provides a library to parse and apply patches.")
> (license license:expat)))
>
> +(define-public python-pybadges
> + (package
> + (name "python-pybadges")
> + (version "3.0.1")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/google/pybadges")
> + (commit (string-append version))))

(string-append with a single string is a bit odd ;)

Toggle quote (20 lines)
> + (file-name (git-file-name name version))
> + (sha256
> + "1zgb9idz7m3mzf8wvik0gwmyrxp753axqjv2pab326cr5myj1s4b")))
> + (build-system pyproject-build-system)
> + (arguments
> + (list
> + #:test-flags
> + #~'("-k"
> + ;; Disable network dependent tests.
> + "not test_changes and not test_not_image_url and not test_http_url")))
> + (propagated-inputs (list python-jinja2 python-requests))
> + (native-inputs (list python-flask
> + python-fonttools
> + python-nox
> + python-pillow
> + python-pytest
> + python-xmldiff))
> + (home-page "https://github.com/google/pybadges")
> + (synopsis
> + "Libbrary and command-line tool for generating Github-style badges")
^ typo there
Toggle quote (4 lines)
> + (description
> + "This package provides @code{python-pybadges}: a library and command-line
> +tool for generating Github-style badges.")

Maybe you can be a bit more descriptive: "as SVG images" in the Github
description is informative. I often also like (but I'm not sure it's a
norm) to write my synopsis as an action statement, such as "Generate
Github-style badges on the command-line".

Toggle quote (2 lines)
> + (license license:asl2.0)))

Otherwise LGTM.

Toggle quote (7 lines)
> +
> (define-public python-grid5000
> (package
> (name "python-grid5000")
>
> base-commit: 69951a61a1d8f1f2135ea2dc836738be282b97bc

--
Best regards,
Nicolas Graves
P
422088ec-8c50-e8b8-9d59-b8e34c750482@autistici.org
Hi Nicolas,


Thank you for your review: I'm sending an updated patch.


giacomo
G
G
Giacomo Leidi wrote on 13 May 19:05 +0200
[PATCH v2] gnu: Add python-pybadges.
(address . 70269@debbugs.gnu.org)(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
e564b34381c995d0f30ed68f4c92f26f6d089368.1715619952.git.goodoldpaul@autistici.org
* gnu/packages/python-web.scm (python-pybadges): New variable.

Change-Id: Idd53ddf94b24112015c0a0b82396cf366920417e
---
gnu/packages/python-web.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index affa2f52f4..df19b30386 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -9183,6 +9183,40 @@ (define-public python-whatthepatch
"This package provides a library to parse and apply patches.")
(license license:expat)))
+(define-public python-pybadges
+ (package
+ (name "python-pybadges")
+ (version "3.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/pybadges")
+ (commit (string-append version))))
+ (file-name (git-file-name name version))
+ (sha256
+ "1zgb9idz7m3mzf8wvik0gwmyrxp753axqjv2pab326cr5myj1s4b")))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ #~'("-k"
+ ;; Disable network dependent tests.
+ "not test_changes and not test_not_image_url and not test_http_url")))
+ (propagated-inputs (list python-jinja2 python-requests))
+ (native-inputs (list python-flask
+ python-fonttools
+ python-nox
+ python-pillow
+ python-pytest
+ python-xmldiff))
+ (home-page "https://github.com/google/pybadges")
+ (synopsis
+ "Generate Github-style badges on the command-line")
+ (description
+ "This package provides @code{python-pybadges}: a library and command-line
+tool for generating Github-style badges as SVG images.")
+ (license license:asl2.0)))
+
(define-public python-grid5000
(package
(name "python-grid5000")

base-commit: aa9ac252206615713ab988d7068da9e14a9bccc0
--
2.41.0
N
N
Nicolas Graves wrote on 14 May 22:10 +0200
QA review for 70269
877cfwp323.fsf@ngraves.fr
user guix
usertag 70269 + reviewed-looks-good
thanks

Guix QA review form submission:
LGTM

Items marked as checked: Lint warnings, Package builds, Commit messages, New package licenses, New package tests, New package synopsis and descriptions

--
Best regards,
Nicolas Graves
A
A
Andreas Enge wrote on 15 May 15:58 +0200
Comments
(address . 70269@debbugs.gnu.org)
ZkS_deze0PcW6N7J@jurong
Hello,

the lonely "string-append" is still there, and the description a bit short.
I would not mind changing that myself, but since I am having trouble
downloading the patch anyway (clicking on "download raw message" in
issues.guix.gnu.org drops the attached commit), I will let you send in
a third version.

Thanks!

Andreas
L
L
Ludovic Courtès wrote on 31 May 12:02 +0200
Re: [bug#70269] [PATCH v2] gnu: Add python-pybadges.
(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
877cfauwn3.fsf@gnu.org
Hi,

Applied with the changes below, as suggested by Andreas.

Thanks everyone!

Ludo’.
Toggle diff (23 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 4970366c93d..5ca50fa5a6c 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -9232,7 +9232,7 @@ (define-public python-pybadges
(method git-fetch)
(uri (git-reference
(url "https://github.com/google/pybadges")
- (commit (string-append version))))
+ (commit version)))
(file-name (git-file-name name version))
(sha256
"1zgb9idz7m3mzf8wvik0gwmyrxp753axqjv2pab326cr5myj1s4b")))
@@ -9251,8 +9251,7 @@ (define-public python-pybadges
python-pytest
python-xmldiff))
(home-page "https://github.com/google/pybadges")
- (synopsis
- "Generate Github-style badges on the command-line")
+ (synopsis "Generate Github-style badges on the command-line")
(description
"This package provides @code{python-pybadges}: a library and command-line
tool for generating Github-style badges as SVG images.")
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70269@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70269
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch