[PATCH] gnu: Add python-vdf.

  • Open
  • quality assurance status badge
Details
2 participants
  • Giacomo Leidi
  • Steve George
Owner
unassigned
Submitted by
Giacomo Leidi
Severity
normal
G
G
Giacomo Leidi wrote on 7 Apr 23:49 +0200
(address . guix-patches@gnu.org)(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
66a0f667d733cfbb6093706c66f717970b529742.1712526583.git.goodoldpaul@autistici.org
* gnu/packages/python-xyz.scm (python-vdf): New variable.

Change-Id: Ie8a14292b9c9937d22f011ac078562e81abd6b36
---
gnu/packages/python-xyz.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0ac9d669d3..2326aa4323 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6761,6 +6761,23 @@ (define-public python-pygments
"Pygments is a syntax highlighting package written in Python.")
(license license:bsd-2)))
+(define-public python-vdf
+ (package
+ (name "python-vdf")
+ (version "3.4")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "vdf" version))
+ (sha256
+ (base32
+ "1bz2gn04pl6rj2mawlzlirz1ygg4rdypq0pxbyg018873vs1jm7x"))))
+ (build-system pyproject-build-system)
+ (home-page "https://github.com/ValvePython/vdf")
+ (synopsis "Work with Valve's VDF text format")
+ (description "This packages provides @code{python-vdf}, a library for
+working with Valve's VDF text format.")
+ (license license:expat)))
+
(define-public python-pygments-github-lexers
(package
(name "python-pygments-github-lexers")

base-commit: 69951a61a1d8f1f2135ea2dc836738be282b97bc
--
2.41.0
S
S
Steve George wrote on 17 Apr 11:34 +0200
[PATCH v2 1/1] gnu: Add python-vdf.
(address . 70268@debbugs.gnu.org)
b8a9cbdbcecec66f9322c86d03181c596a1f7733.1713345494.git.steve@futurile.net
From: Giacomo Leidi via Guix-patches via <guix-patches@gnu.org>

* gnu/packages/python-xyz.scm (python-vdf): New variable.

Reviewed-by: Steve George <steve@futurile.net>

Change-Id: Ie8a14292b9c9937d22f011ac078562e81abd6b36
---
gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bac90b1e07..1637f2aa8e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6834,6 +6834,24 @@ (define-public python-pygments
"Pygments is a syntax highlighting package written in Python.")
(license license:bsd-2)))
+(define-public python-vdf
+ (package
+ (name "python-vdf")
+ (version "3.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "vdf" version))
+ (sha256
+ (base32
+ "1bz2gn04pl6rj2mawlzlirz1ygg4rdypq0pxbyg018873vs1jm7x"))))
+ (build-system pyproject-build-system)
+ (home-page "https://github.com/ValvePython/vdf")
+ (synopsis "Work with Valve's VDF text format")
+ (description "This package provides @code{python-vdf}, a library for
+working with Valve's VDF text format.")
+ (license license:expat)))
+
(define-public python-pygments-github-lexers
(package
(name "python-pygments-github-lexers")
--
2.41.0
S
S
Steve George wrote on 17 Apr 11:34 +0200
[PATCH v2 0/1] RE: Add python-vdf
(address . 70268@debbugs.gnu.org)(name . Steve George)(address . steve@futurile.net)
cover.1713345494.git.steve@futurile.net
Review:
* Was failing QA due to typo - running 'guix lint' caught it
* submission: checked commit format, synopsis and description
* submission: checked license, patch applies cleanly
* functionality: test installed, python import works
* code: minor reformat; guix lint is clean
* added: Reviewed-by commit trailer
* re-roll to trigger QA rebuild

Giacomo Leidi via Guix-patches via (1):
gnu: Add python-vdf.

gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)


base-commit: b47ae1ecc43baaf726701ab2d2f810ecfaa75428
--
2.41.0
?