[PATCH] gnu: Add python-vdf.

  • Done
  • quality assurance status badge
Details
3 participants
  • Giacomo Leidi
  • Christopher Baines
  • Steve George
Owner
unassigned
Submitted by
Giacomo Leidi
Severity
normal
G
G
Giacomo Leidi wrote on 7 Apr 23:49 +0200
(address . guix-patches@gnu.org)(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
66a0f667d733cfbb6093706c66f717970b529742.1712526583.git.goodoldpaul@autistici.org
* gnu/packages/python-xyz.scm (python-vdf): New variable.

Change-Id: Ie8a14292b9c9937d22f011ac078562e81abd6b36
---
gnu/packages/python-xyz.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0ac9d669d3..2326aa4323 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6761,6 +6761,23 @@ (define-public python-pygments
"Pygments is a syntax highlighting package written in Python.")
(license license:bsd-2)))
+(define-public python-vdf
+ (package
+ (name "python-vdf")
+ (version "3.4")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "vdf" version))
+ (sha256
+ (base32
+ "1bz2gn04pl6rj2mawlzlirz1ygg4rdypq0pxbyg018873vs1jm7x"))))
+ (build-system pyproject-build-system)
+ (home-page "https://github.com/ValvePython/vdf")
+ (synopsis "Work with Valve's VDF text format")
+ (description "This packages provides @code{python-vdf}, a library for
+working with Valve's VDF text format.")
+ (license license:expat)))
+
(define-public python-pygments-github-lexers
(package
(name "python-pygments-github-lexers")

base-commit: 69951a61a1d8f1f2135ea2dc836738be282b97bc
--
2.41.0
S
S
Steve George wrote on 17 Apr 11:34 +0200
[PATCH v2 1/1] gnu: Add python-vdf.
(address . 70268@debbugs.gnu.org)
b8a9cbdbcecec66f9322c86d03181c596a1f7733.1713345494.git.steve@futurile.net
From: Giacomo Leidi via Guix-patches via <guix-patches@gnu.org>

* gnu/packages/python-xyz.scm (python-vdf): New variable.

Reviewed-by: Steve George <steve@futurile.net>

Change-Id: Ie8a14292b9c9937d22f011ac078562e81abd6b36
---
gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bac90b1e07..1637f2aa8e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6834,6 +6834,24 @@ (define-public python-pygments
"Pygments is a syntax highlighting package written in Python.")
(license license:bsd-2)))
+(define-public python-vdf
+ (package
+ (name "python-vdf")
+ (version "3.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "vdf" version))
+ (sha256
+ (base32
+ "1bz2gn04pl6rj2mawlzlirz1ygg4rdypq0pxbyg018873vs1jm7x"))))
+ (build-system pyproject-build-system)
+ (home-page "https://github.com/ValvePython/vdf")
+ (synopsis "Work with Valve's VDF text format")
+ (description "This package provides @code{python-vdf}, a library for
+working with Valve's VDF text format.")
+ (license license:expat)))
+
(define-public python-pygments-github-lexers
(package
(name "python-pygments-github-lexers")
--
2.41.0
S
S
Steve George wrote on 17 Apr 11:34 +0200
[PATCH v2 0/1] RE: Add python-vdf
(address . 70268@debbugs.gnu.org)(name . Steve George)(address . steve@futurile.net)
cover.1713345494.git.steve@futurile.net
Review:
* Was failing QA due to typo - running 'guix lint' caught it
* submission: checked commit format, synopsis and description
* submission: checked license, patch applies cleanly
* functionality: test installed, python import works
* code: minor reformat; guix lint is clean
* added: Reviewed-by commit trailer
* re-roll to trigger QA rebuild

Giacomo Leidi via Guix-patches via (1):
gnu: Add python-vdf.

gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)


base-commit: b47ae1ecc43baaf726701ab2d2f810ecfaa75428
--
2.41.0
C
C
Christopher Baines wrote on 12 May 20:21 +0200
Re: [bug#70268] [PATCH v2 1/1] gnu: Add python-vdf.
(address . 70268-done@debbugs.gnu.org)
87ttj27uwp.fsf@cbaines.net
Steve George <steve@futurile.net> writes:

Toggle quote (11 lines)
> From: Giacomo Leidi via Guix-patches via <guix-patches@gnu.org>
>
> * gnu/packages/python-xyz.scm (python-vdf): New variable.
>
> Reviewed-by: Steve George <steve@futurile.net>
>
> Change-Id: Ie8a14292b9c9937d22f011ac078562e81abd6b36
> ---
> gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
> 1 file changed, 18 insertions(+)

Thanks both, I've pushed this to master as
ca571f4259df82500c687effcdb7d11904a52e6c.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmZBCMZfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XfyXA//RG7E1oJf22pAmcLI8kN4dDrj7UhhNWu5
eT8o2F2fqxTrZHh32Pd2Ve5GbrakTVTH6l0DrNGtNE7a6tULRFHAy4wJPQfxI17L
4VECzLXnRW8LbaYZjmsU7dhA2Ijuw0GKISJ3SeKapSeBl+RerAuKutqxoHvtXU3F
ngZ4lCuLT8Y2Q3w1rbG+Z1XhoY2P/pqTDpbK3XOsXpNCKIaAsxxzbzX/9Zj3Bpil
hsgg4L60RO2+B7cU9wgmBzNi1/vSgyuXnNUCage3rGVn5UTvCuGZvqeveDFA6eTy
LrnnxBzjJyKw9lUOrK1l2Yobh0Uv45Z4gB+2VHAtN6g19YtCLXCNGaw0QusMaMW/
cBEhlwVtbEK44neE8V6xODKM0ue6d9mu54Y0A6//jHQfISn/eMM+UgMp1KcvYCi6
SVYI4NE3GGGTXQIAMnjhoSR4sZjbjDtNwBImJVzFB6PkzNzPb+Ku81y7LwliqMiN
p/zGIh4mq7b12kKknd5mMwbxBwEwPsOK7zETn4BAWVgSkTY5tWlYYQzDqOnIhkfK
NB8H4t7upUcX8+QkSnTfRcWloFqPaegJn3rR061sF53XgKja6LK2pDQAG54xmsvK
JuF2ZGPA7YaPMQtCzjEUMhqFqy6OBhfUULRe3qFh1eFOV380afLAtti2YjHyTJGP
b3tYCM1oyuM=
=YTqw
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70268@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70268
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch