Sharlatan Hellseher wrote 11 months ago
(address . bug-guix@gnu.org)(name . Ricardo Wurmus)(address . rekado@elephly.net)
Hi,
While refreshing and checking packages in (gnu packages code) I've
noticed that withershins is no longer buildable, it looks like the
source is not compatible with a new version of binutils.
One more thing - the project does not exist by
https://github.com/cameronwhite/withershins but I could find it in
Cc: Ricardo as he was the last person who has added and updated the
package.
Error trace:
Toggle snippet (39 lines)
starting phase `build'
/gnu/store/gl26kr5v6ch5lc3ignly61kb224drijc-cmake-minimal-3.24.2/bin/cmake -S/tmp/guix-build-withershins-0.1.drv-0/source -B/tmp/guix-build-withershins-0.1.drv-0/source --check-build-system CMakeFiles/Makefile.cmake 0
/gnu/store/gl26kr5v6ch5lc3ignly61kb224drijc-cmake-minimal-3.24.2/bin/cmake -E cmake_progress_start /tmp/guix-build-withershins-0.1.drv-0/source/CMakeFiles /tmp/guix-build-withershins-0.1.drv-0/source//CMakeFiles/progress.marks
make -f CMakeFiles/Makefile2 all
make[1]: Entering directory '/tmp/guix-build-withershins-0.1.drv-0/source'
make -f src/CMakeFiles/withershins.dir/build.make src/CMakeFiles/withershins.dir/depend
make[2]: Entering directory '/tmp/guix-build-withershins-0.1.drv-0/source'
cd /tmp/guix-build-withershins-0.1.drv-0/source && /gnu/store/gl26kr5v6ch5lc3ignly61kb224drijc-cmake-minimal-3.24.2/bin/cmake -E cmake_depends "Unix Makefiles" /tmp/guix-build-withershins-0.1.drv-0/source /tmp/guix-build-withershins-0.1.drv-0/source/src /tmp/guix-build-withershins-0.1.drv-0/source /tmp/guix-build-withershins-0.1.drv-0/source/src /tmp/guix-build-withershins-0.1.drv-0/source/src/CMakeFiles/withershins.dir/DependInfo.cmake --color=
make[2]: Leaving directory '/tmp/guix-build-withershins-0.1.drv-0/source'
make -f src/CMakeFiles/withershins.dir/build.make src/CMakeFiles/withershins.dir/build
make[2]: Entering directory '/tmp/guix-build-withershins-0.1.drv-0/source'
[ 16%] Building CXX object src/CMakeFiles/withershins.dir/withershins.cpp.o
cd /tmp/guix-build-withershins-0.1.drv-0/source/src && /gnu/store/5lqhcv91ijy82p92ac6g5xw48l0lwwz4-gcc-11.3.0/bin/c++ -DWITHERSHINS_ENABLE_LIBBFD -I/tmp/guix-build-withershins-0.1.drv-0/source/src -std=c++11 -Wall -Wextra -pthread -O2 -g -DNDEBUG -MD -MT src/CMakeFiles/withershins.dir/withershins.cpp.o -MF CMakeFiles/withershins.dir/withershins.cpp.o.d -o CMakeFiles/withershins.dir/withershins.cpp.o -c /tmp/guix-build-withershins-0.1.drv-0/source/src/withershins.cpp
[ 33%] Building CXX object src/CMakeFiles/withershins.dir/withershins_unix.cpp.o
cd /tmp/guix-build-withershins-0.1.drv-0/source/src && /gnu/store/5lqhcv91ijy82p92ac6g5xw48l0lwwz4-gcc-11.3.0/bin/c++ -DWITHERSHINS_ENABLE_LIBBFD -I/tmp/guix-build-withershins-0.1.drv-0/source/src -std=c++11 -Wall -Wextra -pthread -O2 -g -DNDEBUG -MD -MT src/CMakeFiles/withershins.dir/withershins_unix.cpp.o -MF CMakeFiles/withershins.dir/withershins_unix.cpp.o.d -o CMakeFiles/withershins.dir/withershins_unix.cpp.o -c /tmp/guix-build-withershins-0.1.drv-0/source/src/withershins_unix.cpp
/tmp/guix-build-withershins-0.1.drv-0/source/src/withershins_unix.cpp: In function ‘bool find_file_info(const string&, const void*, std::string&, std::string&, int&)’:
/tmp/guix-build-withershins-0.1.drv-0/source/src/withershins_unix.cpp:151:37: error: ‘bfd_get_section_vma’ was not declared in this scope; did you mean ‘bfd_set_section_vma’?
151 | const bfd_vma section_vma = bfd_get_section_vma(abfd.get(), section);
| ^~~~~~~~~~~~~~~~~~~
| bfd_set_section_vma
/tmp/guix-build-withershins-0.1.drv-0/source/src/withershins_unix.cpp:153:58: error: cannot convert ‘std::unique_ptr<bfd, bfd_delete>::pointer’ {aka ‘bfd*’} to ‘const asection*’ {aka ‘const bfd_section*’}
153 | vma < section_vma + bfd_section_size(abfd.get(), section))
| ~~~~~~~~^~
| |
| std::unique_ptr<bfd, bfd_delete>::pointer {aka bfd*}
In file included from /tmp/guix-build-withershins-0.1.drv-0/source/src/withershins_unix.cpp:21:
/gnu/store/cv571kkg5hyk98yw48857h1d0zi9azni-binutils-2.38/include/bfd.h:1193:35: note: initializing argument 1 of ‘bfd_size_type bfd_section_size(const asection*)’
1193 | bfd_section_size (const asection *sec)
| ~~~~~~~~~~~~~~~~^~~
make[2]: *** [src/CMakeFiles/withershins.dir/build.make:93: src/CMakeFiles/withershins.dir/withershins_unix.cpp.o] Error 1
make[2]: Leaving directory '/tmp/guix-build-withershins-0.1.drv-0/source'
make[1]: *** [CMakeFiles/Makefile2:119: src/CMakeFiles/withershins.dir/all] Error 2
make[1]: Leaving directory '/tmp/guix-build-withershins-0.1.drv-0/source'
make: *** [Makefile:94: all] Error 2
error: in phase 'build': uncaught exception:
%exception #<&invoke-error program: "make" arguments: () exit-status: 2 term-signal: #f stop-signal: #f>
phase `build' failed after 0.5 seconds
References:
- Similar issue in aws-lambda-cpp https://github.com/awslabs/aws-lambda-cpp/issues/93.
--
Oleg
-----BEGIN PGP SIGNATURE-----
iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmYSbEQACgkQdtcnv/Ys
0rXihg//YGQxV7Xvj3vG2SDpSbv218GRiN7zEzzHFsg2sop8LO5aK89yxrVH/fPa
ayLH6lIYO6VNaQsb/Rmyn4SiBz4uJw6OXgFMQzxWdIXJHZ5lzPD7TMz7jdA7Tg6e
wQGLvR+o8Y11l0aZazXLR/pR5Am3DjUQWyKp32lwDaaCNhuM04kj84DNyRSTpBJW
WCJ0QhvLJEoo7CW4Jh9NJ11CKRSektJzIAScheIqf4rbZMA1FLUDTai7PLrEJO3y
2QeQdum0LI3aIQNynxJCtkWHigv0DZ8u+BGS2foV+eUPq6jSszMMOCSPrwaV7DUU
xz8Unk+ngp2tXzj2wQqHDYCv2ThnP5ICX0zF3DUiKzYVQE+9jeqF16be/1kB3JJx
HAMkqA8JcXZC3m5XeJteVZGHR6r8Kz8aPhAjpeg/I883gnRE+Pa6V7utKSJpcaEO
PjYGanifwxD444FGYd3qHqnAem19tmapr+ERCsMiUDGHrbuvjUgsdA9rbQj/bwyr
50JFI+mihbmgZ1xzGX7f7p4A5GtIWGdAS5EiLefxq53k4oYoDBW2Z2fMBWzvXxl1
yzrpTuWWPwLYO+qHcEh7KVdHgVjXk05N+Jgd8Kj3fmfL7N7qlZyd72l3SO4PZfuX
pxGnI1QsUiwfYK7lPpVFEQgZL7ZixCsCU0A8xhbA6+UgClgSCHc=
=DkUa
-----END PGP SIGNATURE-----