[PATCH] gnu: Add kmail-account-wizard.

  • Done
  • quality assurance status badge
Details
2 participants
  • Sughosha
  • Zheng Junjie
Owner
unassigned
Submitted by
Sughosha
Severity
normal
S
S
Sughosha wrote on 7 Apr 10:33 +0200
(address . guix-patches@gnu.org)(name . Sughosha)(address . sughosha@disroot.org)
e297a7a2f9cf9db23701d5434da851f21ee264bb.1712478828.git.sughosha@disroot.org
* gnu/packages/kde-pim.scm (kmail-account-wizard): New variable.

Change-Id: I1648f588712ccfe5a8e34c16a92f440691d3af18
---
gnu/packages/kde-pim.scm | 49 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 49 insertions(+)

Toggle diff (64 lines)
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index 5780b9dbca..e4ab27467c 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -1329,6 +1329,55 @@ (define-public kmail
(license ;; GPL for programs, LGPL for libraries, FDL for documentation
(list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
+(define-public kmail-account-wizard
+ (package
+ (name "kmail-account-wizard")
+ (version "23.04.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/release-service/" version
+ "/src/kmail-account-wizard-" version ".tar.xz"))
+ (sha256
+ (base32 "1840zjgrqwk2zgqbb33gl9nvigsrmk5grzvzg5cw116h7lb7z7xx"))))
+ (build-system qt-build-system)
+ (native-inputs
+ (list extra-cmake-modules shared-mime-info))
+ (inputs
+ (list akonadi
+ akonadi-mime
+ kcrash
+ kross
+ kcmutils
+ kdbusaddons
+ kiconthemes
+ kidentitymanagement
+ kimap
+ kitemmodels
+ kldap
+ kmailtransport
+ kmime
+ knewstuff
+ knotifications
+ knotifyconfig
+ kpimcommon
+ kpimtextedit
+ ktextaddons
+ ktexteditor
+ kwallet
+ libkdepim
+ libkleo
+ qtkeychain
+ qtscript
+ qttools-5))
+ (home-page "https://invent.kde.org/pim/kmail-account-wizard")
+ (synopsis "Assistant for the configuration of accounts in KMail")
+ (description
+ "This package provides an assistant for the configuration of accounts in
+KMail.")
+ (license ;;GPL for programs, LGPL for libraries, FDL for documentation
+ (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
+
(define-public kmailcommon
(package
(name "kmailcommon")

base-commit: 188d18fc47f0d38edfe06e3e5834fa8587bd300b
--
2.41.0
Z
Z
Zheng Junjie wrote on 18 Jul 07:23 +0200
(name . Sughosha via Guix-patches via)(address . guix-patches@gnu.org)
87a5ifi88z.fsf@iscas.ac.cn
Sughosha via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (69 lines)
> * gnu/packages/kde-pim.scm (kmail-account-wizard): New variable.
>
> Change-Id: I1648f588712ccfe5a8e34c16a92f440691d3af18
> ---
> gnu/packages/kde-pim.scm | 49 ++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 49 insertions(+)
>
> diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
> index 5780b9dbca..e4ab27467c 100644
> --- a/gnu/packages/kde-pim.scm
> +++ b/gnu/packages/kde-pim.scm
> @@ -1329,6 +1329,55 @@ (define-public kmail
> (license ;; GPL for programs, LGPL for libraries, FDL for documentation
> (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
>
> +(define-public kmail-account-wizard
> + (package
> + (name "kmail-account-wizard")
> + (version "23.04.3")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "mirror://kde/stable/release-service/" version
> + "/src/kmail-account-wizard-" version ".tar.xz"))
> + (sha256
> + (base32 "1840zjgrqwk2zgqbb33gl9nvigsrmk5grzvzg5cw116h7lb7z7xx"))))
> + (build-system qt-build-system)
> + (native-inputs
> + (list extra-cmake-modules shared-mime-info))
> + (inputs
> + (list akonadi
> + akonadi-mime
> + kcrash
> + kross
> + kcmutils
> + kdbusaddons
> + kiconthemes
> + kidentitymanagement
> + kimap
> + kitemmodels
> + kldap
> + kmailtransport
> + kmime
> + knewstuff
> + knotifications
> + knotifyconfig
> + kpimcommon
> + kpimtextedit
> + ktextaddons
> + ktexteditor
> + kwallet
> + libkdepim
> + libkleo
> + qtkeychain
> + qtscript
> + qttools-5))
> + (home-page "https://invent.kde.org/pim/kmail-account-wizard")
> + (synopsis "Assistant for the configuration of accounts in KMail")
> + (description
> + "This package provides an assistant for the configuration of accounts in
> +KMail.")
> + (license ;;GPL for programs, LGPL for libraries, FDL for documentation
> + (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
> +
> (define-public kmailcommon
> (package
> (name "kmailcommon")
>
> base-commit: 188d18fc47f0d38edfe06e3e5834fa8587bd300b
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmaYprwACgkQO1qpk+Gi
3/AzHRAAu26k3jG+YFAw3exVpmTPPsw2Gs5h8NjKQDAAIUydyXJwi1AjXVE+1LLx
U3o43qWlh78AS+SpsvvWhF8T/WNKkVcRF88qZ9dDg8U8mnjYsJcuAHX4dds1cju2
aeHKdTD9ACHnJFSigSSRc0KF5Jwy024GQzuhf4miI4MMeXZakjx7F/ruNBjMHIDf
ZMlSSpRJHSZyu1MTLCNXbYJYUGUjh8S0uVhuigH67Hepz1UqppYN4SA4Ze95LmRD
ONkW3qzcn4F2VDDc5CsDKjP4VH9pcJ3U/EPQ2DbqlEItPhhs91UraXAq4MjpzmUg
1U/K69K7Onec8jz/+SbT5ynXDuA51g9TaYqZZvoRakquhFGAIrf5FgIZw76B2zdx
fbSIVVus8Kc8XzaF8Sr5d2DhK4dK+tlxDN0y6NszN7cS9gI+KkMMlabMjYECZo2q
smfyGK2wM6A3pVhdSHVnOXtb74q6k+xS2qiJ6+Ic6Hte+WVjMKUojSYWTLM2UlUN
ajTEdj5D6i6P3dKNoyhuCh2umqJtUkLHQMMsPer8KtTjgMLAP7VQtKfpTEoXevIW
ZkH+l89RN7Hyw/CL4ivwo5FFhvdI/DqevZu9NaU5v8wbATNs9gpAo0LCBbjoU8l8
MjQbUhlkcV3NRuQKOMfsGlwrfj6OJsv4iZZgAw+LG+3jXL0pmRs=
=xn/T
-----END PGP SIGNATURE-----

?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 70253@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70253
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch