[PATCH 0/3] Add optional Blender dependencies.

  • Open
  • quality assurance status badge
Details
One participant
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 6 Apr 18:46 +0200
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
cover.1712421899.git.monego@posteo.net
Vinicius Monego (3):
gnu: openimageio: Add optional dependencies.
gnu: Add materialx.
gnu: blender: Add optional dependencies.

gnu/packages/graphics.scm | 58 ++++++++++++++++++++++++++++++++++++++-
1 file changed, 57 insertions(+), 1 deletion(-)


base-commit: 12fd64c9f952189d82a8a6ba91f2178c479eb890
--
2.39.2
V
V
Vinicius Monego wrote on 6 Apr 18:49 +0200
[PATCH 1/3] gnu: openimageio: Add optional dependencies.
(address . 70242@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
d11030a34d33735754a7d027d8d128a1b389bec2.1712421963.git.monego@posteo.net
* gnu/packages/graphics.scm (openimageio)[inputs]: Add dcmtk, ffmpeg,
freetype, libglvnd, libraw, libwebp, opencolorio, openjpeg, tbb.

Change-Id: I19ac4119783744a37aee0b55d4b49dcf02b55762
---
gnu/packages/graphics.scm | 9 +++++++++
1 file changed, 9 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index a63629823a..fcf3999f24 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1323,18 +1323,27 @@ (define-public openimageio
(list pkg-config))
(inputs
(list boost
+ dcmtk
+ ffmpeg
fmt
+ freetype
giflib
imath
+ libglvnd
libheif
libjpeg-turbo
libpng
+ libraw
libtiff
+ libwebp
+ opencolorio
openexr
+ openjpeg
pugixml
pybind11
python-wrapper
robin-map
+ tbb
zlib))
(synopsis "C++ library for reading and writing images")
(description

base-commit: 12fd64c9f952189d82a8a6ba91f2178c479eb890
--
2.39.2
V
V
Vinicius Monego wrote on 6 Apr 18:49 +0200
[PATCH 2/3] gnu: Add materialx.
(address . 70242@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
b7f4ae5f961c576284466a21d29f0e56f4532a09.1712421963.git.monego@posteo.net
* gnu/packages/graphics.scm (materialx): New variable.

Change-Id: I62c6a1675114611f23287068148171a44fa30a42
---
gnu/packages/graphics.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index fcf3999f24..cd7dbf2dbe 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1354,6 +1354,41 @@ (define-public openimageio
(home-page "https://www.openimageio.org")
(license license:bsd-3)))
+(define-public materialx
+ (package
+ (name "materialx")
+ (version "1.38.9")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/AcademySoftwareFoundation/MaterialX")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "190xkg1q1sr9d95rq8rim6cxzlg2safki9i9zjsjw9wwv2bl95wr"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:configure-flags #~(list "-DBUILD_SHARED_LIBS=ON")
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke
+ "ctest" "-E"
+ "MaterialXTest_Render_GLSL_TestSuite")))))))
+ (inputs
+ (list libglvnd libx11 libxt))
+ (home-page "https://materialx.org/")
+ (synopsis
+ "Standard for the exchange of rich material and look-development content")
+ (description "MaterialX is an open standard for representing rich material
+and look-development content in computer graphics, enabling its
+platform-independent description and exchange across applications and
+renderers.")
+ (license license:asl2.0)))
+
(define-public openscenegraph
(package
(name "openscenegraph")
--
2.39.2
V
V
Vinicius Monego wrote on 6 Apr 18:49 +0200
[PATCH 3/3] gnu: blender: Add optional dependencies.
(address . 70242@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
382b61d3ed157cecc582b071201ef53827bf6c08.1712421963.git.monego@posteo.net
* gnu/packages/graphics.scm (blender)[inputs]: Add alembic, libharu, libspnav,
libwebp, llvm, materialx, openshadinglanguage, openxr, potrace, pulseaudio,
sdl2.

Change-Id: Ic6354df6623781d08876dc8aa1f89065e07f92f6
---
gnu/packages/graphics.scm | 14 +++++++++++++-
1 file changed, 13 insertions(+), 1 deletion(-)

Toggle diff (59 lines)
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index cd7dbf2dbe..bf6420d19a 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -70,6 +70,7 @@ (define-module (gnu packages graphics)
#:use-module (gnu packages crypto)
#:use-module (gnu packages datastructures)
#:use-module (gnu packages documentation)
+ #:use-module (gnu packages engineering)
#:use-module (gnu packages flex)
#:use-module (gnu packages fonts)
#:use-module (gnu packages fontutils)
@@ -544,7 +545,8 @@ (define-public blender
"/lib/python" #$python-version
"/site-packages/")))))
(inputs
- (list boost
+ (list alembic
+ boost
bullet
eigen
embree
@@ -558,24 +560,34 @@ (define-public blender
jack-1
jemalloc
libepoxy
+ libharu
libjpeg-turbo
libpng
libsndfile
+ libspnav
libtiff
+ libwebp
libx11
libxi
libxrender
+ llvm
lzo
+ materialx
openal
opencolorio
openexr
openimageio
openjpeg
+ openshadinglanguage
opensubdiv
openvdb
+ openxr
+ potrace
pugixml
+ pulseaudio
python
python-numpy
+ sdl2
tbb
zlib
`(,zstd "lib")))
--
2.39.2
?