[PATCH] gnu: uefitool: Add extra outputs, correct typo

  • Open
  • quality assurance status badge
Details
2 participants
  • Ian Eure
  • Christopher Baines
Owner
unassigned
Submitted by
Ian Eure
Severity
normal
I
I
Ian Eure wrote on 6 Apr 17:24 +0200
(address . guix-patches@gnu.org)(name . Ian Eure)(address . ian@retrospec.tv)
db7d802738f4de9e67fb5287769d5a702abeda6a.1712417040.git.ian@retrospec.tv
* gnu/packages/flashing-tools.scm (uefitool): Add UEFIPatch and UEFIReplace in
addition to UEFITool; add outputs for them. Correct package description.

Change-Id: I45ca03a71c463c91ab11e9dcd47971afc06724b7
---
gnu/packages/flashing-tools.scm | 46 ++++++++++++++++++++++++---------
1 file changed, 34 insertions(+), 12 deletions(-)

Toggle diff (72 lines)
diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index 83a4c3e3e7..3787e9d32a 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -493,29 +493,51 @@ (define-public uefitool
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/LongSoft/UEFITool")
- (commit version)))
+ (url "https://github.com/LongSoft/UEFITool")
+ (commit version)))
(sha256
(base32
"1n2hd2dysi5bv2iyq40phh1jxc48gdwzs414vfbxvcharcwapnja"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
+ (outputs '("out" "uefipatch" "uefireplace"))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda _
- (invoke "qmake" "-makefile")))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (install-file "UEFITool" (string-append (assoc-ref outputs "out")
- "/bin")))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (invoke "qmake" "-makefile")))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (install-file "UEFITool" (string-append (assoc-ref outputs "out")
+ "/bin"))))
+ (add-after 'configure 'configure-extras
+ (lambda _
+ (with-directory-excursion "UEFIPatch"
+ (invoke "qmake" "-makefile"))
+ (with-directory-excursion "UEFIReplace"
+ (invoke "qmake" "-makefile"))))
+ (add-after 'build 'build-extras
+ (lambda _
+ (with-directory-excursion "UEFIPatch"
+ (invoke "make" "-j"))
+ (with-directory-excursion "UEFIReplace"
+ (invoke "make" "-j"))))
+ (add-after 'install 'install-extras
+ (lambda* (#:key outputs #:allow-other-keys)
+ (install-file "UEFIPatch/UEFIPatch"
+ (string-append (assoc-ref outputs "uefipatch")
+ "/bin"))
+ (install-file "UEFIReplace/UEFIReplace"
+ (string-append (assoc-ref outputs "uefireplace")
+ "/bin")))))))
(inputs
(list qtbase-5))
(home-page "https://github.com/LongSoft/UEFITool/")
(synopsis "UEFI image editor")
(description "@code{uefitool} is a graphical image file editor for
-Unifinished Extensible Firmware Interface (UEFI) images.")
+Unified Extensible Firmware Interface (UEFI) images.")
(license license:bsd-2)))
(define-public srecord

base-commit: ab3731d255ff1ac8d6874bc0f68ad94f21f08e79
--
2.41.0
C
C
Christopher Baines wrote on 15 Apr 10:58 +0200
(name . Ian Eure)(address . ian@retrospec.tv)(address . 70240@debbugs.gnu.org)
87ttk30zq3.fsf@cbaines.net
Ian Eure <ian@retrospec.tv> writes:

Toggle quote (27 lines)
> * gnu/packages/flashing-tools.scm (uefitool): Add UEFIPatch and UEFIReplace in
> addition to UEFITool; add outputs for them. Correct package description.
>
> Change-Id: I45ca03a71c463c91ab11e9dcd47971afc06724b7
> ---
> gnu/packages/flashing-tools.scm | 46 ++++++++++++++++++++++++---------
> 1 file changed, 34 insertions(+), 12 deletions(-)
>
> diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
> index 83a4c3e3e7..3787e9d32a 100644
> --- a/gnu/packages/flashing-tools.scm
> +++ b/gnu/packages/flashing-tools.scm
> @@ -493,29 +493,51 @@ (define-public uefitool
> (source (origin
> (method git-fetch)
> (uri (git-reference
> - (url "https://github.com/LongSoft/UEFITool")
> - (commit version)))
> + (url "https://github.com/LongSoft/UEFITool")
> + (commit version)))
> (sha256
> (base32
> "1n2hd2dysi5bv2iyq40phh1jxc48gdwzs414vfbxvcharcwapnja"))
> (file-name (git-file-name name version))))
> (build-system gnu-build-system)
> + (outputs '("out" "uefipatch" "uefireplace"))

Is there a reason you have split the files across several outputs?

Generally, unless there's a specific reason to do so, it's better to
keep things simple and in one output.
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmYc7CRfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xc4jA//cgniHJSgwRoA771Uxqa5XihHtdIzkJrs
YEzgVLjGwWeQYYb/bU7w8A0jIyF6xYg7nVgW4bC+q9oHNHlq1VxsoVOg8JIX55Kw
g/kIyvuR1DYKRscilU6jDdJMZqiK88T9XdZDXwBSHiJ8AXW7KMzKXOlHuL9uOKvN
twTFtDu5xjq+klJKMgOTmqgbGMdQI3zBkZHbK2tAVC6ldmaFbATaAXPHoxQamOEe
7OwYP6zo35PdMEIWA0oNqCVyjMrZAz59rfFG8nzH+DmCwa5vE+4Cz6IXVRBjpNq5
RzJDvf2NRaDaPBRfJ+DjhB/6/O533DN7i0Q1bhvGNoePKT4KmmJuQ+NIB2MxaeB3
eQm9KqaG+cGt6268KoZrPEWiP+wWP0/WnaoAUwQpPsBH7t0EHYtIgTweyr5z4UKO
/8vlgaLqVI4dYuo+2AOJv4tVmQ3+mRvfeuBFIA3f9Va7Lyryrv4zlOLGCKKAQsjd
XZcNlGHcvbsOgcNI0IcIW6M9NIgIgZ8A96dYSKRzpi25haZhjCnRSOsPgqg3Ah95
Sx3STq+2JmnWmjIaIQB1zu0QgVIoXBGw3fivVVWaM0BhJBXtS980iTQAhSv/DkWq
0eq6RMdwa98qGQL/2RXmdhhd1aN5BOoLhYmqUBFuXvAE8iRDX3hUvQsieDj7QSvF
UxBVTAOKUjk=
=Xasz
-----END PGP SIGNATURE-----

?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 70240@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70240
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch