[PATCH 0/2] Update c-toxcore and toxic.

  • Done
  • quality assurance status badge
Details
One participant
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 6 Apr 02:45 +0200
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
cover.1712364159.git.monego@posteo.net
Vinicius Monego (2):
gnu: c-toxcore: Update to 0.2.19.
gnu: toxic: Update to 0.15.1.

gnu/packages/messaging.scm | 54 +++++++++++++++++++-------------------
1 file changed, 27 insertions(+), 27 deletions(-)


base-commit: 188d18fc47f0d38edfe06e3e5834fa8587bd300b
--
2.39.2
V
V
Vinicius Monego wrote on 6 Apr 02:47 +0200
[PATCH 1/2] gnu: c-toxcore: Update to 0.2.19.
(address . 70224@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
1f80fc5b8d0b0f10e7bc9097a7ac55f14305e028.1712364159.git.monego@posteo.net
* gnu/packages/messaging.scm (c-toxcore): Update to 0.2.19.
[source]: Fetch sources recursively.
[arguments]<#:configure-flags>: Use G-Expressions. Pass "-DENABLE_STATIC=false".

Change-Id: I42fc47b45e1afdbb2c60c80bc56e1b839923ec34
---
gnu/packages/messaging.scm | 16 ++++++++++------
1 file changed, 10 insertions(+), 6 deletions(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 03b7368ae0..0cd02ae348 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -29,7 +29,7 @@
;;; Copyright © 2020, 2021 Robert Karszniewicz <avoidr@posteo.de>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2021, 2023 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
-;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021, 2024 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 jgart <jgart@dismail.de>
;;; Copyright © 2022 Aleksandr Vityazev <avityazev@posteo.org>
;;; Copyright © 2022 Ricardo Wurmus <rekado@elephly.net>
@@ -1666,20 +1666,24 @@ (define-public libtoxcore
(define-public c-toxcore
(package
(name "c-toxcore")
- (version "0.2.12")
+ (version "0.2.19")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/TokTok/c-toxcore")
- (commit (string-append "v" version))))
+ (commit (string-append "v" version))
+ ;; XXX: c-toxcore now depends on a package called 'cmp', an
+ ;; implementation of MessagePack in C. Fetch the submodule
+ ;; for now, maybe package it later.
+ (recursive? #t)))
(file-name (git-file-name name version))
(sha256
(base32
- "0a6sqpm00d2rn0nviqfz4gh9ck1wzci6rxgmqmcyryl5ca19ffvp"))))
+ "0wq6grc5lfjip39gm0ji1cw6b1sdv1zvimg1g40haqzhj51755za"))))
(arguments
- `(#:tests? #f)) ; FIXME: Testsuite seems to stay stuck on test 3. Disable
- ; for now.
+ (list #:tests? #f ; figure out how to run the tests
+ #:configure-flags #~(list "-DENABLE_STATIC=false")))
(build-system cmake-build-system)
(native-inputs
(list pkg-config))
--
2.39.2
V
V
Vinicius Monego wrote on 6 Apr 02:47 +0200
[PATCH 2/2] gnu: toxic: Update to 0.15.1.
(address . 70224@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
bb388a5312539c7a348fdc3c2e533861cd56ea6c.1712364159.git.monego@posteo.net
* gnu/packages/messaging.scm (toxic): Update to 0.15.1.
[arguments]: Use G-Expressions.
<#:make-flags>: Use gexp variables and cc-for-target.
<#:phases>: Remove trailing #t.

Change-Id: If1d46888e26b16ffcbbca48dc2c88b921e30c433
---
gnu/packages/messaging.scm | 38 +++++++++++++++++---------------------
1 file changed, 17 insertions(+), 21 deletions(-)

Toggle diff (61 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 0cd02ae348..6278bec2ef 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2234,7 +2234,7 @@ (define-public libircclient
(define-public toxic
(package
(name "toxic")
- (version "0.8.4")
+ (version "0.15.1")
(source
(origin
(method git-fetch)
@@ -2242,29 +2242,25 @@ (define-public toxic
(url "https://github.com/JFreegman/toxic")
(commit (string-append "v" version))))
(sha256
- (base32 "0p1cmj1kyp506y5xm04mhlznhf5wcylvgsn6b307ms91vjqs3fg2"))
+ (base32 "1cbgw9my7nd8b215a3db2jc74nibi9kj0yk5q3c9dnh306as6wzs"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no tests
- #:make-flags
- (list
- "CC=gcc"
- (string-append "PREFIX="
- (assoc-ref %outputs "out")))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (add-before 'build 'enable-python-scripting
- (lambda _
- ;; XXX: For compatibility with Python 3.8, adjust python3-config
- ;; invokation to include --embed; see
- ;; <https://github.com/JFreegman/toxic/issues/533>.
- (substitute* "cfg/checks/python.mk"
- (("python3-config --ldflags")
- "python3-config --ldflags --embed"))
- (setenv "ENABLE_PYTHON" "1")
- #t)))))
+ (list #:tests? #f ; no tests
+ #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'enable-python-scripting
+ (lambda _
+ ;; XXX: For compatibility with Python 3.8, adjust
+ ;; python3-config invocation to include --embed; see
+ ;; <https://github.com/JFreegman/toxic/issues/533>.
+ (substitute* "cfg/checks/python.mk"
+ (("python3-config --ldflags")
+ "python3-config --ldflags --embed"))
+ (setenv "ENABLE_PYTHON" "1"))))))
(inputs
(list c-toxcore
curl
--
2.39.2
V
V
Vinicius Monego wrote on 7 Jul 06:20 +0200
Re: [PATCH 0/2] Update c-toxcore and toxic.
(address . 70224-done@debbugs.gnu.org)
b1646d5463f293c1bf928aee5343d7109b1ae412.camel@posteo.net
Em sáb, 2024-04-06 às 00:45 +0000, Vinicius Monego escreveu:
Toggle quote (11 lines)
> Vinicius Monego (2):
>   gnu: c-toxcore: Update to 0.2.19.
>   gnu: toxic: Update to 0.15.1.
>
>  gnu/packages/messaging.scm | 54 +++++++++++++++++++-----------------
> --
>  1 file changed, 27 insertions(+), 27 deletions(-)
>
>
> base-commit: 188d18fc47f0d38edfe06e3e5834fa8587bd300b

Patches pushed a while ago, closing.

Vinicius
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 70224@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70224
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch