(address . bug-guix@gnu.org)
Hi,
I have /var/run and /run on separate file systems, recently I noticed system
reconfiguration stopped with "guix system: error: rename-file: Invalid
cross-device link":
Toggle snippet (19 lines)
newfstatat(AT_FDCWD, "/run", {st_mode=S_IFDIR|0755, st_size=440, ...}, AT_SYMLINK_NOFOLLOW) = 0
newfstatat(AT_FDCWD, "/run/dbus", {st_mode=S_IFDIR|0700, st_size=40, ...}, AT_SYMLINK_NOFOLLOW) = 0
mkdir("/run", 0777) = -1 EEXIST (File exists)
mkdir("/run/dbus", 0777) = -1 EEXIST (File exists)
chown("/run/dbus", 988, 983) = 0
chmod("/run/dbus", 0755) = 0
symlink("/run/dbus", "/var/run/dbus") = -1 EEXIST (File exists)
readlink("/var/run/dbus", 0x1634730, 100) = -1 EINVAL (Invalid argument)
openat(AT_FDCWD, "/var/run/dbus", O_RDONLY|O_NONBLOCK|O_CLOEXEC|O_DIRECTORY) = 17
newfstatat(17, "", {st_mode=S_IFDIR|0755, st_size=80, ...}, AT_EMPTY_PATH) = 0
getdents64(17, 0x16dfe10 /* 4 entries */, 32768) = 112
rename("/var/run/dbus/system_bus_socket", "/run/dbus/system_bus_socket") = -1 EXDEV (Invalid cross-device link)
close(13) = 0
write(2, "\33[1m\33[0mguix system: error: rena"..., 67[1m[0mguix system: error: rename-file: Invalid cross-device link
) = 67
exit_group(1) = ?
+++ exited with 1 +++
It's because /var/run/dbus was used for dbus service before, and now migration
to /run/dbus is done with ‘rename-file’:
Toggle snippet (4 lines)
(rename-file (string-append "/var/run/dbus/" next)
(string-append "/run/dbus/" next))
I think the logic can be improved for this case, but not sure how at the moment.
What do you think?
Thanks