[PATCH] gnu: Borg: Update to 1.2.8.

  • Done
  • quality assurance status badge
Details
3 participants
  • Dale Mellor
  • Leo Famulari
  • Christopher Baines
Owner
Somebody
Submitted by
Leo Famulari
Severity
normal
L
L
Leo Famulari wrote on 2 Apr 20:18 +0200
(address . guix-patches@gnu.org)
46673aa390af70cf1be667190e7d15afb5705b89.1712081885.git.leo@famulari.name
* gnu/packages/backup.scm (borg): Update to 1.2.8.
[arguments]: Remove a variety of workarounds that have been obviated by changes
upstream and in the Python package build tools.

Change-Id: I031bb4e6ac2f562a3e387a5e815b31416367766f
---
gnu/packages/backup.scm | 17 ++++-------------
1 file changed, 4 insertions(+), 13 deletions(-)

Toggle diff (53 lines)
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 4fa39b741c..d671a6283e 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -655,13 +655,13 @@ (define-public libchop
(define-public borg
(package
(name "borg")
- (version "1.2.7")
+ (version "1.2.8")
(source
(origin
(method url-fetch)
(uri (pypi-uri "borgbackup" version))
(sha256
- (base32 "06j1v4bw9jkjh6m29ns5sigmp0cslcf0cyy8rrqij11w72ijhgzn"))
+ (base32 "1aplj54x6hcyg3mnzscnwi07npy7nrws2246ss25ax6bsaq257fk"))
(modules '((guix build utils)))
(snippet
#~(begin
@@ -703,18 +703,10 @@ (define-public borg
(setenv "BORG_OPENSSL_PREFIX" openssl)
(setenv "BORG_LIBLZ4_PREFIX" lz4)
(setenv "BORG_LIBXXHASH_PREFIX" xxhash)
- (setenv "BORG_LIBZSTD_PREFIX" zstd)
- (setenv "PYTHON_EGG_CACHE" "/tmp")
- ;; The test 'test_return_codes[python]' fails when
- ;; HOME=/homeless-shelter.
- (setenv "HOME" "/tmp"))))
- ;; The tests need to be run after Borg is installed.
- (delete 'check)
- (add-after 'install 'check
+ (setenv "BORG_LIBZSTD_PREFIX" zstd))))
+ (replace 'check
(lambda* (#:key inputs outputs tests? #:allow-other-keys)
(when tests?
- ;; Make the installed package available for the test suite.
- (add-installed-pythonpath inputs outputs)
;; The tests should be run in an empty directory.
(mkdir-p "tests")
(with-directory-excursion "tests"
@@ -729,7 +721,6 @@ (define-public borg
"and not test_access_acl "
"and not test_default_acl "
"and not test_get_item_uid_gid "
- "and not test_non_ascii_acl "
"and not test_create_content_from_command "
"and not test_create_content_from_command_with_failed_command "
"and not test_create_stdin "

base-commit: 7af70efd7633b0d70091762cf43ce01a86176e8e
--
2.41.0
D
D
Dale Mellor wrote on 12 Apr 09:38 +0200
Own 70152
(name . control)(address . control@debbugs.gnu.org)
1906e777f604e883e34813cdc838dfe94d3dd437.camel@rdmp.org
owner 70152 !
user guix
usertag 70152 + under-review
quit
D
D
Dale Mellor wrote on 12 Apr 10:01 +0200
[PATCH v2] gnu: Borg: Update to 1.2.8.
(address . 70152@debbugs.gnu.org)
20240412080101.1332966-1-guix-devel-0brg6a@rdmp.org
From: Leo Famulari <leo@famulari.name>

* gnu/packages/backup.scm (borg): Update to 1.2.8.
[arguments]: Remove a variety of workarounds that have been obviated by changes
upstream and in the Python package build tools.

Review:
* guix lint throws false positive due to deprecation in package:inputs field
* guix build --check is clean
* guix install is clean
* it works for me

Reviewed-by: Dale Mellor <guix-devel-0brg6a@rdmp.org>

Change-Id: I031bb4e6ac2f562a3e387a5e815b31416367766f
---
gnu/packages/backup.scm | 17 ++++-------------
1 file changed, 4 insertions(+), 13 deletions(-)

Toggle diff (51 lines)
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 699f4cbc8f..44365d3bcb 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -675,13 +675,13 @@ (define-public libchop
(define-public borg
(package
(name "borg")
- (version "1.2.7")
+ (version "1.2.8")
(source
(origin
(method url-fetch)
(uri (pypi-uri "borgbackup" version))
(sha256
- (base32 "06j1v4bw9jkjh6m29ns5sigmp0cslcf0cyy8rrqij11w72ijhgzn"))
+ (base32 "1aplj54x6hcyg3mnzscnwi07npy7nrws2246ss25ax6bsaq257fk"))
(modules '((guix build utils)))
(snippet
#~(begin
@@ -723,18 +723,10 @@ (define-public borg
(setenv "BORG_OPENSSL_PREFIX" openssl)
(setenv "BORG_LIBLZ4_PREFIX" lz4)
(setenv "BORG_LIBXXHASH_PREFIX" xxhash)
- (setenv "BORG_LIBZSTD_PREFIX" zstd)
- (setenv "PYTHON_EGG_CACHE" "/tmp")
- ;; The test 'test_return_codes[python]' fails when
- ;; HOME=/homeless-shelter.
- (setenv "HOME" "/tmp"))))
- ;; The tests need to be run after Borg is installed.
- (delete 'check)
- (add-after 'install 'check
+ (setenv "BORG_LIBZSTD_PREFIX" zstd))))
+ (replace 'check
(lambda* (#:key inputs outputs tests? #:allow-other-keys)
(when tests?
- ;; Make the installed package available for the test suite.
- (add-installed-pythonpath inputs outputs)
;; The tests should be run in an empty directory.
(mkdir-p "tests")
(with-directory-excursion "tests"
@@ -749,7 +741,6 @@ (define-public borg
"and not test_access_acl "
"and not test_default_acl "
"and not test_get_item_uid_gid "
- "and not test_non_ascii_acl "
"and not test_create_content_from_command "
"and not test_create_content_from_command_with_failed_command "
"and not test_create_stdin "
--
2.41.0
C
C
Christopher Baines wrote on 15 Apr 11:32 +0200
(name . Dale Mellor)(address . guix-devel-0brg6a@rdmp.org)
877cgz0y4a.fsf@cbaines.net
Dale Mellor <guix-devel-0brg6a@rdmp.org> writes:

Toggle quote (19 lines)
> From: Leo Famulari <leo@famulari.name>
>
> * gnu/packages/backup.scm (borg): Update to 1.2.8.
> [arguments]: Remove a variety of workarounds that have been obviated by changes
> upstream and in the Python package build tools.
>
> Review:
> * guix lint throws false positive due to deprecation in package:inputs field
> * guix build --check is clean
> * guix install is clean
> * it works for me
>
> Reviewed-by: Dale Mellor <guix-devel-0brg6a@rdmp.org>
>
> Change-Id: I031bb4e6ac2f562a3e387a5e815b31416367766f
> ---
> gnu/packages/backup.scm | 17 ++++-------------
> 1 file changed, 4 insertions(+), 13 deletions(-)

Thanks both, I've pushed this to master as
2c059863483b698c4f6f50a2ce4daaef5f1de83f.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmYc9EVfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xf10RAAsFL9lV4uEBcCSXz0JqA/6aZpSvM+ze6f
C8U3l489TxQrr+Jm6WAIRo3s1NCHdMep+qlJ/7eOQrAas/H+ItkvIxcfhyN3+J68
5JfQpV6wBDd0qpmtrZUFG95G4gHrBnJ9A3ERUWFQhUJzUw0VWv+JZ2wZhQQaIqDn
p1Kpq4W99OEGItIm3kplns2djl1HHsvftM4R3e1t8R09eOmHYYR6z/QVOSCBwYxr
X0o06LYR2voTb745XtGD0iP1sJ+ZbIrHFDxLI26Ev0dLNuzFO/QZAG39cuGXw3KY
EGt+Gc0OYHfkDHtchxsPw/jVIenEg8vcSzz4FWVNRxDZJi8eS7c0ikQOuGuAZZZZ
XV8YHzZmix8QHZ2F3GU3JelYBx28abYm0M+XuAAq5R28Tcr8sWxPNcR2r9N+V/c0
9r3L4uFxbE7pco/asg9Mw+dDCZXMhSpYkcr8mevlQqn8dhj3576rQq4PvujXqiGQ
1H1xlLEUJ1Q6V+nu1ymNoFkAFepXrY+5bnMqWadrw7k9PoqjizYAcO51vPH1R3j8
3dVbafuaTXOR3l+5MxtoWCwtxm4RQE80iF1IteduTcOE7PLplpkI8L+n8mxa+fFH
KiHd4Gd4vDMjYdElnzRX/KdPoazX4yo403DptKNSRqqu98IpwJvTqlxIzWW4B5Nh
RYa/5Qvs7xc=
=luc8
-----END PGP SIGNATURE-----

Closed
L
L
Leo Famulari wrote on 17 Apr 20:06 +0200
(name . Christopher Baines)(address . mail@cbaines.net)
ZiAPozaONqroSn8J@jasmine.lan
On Mon, Apr 15, 2024 at 10:32:53AM +0100, Christopher Baines wrote:
Toggle quote (3 lines)
> Thanks both, I've pushed this to master as
> 2c059863483b698c4f6f50a2ce4daaef5f1de83f.

Thanks to Dale and Chris!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70152@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70152
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch