(address . guix-patches@gnu.org)
* gnu/packages/backup.scm (borg): Update to 1.2.8.
[arguments]: Remove a variety of workarounds that have been obviated by changes
upstream and in the Python package build tools.
Change-Id: I031bb4e6ac2f562a3e387a5e815b31416367766f
---
gnu/packages/backup.scm | 17 ++++-------------
1 file changed, 4 insertions(+), 13 deletions(-)
Toggle diff (53 lines)
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 4fa39b741c..d671a6283e 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -655,13 +655,13 @@ (define-public libchop
(define-public borg
(package
(name "borg")
- (version "1.2.7")
+ (version "1.2.8")
(source
(origin
(method url-fetch)
(uri (pypi-uri "borgbackup" version))
(sha256
- (base32 "06j1v4bw9jkjh6m29ns5sigmp0cslcf0cyy8rrqij11w72ijhgzn"))
+ (base32 "1aplj54x6hcyg3mnzscnwi07npy7nrws2246ss25ax6bsaq257fk"))
(modules '((guix build utils)))
(snippet
#~(begin
@@ -703,18 +703,10 @@ (define-public borg
(setenv "BORG_OPENSSL_PREFIX" openssl)
(setenv "BORG_LIBLZ4_PREFIX" lz4)
(setenv "BORG_LIBXXHASH_PREFIX" xxhash)
- (setenv "BORG_LIBZSTD_PREFIX" zstd)
- (setenv "PYTHON_EGG_CACHE" "/tmp")
- ;; The test 'test_return_codes[python]' fails when
- ;; HOME=/homeless-shelter.
- (setenv "HOME" "/tmp"))))
- ;; The tests need to be run after Borg is installed.
- (delete 'check)
- (add-after 'install 'check
+ (setenv "BORG_LIBZSTD_PREFIX" zstd))))
+ (replace 'check
(lambda* (#:key inputs outputs tests? #:allow-other-keys)
(when tests?
- ;; Make the installed package available for the test suite.
- (add-installed-pythonpath inputs outputs)
;; The tests should be run in an empty directory.
(mkdir-p "tests")
(with-directory-excursion "tests"
@@ -729,7 +721,6 @@ (define-public borg
"and not test_access_acl "
"and not test_default_acl "
"and not test_get_item_uid_gid "
- "and not test_non_ascii_acl "
"and not test_create_content_from_command "
"and not test_create_content_from_command_with_failed_command "
"and not test_create_stdin "
base-commit: 7af70efd7633b0d70091762cf43ce01a86176e8e
--
2.41.0