[PATCH] gnu: Add emacs-stgit-2.

  • Open
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Sergio Pastor Pérez
Owner
unassigned
Submitted by
Sergio Pastor Pérez
Severity
normal
S
S
Sergio Pastor Pérez wrote on 1 Apr 21:54 +0200
(address . guix-patches@gnu.org)(name . Sergio Pastor Pérez)(address . sergio.pastorperez@outlook.es)
PAXP251MB034804BA6AB148963B84A49EF33F2@PAXP251MB0348.EURP251.PROD.OUTLOOK.COM
* gnu/packages/emacs-xyz.scm (emacs-stgit-2): New variable.

Change-Id: I0231d35ae94ce26eb4a9e55f70d78ab33c5f03e3
---
gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 977aa89729..4999048625 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -7552,6 +7552,32 @@ (define-public emacs-standard-dirs
configuration, cache, and other data.")
(license license:gpl3+)))
+(define-public emacs-stgit-2
+ (package
+ (inherit stgit-2)
+ (name "emacs-stgit")
+ (build-system emacs-build-system)
+ (native-inputs '())
+ (inputs (list stgit-2 git))
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "contrib")))
+ (add-after 'chdir 'patch-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((stgit (search-input-file inputs "/bin/stg"))
+ (git (search-input-file inputs "/bin/git")))
+ (substitute* "stgit.el"
+ (("\"stg\"")
+ (string-append "\"" stgit "\""))
+ (("\"git\"")
+ (string-append "\"" git "\"")))))))))
+ (synopsis "Run Stgit within Emacs")
+ (description
+ "This package provides an Emacs-based interface to the Stgit.")))
+
(define-public emacs-string-inflection
(package
(name "emacs-string-inflection")

base-commit: 9e9ec741d0dc5ce58f8d21d31800ff2cafce128f
--
2.41.0
C
C
Christopher Baines wrote on 15 Apr 20:52 +0200
(name . Sergio Pastor Pérez)(address . sergio.pastorperez@outlook.es)
87wmoyv4ps.fsf@cbaines.net
Sergio Pastor Pérez <sergio.pastorperez@outlook.es> writes:

Toggle quote (19 lines)
> * gnu/packages/emacs-xyz.scm (emacs-stgit-2): New variable.
>
> Change-Id: I0231d35ae94ce26eb4a9e55f70d78ab33c5f03e3
> ---
> gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
> 1 file changed, 26 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 977aa89729..4999048625 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -7552,6 +7552,32 @@ (define-public emacs-standard-dirs
> configuration, cache, and other data.")
> (license license:gpl3+)))
>
> +(define-public emacs-stgit-2
> + (package
> + (inherit stgit-2)

Package inheritance across modules is problomatic [1], which is probably
what's causing the issue with QA/the data service processing this.

You can avoid this by moving the package definition to the
version-control module where stgit-2 is defined.

-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmYdd19fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XeMehAAsCndl8g//7Thwn5SB9CRRXyEW3G8V/UK
YOlxlwd1D+hHrnNky+VLPUp66sj4shiWsMdv2wvVw18jBuWbu4WqXlQu4i37gJzR
bQNgEAzem/guhtrMUHjFJWf+8sAxIPg4AFBL5vzq5HWd+NqGtHD5D+ygpaVuonRm
HHtR4ScnEul2cJ3qM4TRLOeJT7FXs9X4UAxJKJ9EInIVrfbSFNRwgNOAwFGS0zbk
pOXnAy7aaTGmk66bJrl4raC3hJbHgDXRQAPAj9ZsCAI+Ble43tR0Bww1DIg+5qux
nb6apPToHkmGvMDAiDHVLUeObT1dsaFloeKyNzepsQmBShP0wm4+7YOA3d9sMXWS
OJkcZLAc2nzgCDlKLYiDn3iUHeBFCojDtD+hIaKtTQWQQLAo5M6t837l5GBAWSo4
UetX/MSwVdhLe0Abp9FEM7lj/i9d3ZARnEPQZuAmIk2AUDWnDfZHyw9swZAmZO2y
iprNzG/i01q+WwnMGE0cduYryXregVqimyZktCXPLJJuqKkgZtW6iAL4e1MWPrXt
ByUHqLZKH4rEEbKTp3ZPn3/qoD+XCWIm7XbH/A2sQJfkD4LR3PkCSg78nQq3DTGB
cQqQZNUbkeQXwPSaI2qN2vedoHwObpzVnyIfYOvdW6u3fyBiidF6ecmhGp35cRlV
Nm1lUOgKcD4=
=/oFa
-----END PGP SIGNATURE-----

?