[PATCH] home: services: add newline to XDG_RUNTIME_DIR warning

  • Open
  • quality assurance status badge
Details
One participant
  • Richard Sent
Owner
unassigned
Submitted by
Richard Sent
Severity
normal
R
R
Richard Sent wrote on 30 Mar 02:10 +0100
(address . guix-patches@gnu.org)(name . Richard Sent)(address . richard@freakingpenguin.com)
06b44aeb449a5335f12e1a4774d8a3222d87bf8c.1711761035.git.richard@freakingpenguin.com
* gnu/home/services.scm: Add end-of-text newline to warning printed by
on-first-login script when XDG_RUNTIME_DIR does not exist.

Change-Id: I3bfe2c415f6941fa9a2231ab2a0be53db965053f
---
Without this change, the prompt will be pushed to the side by the
warning message. Other warnings in the repo follow this convention, so
I assume this one should as well.

gnu/home/services.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/home/services.scm b/gnu/home/services.scm
index b69cd91203..39c9033ad6 100644
--- a/gnu/home/services.scm
+++ b/gnu/home/services.scm
@@ -445,7 +445,7 @@ (define (compute-on-first-login-script _ gexps)
(warning (G_ "XDG_RUNTIME_DIR doesn't exists, on-first-login script
won't execute anything. You can check if xdg runtime directory exists,
XDG_RUNTIME_DIR variable is set to appropriate value and manually execute the
-script by running '$HOME/.guix-home/on-first-login'"))))))))
+script by running '$HOME/.guix-home/on-first-login'~%"))))))))
(define (on-first-login-script-entry on-first-login)
"Return, as a monadic value, an entry for the on-first-login script

base-commit: d67e4f0f9b10c7ddac8fb0ca68cbf1d6ad0a6e5d
--
2.41.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 70085@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70085
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch