[PATCH] gnu: Add python-find-libpython.

  • Open
  • quality assurance status badge
Details
One participant
  • Cayetano Santos
Owner
unassigned
Submitted by
Cayetano Santos
Severity
normal
C
C
Cayetano Santos wrote on 29 Mar 09:57 +0100
(address . guix-patches@gnu.org)(name . Cayetano Santos)(address . csantosb@inventati.org)
d8c65cdcdbb550a50d99441a5903a59abea52e91.1711702678.git.csantosb@inventati.org
* gnu/packages/python-xyz.scm (python-find-libpython): New variable.
---
gnu/packages/python-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8a6ef23b58..7008ee6ae9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20886,6 +20886,29 @@ (define-public python-lark-parser
some degree most natural languages too.")
(license license:expat)))
+(define-public python-find-libpython
+ (package
+ (name "python-find-libpython")
+ (version "0.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ktbarrett/find_libpython")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1z1r9nix2z75sv41j97pnl6jgj2lk6k8la23vavxjpprsc9ld1dd"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-pytest))
+ (home-page "https://github.com/ktbarrett/find_libpython")
+ (synopsis "Find the path to the @code{libpython} dynamic library")
+ (description "@code{find_libpython} helps find the path to the
+@code{libpython} dynamic library for the current Python environment. It is
+both a script and a Python package.")
+ (license license:expat)))
+
(define-public python-libcst
(package
(name "python-libcst")

base-commit: 0ff72d105ca03a82de6bb5193266fd05fce72daf
--
2.41.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 70067@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70067
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch