[PATCH] gnu: rust-xkbcommon-dl: Fix loading of libxkbcommon-x11.so.

  • Done
  • quality assurance status badge
Details
One participant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 11 months ago
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
d5a7866dc65b5a36d717a028c7ff5bfbb2b36d3d.1711630844.git.sharlatanus@gmail.com
This to resolve Alacritty segmentation fault reported in #68243, attemp
to fix in #69797.

* gnu/packages/crates-graphics.scm (rust-xkbcommon-dl) [arguments]:
Handle libxkbcommon-x11.so in the ‘add-absolute-library-references’
phase.

Change-Id: Ib724775210cfad7dedaa454f0f456c0dded67dcc
---
gnu/packages/crates-graphics.scm | 14 +++++++++++++-
1 file changed, 13 insertions(+), 1 deletion(-)

Toggle diff (36 lines)
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index f95a4a65cd..117b4f5603 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2023, 2024 Jaeme Sifat <jaeme@runbox.com>
;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
+;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5745,7 +5746,18 @@ (define-public rust-xkbcommon-dl-0.4
("rust-dlib" ,rust-dlib-0.5)
("rust-log" ,rust-log-0.4)
("rust-once-cell" ,rust-once-cell-1)
- ("rust-xkeysym" ,rust-xkeysym-0.2))))
+ ("rust-xkeysym" ,rust-xkeysym-0.2))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'configure 'add-absolute-library-references
+ (lambda* (#:key inputs vendor-dir #:allow-other-keys)
+ (substitute* (find-files vendor-dir "\\.rs$")
+ (("libxkbcommon-x11\\.so")
+ (search-input-file inputs "lib/libxkbcommon-x11.so"))
+ (("libxkbcommon\\.so")
+ (search-input-file inputs "lib/libxkbcommon.so"))))))))
+ (inputs
+ (list libxkbcommon))
(home-page "https://github.com/rust-windowing/xkbcommon-dl")
(synopsis "Dynamically loaded xkbcommon and xkbcommon-x11 Rust bindings")
(description

base-commit: fb9549164520ad993c2fbbaedc899844d57baabc
--
2.41.0
Sharlatan Hellseher wrote 11 months ago
(address . 70053-done@debbugs.gnu.org)
87le60n9bh.fsf@gmail.com
Pushed as 423ca234cbd7b4902fd2a3fbc089a6fd57ed5583 to master.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmYHEhIACgkQdtcnv/Ys
0rXbAhAArfbSpjA6aKC/XJqeJ25tKBPav0RLNei4DIYMWq406aFRRDh87qzfUHM1
r62J53zauLbALy7LjJU5bjqSCvN9DsNKtVB0izK2vviSHXDK5DIqSVSeuZhx46Gf
SB3xKaZhJsjpt/E6cCvOy6J2bLjCYjuCeV0nb5JAglPKdvgMYrP+5u0RjeRISmXx
jP3ysR77/o6f6nkKfdZYMEsWiCtZ512lTwNUy0jesSHVmxKJSQLB75ydJPkkiW85
sot9rUHlkINRm1u5eozL4IptNg6QmnA0gVqIgqY9yihggg9nMVf2FlsNEjCTBZH2
D1FRjQ5YeN9BtCykOIEIr6jfQbtkwWBIOaOk7x1/aTSe5H1p2XVt4/fCoc13DSw1
0FkK70rZEYaMRCY5Mw9/W1GCMN6YArRj2XzEC16QBSKS3Noxbj+wKKHGmaBa/h01
dRavBzDB/ar4ofXh11KvCLREZjOlZTxGPMMbbE5o04JT3ikK+4pcrtlY+WM7AGnV
NzgRDpkTYz66YSp6cgW9AI4x4ZfTgqigLK0nZD8qLo5uDtylu7oOb98bJlf7Kem9
gru92ABW5tHRaNnAuhDrWK2SuxW7nPYfu1J4wkEobCZt7aATVL6kzstLT6mywWQS
BztNnvEitFZjZb/Ccz5TSq4VaubdlTu6n9GQpC/FXlgpRGjvyaY=
=STz7
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70053@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70053
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help