nafkhamdc wrote 11 months ago
(address . guix-patches@gnu.org)(name . nafkhamdc)(address . navid.afkhami@mdc-berlin.de)
* gnu/packages/python-check.scm (python-pytest-testmon): New variable.
Change-Id: Ia2e6034781898c04bd766145e0352060a975d479
---
gnu/packages/python-check.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)
Toggle diff (37 lines)
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 51a38bbcbe..4f710f13c5 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1093,6 +1093,26 @@ (define-public python-re-assert
simpler.")
(license license:expat)))
+(define-public python-pytest-testmon
+ (package
+ (name "python-pytest-testmon")
+ (version "2.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-testmon" version))
+ (sha256
+ (base32 "166snmcqv3mi0jlhshjlm5387i0gxmpm7m2cwmp3169dwhyjrglf"))))
+ (build-system pyproject-build-system)
+ (arguments
+ `(#:tests? #f)) ;No tests in PyPi tarball.
+ (native-inputs (list python-coverage python-pytest))
+ (home-page "https://github.com/tarpas/pytest-testmon")
+ (synopsis "Selects tests affected by changed files and methods")
+ (description
+ "This plug-in auto-selects and reruns tests impacted by recent changes.")
+ (license license:expat)))
+
(define-public python-pytest-trio
(package
(name "python-pytest-trio")
base-commit: 0e8f7ee3a95011dd9ebdc99e0f3b754160524b5d
prerequisite-patch-id: d26b189d1487d0d6a234a8197c5892f1e179e5f5
prerequisite-patch-id: 3cb34404c868aab6f273aa4342ac7266fc82457f
--
2.34.1