(name . bug-guix)(address . bug-guix@gnu.org)
Hello,
I get an error message when trying to `guix pull` a channel from a private git repository or when trying to `guix build` a package from a private git repository
Previously it worked great up until a few days ago. I have tested it on multiple machines and get the same error, as well as for private repositories hosted on gitlab and github.
This is the error message I get when I pull (for build it is essentially the same)
atte@beryllium:~$ guix pull
Updating channel 'guix-test' from Git repository at 'git@github.com:Blixodus/guix-test.git'...
guix pull: error: Git error: failed to set hostkey preference: The requested method(s) are not currently supported
And this is how I define channels in .config/guix/channels.scm, with a url to a private git repository by ssh
(list (channel
(name 'guix-test)
(url "git@github.com:Blixodus/guix-test.git")
(branch "main")))
Atte Torri