[PATCH] gnu: Add python-icecream.

  • Done
  • quality assurance status badge
Details
2 participants
  • nafkhamdc
  • Ricardo Wurmus
Owner
unassigned
Submitted by
nafkhamdc
Severity
normal

Debbugs page

nafkhamdc wrote 12 months ago
(address . guix-patches@gnu.org)(name . nafkhamdc)(address . navid.afkhami@mdc-berlin.de)
525c4936db9dcd47ccc7e559aaf4d0c5ef804692.1711451016.git.navid.afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (python-icecream): New variable.

Change-Id: I866d0ce591a1b81fdd7e0ee706cb8e9791e70c49
---
gnu/packages/bioinformatics.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index d18d5d8611..5a07857202 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -17928,6 +17928,33 @@ (define-public python-iced
efficiently.")
(license license:bsd-3)))
+(define-public python-icecream
+ (package
+ (name "python-icecream")
+ (version "2.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "icecream" version))
+ (sha256
+ (base32 "1pj9kf7lwm799wppvngg3sndi0qf13iq33yhl59n3hsf6z1sg90a"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags '(list "-k"
+ ;; These tests are failing due to a bug.
+ (string-append "not testEnableDisabl"
+ " and not testSingledispatchArgumentToString"))))
+ (propagated-inputs (list python-asttokens python-colorama python-executing
+ python-pygments))
+ (native-inputs (list python-hypothesis python-pytest))
+ (home-page "https://github.com/gruns/icecream")
+ (synopsis
+ "Single function call to debug variables, expressions, and program execution")
+ (description
+ "This tool debugs variables, expressions, and program execution with one call.")
+ (license license:expat)))
+
(define-public python-hic2cool
(package
(name "python-hic2cool")

base-commit: 7dfb3155fc4dd37bea93a8704c37e4aff87e5013
--
2.34.1
Ricardo Wurmus wrote 12 months ago
gnu: Add python-icecream.
(address . 70011-done@debbugs.gnu.org)
87msqjbw00.fsf@elephly.net
Thanks for the patch! I moved it to python-xyz.scm and added a comment
referencing the upstream issue.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70011@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70011
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help