[PATCH] gnu: Add python-pytest-relaxed.

  • Done
  • quality assurance status badge
Details
2 participants
  • nafkhamdc
  • Ricardo Wurmus
Owner
unassigned
Submitted by
nafkhamdc
Severity
normal

Debbugs page

nafkhamdc wrote 12 months ago
(address . guix-patches@gnu.org)(name . nafkhamdc)(address . navid.afkhami@mdc-berlin.de)
f6b40114030c86411c3f7577e101cce0ed36b21c.1711455513.git.navid.afkhami@mdc-berlin.de
* gnu/packages/check.scm (python-pytest-relaxed): New variable.

Change-Id: I9c506fe6a6586c87d72775a0567fd3c45ba03568
---
gnu/packages/check.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index bd1f2d1b65..0858eb99f4 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1353,6 +1353,27 @@ (define-public python-pytest-cov
supports coverage of subprocesses.")
(license license:expat)))
+(define-public python-pytest-relaxed
+ (package
+ (name "python-pytest-relaxed")
+ (version "2.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bitprophet/pytest-relaxed")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1lnnkadfr390i30209gpl80nymc20pmamvxjhd11gvf4d6f54n7x"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-decorator))
+ (native-inputs (list python-pytest))
+ (home-page "https://github.com/bitprophet/pytest-relaxed")
+ (synopsis "Relaxed test discovery for pytest")
+ (description "This package provides provides relaxed test discovery for pytest.")
+ (license license:bsd-2)))
+
(define-public python-pytest-dotenv
(package
(name "python-pytest-dotenv")

base-commit: 7dfb3155fc4dd37bea93a8704c37e4aff87e5013
prerequisite-patch-id: 453db14a52ef61a9ff789b103b69938d14593fea
--
2.34.1
Ricardo Wurmus wrote 12 months ago
gnu: Add python-pytest-relaxed.
(address . 70009-done@debbugs.gnu.org)
87il17bvz6.fsf@elephly.net
Applied, thank you!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 70009@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 70009
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help