[PATCH] gnu: Add bash-unit.

  • Open
  • quality assurance status badge
Details
2 participants
  • chris
  • jgart
Owner
unassigned
Submitted by
chris
Severity
normal
C
(address . guix-patches@gnu.org)(name . chris)(address . chris@bumblehead.com)
dfbe855483107af9b78bed34ac64eb80bcc43993.1711269603.git.chris@bumblehead.com
* (bash-unit): New variable.

Change-Id: I0952538a456e2ce5f6bbb94c0fa8c1b467606835
---
gnu/packages/bash.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/bash.scm b/gnu/packages/bash.scm
index bb3359d5d1..17a371d385 100644
--- a/gnu/packages/bash.scm
+++ b/gnu/packages/bash.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2021 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2024 chris <chris@bumblehead.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -47,6 +48,7 @@ (define-module (gnu packages bash)
#:use-module (guix monads)
#:use-module (guix store)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system copy)
#:use-module (guix build-system trivial)
#:autoload (guix gnupg) (gnupg-verify*)
#:autoload (guix base32) (bytevector->nix-base32-string)
@@ -481,3 +483,33 @@ (define-public blesh
which replaces the default GNU Readline. It adds syntax highlighting, auto
suggestions, vim modes, and more to Bash interactive sessions.")
(license license:bsd-3)))
+
+(define-public bash-unit
+ (package
+ (name "bash-unit")
+ (version "2.3.1")
+ (home-page "https://github.com/pgrange/bash_unit")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "16vaw9lc7g43g9va1kxbzxqs6b1mawsj4gqi8izz9km3dkbn3pli"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan '(("bash_unit" "bin/"))
+ #:phases (modify-phases %standard-phases
+ (add-before 'install 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "./bash_unit" "tests/test_core.sh")) #t)))))
+ (inputs (list bash-minimal))
+ (synopsis "Bash unit testing framework")
+ (description
+ "@command{bash_unit} allows you to write unit tests, run them and, in case of
+ failure, display the stack trace with source file and line number indications
+ to locate the problem.")
+ (license license:gpl3+)))

base-commit: 28bc0e870b4d48b8e3e773382bb0e999df2e3611
--
2.41.0
J
(address . 69975@debbugs.gnu.org)(name . chris)(address . chris@bumblehead.com)
87ttgy8iai.fsf@syn-2600-6c98-a540-001b-0000-0000-0000-08b5.biz6.spectrum.com
hi chris,

this patch does not apply any longer. i can take a look if you are able
to find the time to send a new patch rebased on the latest master that
applies
--
all the best,
jgart
C
[PATCH] gnu: Add bash-unit.
(address . 69975@debbugs.gnu.org)(name . chris)(address . chris@bumblehead.com)
ce881eaec681a57431d96dd37790b64a07b71b7b.1720768992.git.chris@bumblehead.com
* gnu/packages/bash.scm (bash-unit): New variable.

Change-Id: Ic4185a2364922b03efe7f528e474ac9e71cbf66c
---
gnu/packages/bash.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/bash.scm b/gnu/packages/bash.scm
index 9ecec0a484..a497c77b67 100644
--- a/gnu/packages/bash.scm
+++ b/gnu/packages/bash.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2021 Marius Bakke <marius@gnu.org>
;;; Copyright © 2024 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2024 chris <chris@bumblehead.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -48,6 +49,7 @@ (define-module (gnu packages bash)
#:use-module (guix monads)
#:use-module (guix store)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system copy)
#:use-module (guix build-system trivial)
#:autoload (guix gnupg) (gnupg-verify*)
#:autoload (guix base32) (bytevector->nix-base32-string)
@@ -487,3 +489,33 @@ (define-public blesh
which replaces the default GNU Readline. It adds syntax highlighting, auto
suggestions, vim modes, and more to Bash interactive sessions.")
(license license:bsd-3)))
+
+(define-public bash-unit
+ (package
+ (name "bash-unit")
+ (version "2.3.1")
+ (home-page "https://github.com/pgrange/bash_unit")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "16vaw9lc7g43g9va1kxbzxqs6b1mawsj4gqi8izz9km3dkbn3pli"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan '(("bash_unit" "bin/"))
+ #:phases (modify-phases %standard-phases
+ (add-before 'install 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "./bash_unit" "tests/test_core.sh")) #t)))))
+ (inputs (list bash-minimal))
+ (synopsis "Bash unit testing framework")
+ (description
+ "@command{bash_unit} allows you to write unit tests, run them and, in case of
+ failure, display the stack trace with source file and line number indications
+ to locate the problem.")
+ (license license:gpl3+)))

base-commit: 2d6a3799fcda5c017f653c6e96b91964b07a7ee0
--
2.45.2
C
(address . 69975@debbugs.gnu.org)
ZpDa5C0Ud3oDUQua@guix-xps
Toggle quote (2 lines)
> can take a look if you are able to find the time to send a new patch rebased on the latest master

An updated patch is submitted
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 69975@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69975
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch