[PATCH] gnu: Add bash-unit.

  • Done
  • quality assurance status badge
Details
3 participants
  • chris
  • Greg Hogan
  • jgart
Owner
unassigned
Submitted by
chris
Severity
normal

Debbugs page

chris wrote 12 months ago
(address . guix-patches@gnu.org)(name . chris)(address . chris@bumblehead.com)
dfbe855483107af9b78bed34ac64eb80bcc43993.1711269603.git.chris@bumblehead.com
* (bash-unit): New variable.

Change-Id: I0952538a456e2ce5f6bbb94c0fa8c1b467606835
---
gnu/packages/bash.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/bash.scm b/gnu/packages/bash.scm
index bb3359d5d1..17a371d385 100644
--- a/gnu/packages/bash.scm
+++ b/gnu/packages/bash.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2021 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2024 chris <chris@bumblehead.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -47,6 +48,7 @@ (define-module (gnu packages bash)
#:use-module (guix monads)
#:use-module (guix store)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system copy)
#:use-module (guix build-system trivial)
#:autoload (guix gnupg) (gnupg-verify*)
#:autoload (guix base32) (bytevector->nix-base32-string)
@@ -481,3 +483,33 @@ (define-public blesh
which replaces the default GNU Readline. It adds syntax highlighting, auto
suggestions, vim modes, and more to Bash interactive sessions.")
(license license:bsd-3)))
+
+(define-public bash-unit
+ (package
+ (name "bash-unit")
+ (version "2.3.1")
+ (home-page "https://github.com/pgrange/bash_unit")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "16vaw9lc7g43g9va1kxbzxqs6b1mawsj4gqi8izz9km3dkbn3pli"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan '(("bash_unit" "bin/"))
+ #:phases (modify-phases %standard-phases
+ (add-before 'install 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "./bash_unit" "tests/test_core.sh")) #t)))))
+ (inputs (list bash-minimal))
+ (synopsis "Bash unit testing framework")
+ (description
+ "@command{bash_unit} allows you to write unit tests, run them and, in case of
+ failure, display the stack trace with source file and line number indications
+ to locate the problem.")
+ (license license:gpl3+)))

base-commit: 28bc0e870b4d48b8e3e773382bb0e999df2e3611
--
2.41.0
jgart wrote 8 months ago
(address . 69975@debbugs.gnu.org)(name . chris)(address . chris@bumblehead.com)
87ttgy8iai.fsf@syn-2600-6c98-a540-001b-0000-0000-0000-08b5.biz6.spectrum.com
hi chris,

this patch does not apply any longer. i can take a look if you are able
to find the time to send a new patch rebased on the latest master that
applies
--
all the best,
jgart
chris wrote 8 months ago
[PATCH] gnu: Add bash-unit.
(address . 69975@debbugs.gnu.org)(name . chris)(address . chris@bumblehead.com)
ce881eaec681a57431d96dd37790b64a07b71b7b.1720768992.git.chris@bumblehead.com
* gnu/packages/bash.scm (bash-unit): New variable.

Change-Id: Ic4185a2364922b03efe7f528e474ac9e71cbf66c
---
gnu/packages/bash.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/bash.scm b/gnu/packages/bash.scm
index 9ecec0a484..a497c77b67 100644
--- a/gnu/packages/bash.scm
+++ b/gnu/packages/bash.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2021 Marius Bakke <marius@gnu.org>
;;; Copyright © 2024 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2024 chris <chris@bumblehead.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -48,6 +49,7 @@ (define-module (gnu packages bash)
#:use-module (guix monads)
#:use-module (guix store)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system copy)
#:use-module (guix build-system trivial)
#:autoload (guix gnupg) (gnupg-verify*)
#:autoload (guix base32) (bytevector->nix-base32-string)
@@ -487,3 +489,33 @@ (define-public blesh
which replaces the default GNU Readline. It adds syntax highlighting, auto
suggestions, vim modes, and more to Bash interactive sessions.")
(license license:bsd-3)))
+
+(define-public bash-unit
+ (package
+ (name "bash-unit")
+ (version "2.3.1")
+ (home-page "https://github.com/pgrange/bash_unit")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "16vaw9lc7g43g9va1kxbzxqs6b1mawsj4gqi8izz9km3dkbn3pli"))))
+ (build-system copy-build-system)
+ (arguments
+ `(#:install-plan '(("bash_unit" "bin/"))
+ #:phases (modify-phases %standard-phases
+ (add-before 'install 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "./bash_unit" "tests/test_core.sh")) #t)))))
+ (inputs (list bash-minimal))
+ (synopsis "Bash unit testing framework")
+ (description
+ "@command{bash_unit} allows you to write unit tests, run them and, in case of
+ failure, display the stack trace with source file and line number indications
+ to locate the problem.")
+ (license license:gpl3+)))

base-commit: 2d6a3799fcda5c017f653c6e96b91964b07a7ee0
--
2.45.2
chris wrote 8 months ago
(address . 69975@debbugs.gnu.org)(name . chris)(address . chris@bumblehead.com)(name . jgart)(address . jgart@dismail.de)
ZpDa5C0Ud3oDUQua@guix-xps
Toggle quote (2 lines)
> can take a look if you are able to find the time to send a new patch rebased on the latest master

An updated patch is submitted
Greg Hogan wrote 2 days ago
Re: [bug#69975] [PATCH] gnu: Add bash-unit.
(name . chris)(address . chris@bumblehead.com)(address . 69975-done@debbugs.gnu.org)(name . jgart)(address . jgart@dismail.de)
CA+3U0Z=qM4dONvM0s04z3u9gCGWAbdRNvkwAyAuiDoGaqLZfxQ@mail.gmail.com
On Fri, Jul 12, 2024 at 3:30 AM chris <chris@bumblehead.com> wrote:
Toggle quote (5 lines)
>
> > can take a look if you are able to find the time to send a new patch rebased on the latest master
>
> An updated patch is submitted

Bumped the version to 2.3.2 and pushed as
338867d01cf362679cbed37e93ed2527664a9104.

Greg
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 69975@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 69975
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help