(address . guix-patches@gnu.org)(address . raghavgururajan@disroot.org)
From: Sören Tempel <soeren@soeren-tempel.net>
The --enable-gnuplot option was added previously in Guix Git commit
711316946fa84b55480681588f2cc23811c69784. The option causes any program
linked against the pixman library to constantly write gnuplot input to
standard output. I believe this is not desirable in the common case and,
in fact, this option is intended for testing purposes by upstream [1]. I
don't think that it should be enabled by default in a context of a
distribution.
I noticed this while working porting a Wayland status bar, which uses
pixman, to Guix and wondering why the status bar process was constantly
writing gnuplot input to standard output.
* gnu/packages/xdisorg.scm (pixman): Disable --enable-gnuplot.
---
gnu/packages/xdisorg.scm | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
Toggle diff (16 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index be8623666f..c85529520d 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -720,8 +720,7 @@ (define-public pixman
`(#:configure-flags
(list
"--disable-static"
- "--enable-timers"
- "--enable-gnuplot")))
+ "--enable-timers")))
(native-inputs
(list pkg-config))
(inputs
base-commit: f285a968b1219ae748fcab918b17285e741422c2